Firefox reports a secure connection without existing certificate

When i click on the lock icon in the address bar, nothing happens (I would expect to see the encryption and certificate, but no widget opens). When I right-click into the… (மேலும் படிக்க)

When i click on the lock icon in the address bar, nothing happens (I would expect to see the encryption and certificate, but no widget opens). When I right-click into the page and select "View Page Info", "Security", "View Certificate", no certificate exists. Only generic info is shown (Servers+Authorities). Also an error is reported in the system log, confirming that no certificate exists: JavaScript error: chrome://browser/content/browser-siteIdentity.js, line 642: TypeError: issuerCert is undefined

Questions:

  • Why does Firefox show the lock icon while no certificate exists?
  • How does Firefox establish a secure connection without having a certificate? (From my understanding a certificate is needed for TLS to work.)

Version used: Firefox 78.12.0esr ('Mozilla/5.0 (X11; FreeBSD amd64; rv:78.0) Gecko/20100101 Firefox/78.0'), no add-ons or plugins.

Asked by pmc1 1 வாரத்திற்கு முன்பு

Last reply by pmc1 2 நாட்கள் முன்பு

The bookmarks menu in Firefox stopped scrolling

After the 90.0.2 update, the bookmarks menu no longer scrolls with the center wheel of my mouse. The center wheel scrolls properly in my emails, on webpages, everywhere e… (மேலும் படிக்க)

After the 90.0.2 update, the bookmarks menu no longer scrolls with the center wheel of my mouse. The center wheel scrolls properly in my emails, on webpages, everywhere else but the in the bookmarks. I have to use the up or down arrows to scroll through them, and it's a royal pain because I have so many bookmarks.

Asked by zx9r170 2 மாதங்களுக்கு முன்பு

Last reply by zx9r170 3 நாட்கள் முன்பு

Google stops working in Firefox (mail, drive, classroom, etc.)

In my firefox (up to date) I've started getting errors that google is not connecting, or emails opens blank, or drive opens a blank screen, or classroom assignments open … (மேலும் படிக்க)

In my firefox (up to date) I've started getting errors that google is not connecting, or emails opens blank, or drive opens a blank screen, or classroom assignments open a blank window.

A friend suggested that I use a private tab, and everything works if I use a private tab.

Helps please.

Asked by Mrs.M. 1 மாதத்திற்கு முன்பு

Last reply by Mrs.M. 6 மணி நேரத்திற்கு முன்பு

Selective Blocking of JWplayer by Site

I would like to block some sites (entire domains) from injecting JWPlayer iframes while I'm trying to read the site. (The Hill, https://thehill.com, is particularly annoy… (மேலும் படிக்க)

I would like to block some sites (entire domains) from injecting JWPlayer iframes while I'm trying to read the site. (The Hill, https://thehill.com, is particularly annoying with this.) However, I need to see content that some other sites embed in JWPlayer, so I can't use the nuclear option of blocking the cdn for jwplayer in my hosts file.

Are there any settings or add-ons available that allow by-domain blocking of JWPlayer? (I don't care if it's a "whitelist" or "blacklist" approach, so long as I can manually determine which sites play and which don't.)

Asked by Jaws 3 நாட்கள் முன்பு

Last reply by Jaws 2 நாட்கள் முன்பு

Error on every page

I keep getting errors on pages like Secure Connection Failed An error occurred during a connection to www.amazon.com. SSL received a malformed Alert record. Error code: S… (மேலும் படிக்க)

I keep getting errors on pages like Secure Connection Failed

An error occurred during a connection to www.amazon.com. SSL received a malformed Alert record.

Error code: SSL_ERROR_RX_MALFORMED_ALERT

I have HTTPS only mode turned off but it keeps setting everything to https.

{

 "application": {
   "name": "Firefox",
   "osVersion": "Windows_NT 10.0 19043",
   "version": "92.0.1",
   "buildID": "20210922161155",
   "distributionID": "",
   "userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:92.0) Gecko/20100101 Firefox/92.0",
   "safeMode": false,
   "updateChannel": "release",
   "supportURL": "https://support.mozilla.org/1/firefox/92.0.1/WINNT/en-US/",
   "osTheme": "",
   "numTotalWindows": 1,
   "numFissionWindows": 0,
   "numRemoteWindows": 1,
   "launcherProcessState": 0,
   "fissionAutoStart": false,
   "fissionDecisionStatus": "disabledByDefault",
   "remoteAutoStart": true,
   "policiesStatus": 1,
   "keyLocationServiceGoogleFound": true,
   "keySafebrowsingGoogleFound": true,
   "keyMozillaFound": true
 },
 "securitySoftware": {
   "registeredAntiVirus": "Avast Antivirus",
   "registeredAntiSpyware": "",
   "registeredFirewall": "Avast Antivirus"
 },
 "processes": {
   "remoteTypes": {
     "web": 5,
     "extension": 1,
     "privilegedabout": 1,
     "prealloc": 1,
     "gpu": 1
   },
   "maxWebContentProcesses": 8
 },
 "environmentVariables": {
   "MOZ_CRASHREPORTER_DATA_DIRECTORY": "C:\\Users\\madwo\\AppData\\Roaming\\Mozilla\\Firefox\\Crash Reports",
   "MOZ_CRASHREPORTER_EVENTS_DIRECTORY": "C:\\Users\\madwo\\AppData\\Roaming\\Mozilla\\Firefox\\Crash Reports\\events",
   "MOZ_CRASHREPORTER_PING_DIRECTORY": "C:\\Users\\madwo\\AppData\\Roaming\\Mozilla\\Firefox\\Pending Pings",
   "MOZ_CRASHREPORTER_RESTART_ARG_0": "C:\\Program Files\\Mozilla Firefox\\firefox.exe",
   "MOZ_CRASHREPORTER_STRINGS_OVERRIDE": "C:\\Program Files\\Mozilla Firefox\\browser\\crashreporter-override.ini"
 },
 "lockedPreferences": {
   "fission.autostart.session": false,
   "security.enterprise_roots.enabled": true
 },
 "media": {
   "currentAudioBackend": "wasapi",
   "currentMaxAudioChannels": 2,
   "currentPreferredSampleRate": 48000,
   "audioOutputDevices": [
     
 "addons": [
   {
     "name": "AdBlocker for YouTube™",
     "type": "extension",
     "version": "0.3.4",
     "isActive": true,
     "id": "jid1-q4sG8pYhq8KGHs@jetpack"
   },
   {
     "name": "AdBlocker Ultimate",
     "type": "extension",
     "version": "3.7.11",
     "isActive": true,
     "id": "adblockultimate@adblockultimate.net"
   },
   {
     "name": "Amazon.com",
     "type": "extension",
     "version": "1.3",
     "isActive": true,
     "id": "amazondotcom@search.mozilla.org"
   },
   {
     "name": "Avast AntiTrack Premium",
     "type": "extension",
     "version": "1.6",
     "isActive": true,
     "id": "antitrack@avast.com"
   },
   {
     "name": "Bing",
     "type": "extension",
     "version": "1.3",
     "isActive": true,
     "id": "bing@search.mozilla.org"
   },
   {
     "name": "DuckDuckGo",
     "type": "extension",
     "version": "1.1",
     "isActive": true,
     "id": "ddg@search.mozilla.org"
   },
   {
     "name": "eBay",
     "type": "extension",
     "version": "1.3",
     "isActive": true,
     "id": "ebay@search.mozilla.org"
   },
   {
     "name": "Google",
     "type": "extension",
     "version": "1.1",
     "isActive": true,
     "id": "google@search.mozilla.org"
   },
   {
     "name": "Hoxx VPN Proxy",
     "type": "extension",
     "version": "3.11.0",
     "isActive": true,
     "id": "@hoxx-vpn"
   },
   {
     "name": "Touch VPN - Secure and unlimited VPN proxy",
     "type": "extension",
     "version": "4.2.1",
     "isActive": true,
     "id": "touch-vpn@anchorfree.com"
   },
   {
     "name": "Video Downloader Prime",
     "type": "extension",
     "version": "0.2.5",
     "isActive": true,
     "id": "jid1-i6dUGvCrz2WZu8@jetpack"
   },
   {
     "name": "Video DownloadHelper",
     "type": "extension",
     "version": "7.6.0",
     "isActive": true,
     "id": "{b9db16a4-6edc-47ec-a1f4-b86292ed211d}"
   },
   {
     "name": "Watch2Gether",
     "type": "extension",
     "version": "8.1",
     "isActive": true,
     "id": "{6ea0a676-b3ef-48aa-b23d-24c8876945fb}"
   },
   {
     "name": "Wikipedia (en)",
     "type": "extension",
     "version": "1.1",
     "isActive": true,
     "id": "wikipedia@search.mozilla.org"
   }
 ],
 "features": [
   {
     "name": "DoH Roll-Out",
     "version": "2.0.0",
     "id": "doh-rollout@mozilla.org"
   },
   {
     "name": "Firefox Screenshots",
     "version": "39.0.1",
     "id": "screenshots@mozilla.org"
   },
   {
     "name": "Form Autofill",
     "version": "1.0.1",
     "id": "formautofill@mozilla.org"
   },
   {
     "name": "Picture-In-Picture",
     "version": "1.0.0",
     "id": "pictureinpicture@mozilla.org"
   },
   {
     "name": "Web Compatibility Interventions",
     "version": "25.4.0",
     "id": "webcompat@mozilla.org"
   },
   {
     "name": "WebCompat Reporter",
     "version": "1.4.2",
     "id": "webcompat-reporter@mozilla.org"
   }
 ],
 "normandy": {
   "addonStudies": [],
   "prefRollouts": [],
   "prefStudies": [],
   "nimbusExperiments": [],
   "remoteConfigs": []
 },
 "modifiedPreferences": {}

}

Asked by ijones_fall12 2 நாட்கள் முன்பு

Last reply by ijones_fall12 17 மணி நேரத்திற்கு முன்பு

Firefox not loading Facebook images

Hello, I am at a loss to trying to fix a problem after extensive troubleshooting. When I am on Facebook for about five minutes, Firefox stops loading most images. This on… (மேலும் படிக்க)

Hello, I am at a loss to trying to fix a problem after extensive troubleshooting. When I am on Facebook for about five minutes, Firefox stops loading most images. This only occurs with Firefox, not Safari or Chrome. And it only occurs with Facebook and Instagram, which is owned and run by Facebook. I have to restart Firefox to get images back and then after five minutes or so, it happens again every time. Can anyone help? This is driving me crazy!

Thank you

Asked by lkutchermusic 1 வாரத்திற்கு முன்பு

Last reply by lkutchermusic 6 நாட்கள் முன்பு

Locked out of Firefox sync, formal request to delete personal data best solution?

Hi, it's been a while since I used Firefox and I don't seem to have a way of getting back into Sync with my primary e-mail address since I can't find my backup code. Who … (மேலும் படிக்க)

Hi, it's been a while since I used Firefox and I don't seem to have a way of getting back into Sync with my primary e-mail address since I can't find my backup code. Who do I contact to either get my account deleted so I can start again, or get an account reset option set to my e-mail address? Ultimately none of my devices are logged in, and I cannot find my backup code.

The impression I have so far is that you have to sign in with another e-mail account (which is what I have done now), but this is not the e-mail account I want to use.

If Mozilla are storing my name and contact details for the sign in, would the best route be a formal request for deletion of personal data?

Thanks

Asked by jim.clow 3 நாட்கள் முன்பு

Last reply by jim.clow 1 நாள் முன்பு

Bookmarks menu slow to load/respond since last update

Since the last Firefox update (92.0.1 64-bit), my bookmarks menu is slow to load, and also slow for navigating. It's slow to load the list when I open Bookmarks tab. And … (மேலும் படிக்க)

Since the last Firefox update (92.0.1 64-bit), my bookmarks menu is slow to load, and also slow for navigating. It's slow to load the list when I open Bookmarks tab. And it's slow when I move my cursor up/down the bookmarks, it takes a bit for the highlighted bookmarks to catch up. It's very odd. I don't really have a lot of Bookmarks, I would guess ~500 total. Plus I am using plenty of RAM with Windows 7 on a SSD.

Bookmarks loading and accessing was lightning-fast prior to this last Firefox update. I have searched on this Forum for answers, plus Google.... no luck yet. I'm sure there is an answer. Does anyone have it?? Thanks for any help. Dave F.

PS - I LOVE Firefox. Many thanks to Mozilla for a terrific product! ;-)

Asked by Chevy-SS 1 நாள் முன்பு

Last reply by Chevy-SS 7 மணி நேரத்திற்கு முன்பு

Changes in Firefox from Version 86 to 90, 92

Apologies for asking this here, but I've done the Google and can't find an answer. Background: I keep 2-3 Firefox versions and profiles on my computer. The software is in… (மேலும் படிக்க)

Apologies for asking this here, but I've done the Google and can't find an answer.

Background: I keep 2-3 Firefox versions and profiles on my computer. The software is in, for example, directories FFox82, FFox84, FFox86 The profiles are in, for example, directories Firefox82, Firefox84, Firefox86 (The software and profiles are on different drives.)

When I do an upgrade, I copy the newest software to a new directory and rename it (e.g., FFox92 - so now there are 4 sw directories) Then I copy the newest profile directory and give it a corresponding name (e.g., Firefox92 - so now there are 4 profile directories). I install the new version to its directory and thenlaunch with a -p option. Then I create a new profile and point it to the corresponding folder. Then I launch the new version with the -p option pointing to the new profile directory.

This has worked for decades.

But I just tried it with Firefox 90 and Firefox 92 and NO GO. It acts as if I've never used Firefox before. No apps, no toolbars, no bookmarks, nothing.

What is going on? Am I stuck on Firefox86 for the rest of the century?

And, please, don't tell me how wonderful these new versions are and I should simply accept the change. I have a virtual lifetime invested in the toolbars, extensions and bookmarks on my computer.

I simply want to know if there is a fix and, if so, what it is.

Asked by RemySecor 1 வாரத்திற்கு முன்பு

Last reply by RemySecor 5 நாட்கள் முன்பு

Media Key functionality intermittent

Periodically Firefox will stop accepting media key input from my keyboard, the media keys continue to function for Chrome (neither are open at the same time, when functio… (மேலும் படிக்க)

Periodically Firefox will stop accepting media key input from my keyboard, the media keys continue to function for Chrome (neither are open at the same time, when functionality fails in Firefox, I open chrome to test if the keys are working) media.hardwaremediakeys.enabled is set to true, have swapped it to false and back, restarted, double and triple checked the physical media keys. Sometimes Firefox will just accept the media key input, and sometimes it won't

Asked by takashi1532 1 மாதத்திற்கு முன்பு

Last reply by takashi1532 2 நாட்கள் முன்பு

Ubuntu Snap problem with Firejail

I read that Firefox will using the Snap version by default on Ubuntu 21.10 and beyond. Will the non-Snap version still be available in lets say Ubuntu 22.04 and beyond? T… (மேலும் படிக்க)

I read that Firefox will using the Snap version by default on Ubuntu 21.10 and beyond. Will the non-Snap version still be available in lets say Ubuntu 22.04 and beyond? The reason I ask is because I use Firejail to sandbox Firefox and Firejail doesn't work with Snaps and yes I know that Snaps and Flatpacks both sandbox apps but I prefer Firejail because of the Private Home profile (nothing is saved in this profile settings, bookmarks, add-ons etc) its way more secure than the sandbox offered by a Snap.

Asked by Baldape 5 நாட்கள் முன்பு

Last reply by Baldape 23 மணி நேரத்திற்கு முன்பு

N-th tab in firefox doesn't load

Hiya, I'm having a minor inconvenience with firefox 91.0.2 for a few months now. It's popped up a few months ago and hasn't resolved itself in between updates. I'm guilt… (மேலும் படிக்க)

Hiya,


I'm having a minor inconvenience with firefox 91.0.2 for a few months now. It's popped up a few months ago and hasn't resolved itself in between updates.

I'm guilty of having many (well over 20) tabs open at the same time and around the 20th or 30th tab even, usually one of the (newly opened) tabs, simply never loads. If I open the same link in another tab, the link (any url) does load. See the screencap below.

This is on a windows 64 bit machine OS build: 19043.1165 (21H1) Windows Feature Experience Pack 120.2212.3530.0

I'm running Norton 360 Antivirus software.

Will try running in safe mode, to see if it still happens and confirm in a reply to this message.

Hoping you guys might have some suggestions.

BTW: https://support.mozilla.org/en-US/questions/1317506 is probably the same problem, unfortunately the thread has been archived. This one: https://support.mozilla.org/en-US/questions/1285104 also seems similar.

Asked by Mediationpraktijk De Witte Vlag 2 வாரங்களுக்கு முன்பு

Last reply by Mediationpraktijk De Witte Vlag 4 நாட்கள் முன்பு

White Bar appears above all firefox windows when Firefox is maximized, need help getting rid of it.

I have a strange white bar that appears above the Firefox window at all times, but it's only visible on one of my other monitors, which is positioned above the monitor Fi… (மேலும் படிக்க)

I have a strange white bar that appears above the Firefox window at all times, but it's only visible on one of my other monitors, which is positioned above the monitor Firefox is on. I've tried starting firefox with all my extensions and themes disabled, and all that did was make the bar black instead of white.

This lead me to believe it was the Title bar. However, that's currently disabled. When I enable the title bar, the white bar disappears, but then I'm left with the title bar (which I do not want).

Is there a way I can have the Title bar disabled and not have this bar appear?

Worth noting I'm using the Lepton UI mod (which doesn't seem to be responsible for this) and DisplayFusion (which I thought would have been responsible for this, however I cannot be sure). Running Win 10.

Asked by Shigbeard 4 நாட்கள் முன்பு

Last reply by Shigbeard 4 நாட்கள் முன்பு

MY site not Working On Mozilla

Hey there! my site is over all good i'm open my site in mozilla but got Error by Mozilla blocked My site Here's site Url > [link hidden] Any Solution or please Gui… (மேலும் படிக்க)

Hey there! my site is over all good i'm open my site in mozilla but got Error by Mozilla blocked My site Here's site Url > [link hidden] Any Solution or please Guide me

Asked by zs1558743 1 வாரத்திற்கு முன்பு

Last reply by zs1558743 4 நாட்கள் முன்பு

LINKS DO NOT WORK

LINKS IN THIS SITE DO NOT WORK. THE OWNERS HAVE TESTED IT WITH FIREFOX AND ALL OK WHAT IS WRONG WITH MY PC www.bidorbuy.co.za A SIMPLE NOT TECHNICAL ANSWER PLEASE. … (மேலும் படிக்க)

LINKS IN THIS SITE DO NOT WORK. THE OWNERS HAVE TESTED IT WITH FIREFOX AND ALL OK WHAT IS WRONG WITH MY PC

www.bidorbuy.co.za

A SIMPLE NOT TECHNICAL ANSWER PLEASE.

Asked by rod18 6 நாட்கள் முன்பு

Last reply by rod18 6 நாட்கள் முன்பு

Some YouTube videos aren't in sync with the audio

I'm having a problem with a couple videos where the video and audio aren't in sync. For example, the video in the first screenshot is only 2:30, yet when I play it, it se… (மேலும் படிக்க)

I'm having a problem with a couple videos where the video and audio aren't in sync. For example, the video in the first screenshot is only 2:30, yet when I play it, it seems to partially mimic the video in the second screenshot; it "extends" to 2:41, and it plays the video from the second video. However, it plays the audio from the first video and the progress bar still only goes to 2:30, yet the video keeps playing for another 11 seconds without any audio until the video from the second video ends. Seeking forward causes the different recommendations to pop up as if the video had ended normally.

I am using a MSI laptop on Windows 10. I have restarted my computer, cleared my cookies and cache, and updated Firefox to the latest version. This problem persists with all of my extensions disabled, and when logged in or out of YouTube (no matter the account) or in incognito mode. At first, I thought it had something to do with the video and/or channel, since the other video with the same problem was also uploaded by AmericanDadVEVO. When I tried watching the video in the first screenshot on Microsoft Edge (which I barely use and have no extensions on), however, it worked normally.

Any help would be appreciated! I really do not want to switch to another browser.

Asked by David_H23 2 வாரங்களுக்கு முன்பு

Last reply by David_H23 6 நாட்கள் முன்பு

Sometimes Quora.com will not run properly in a newly opened session. Other times it works perfectly.

Fairly regularly I go to the Quora.com site to answer questions others have asked. Perhaps in one in four times I launch Firefox browser and go to this site it will not r… (மேலும் படிக்க)

Fairly regularly I go to the Quora.com site to answer questions others have asked. Perhaps in one in four times I launch Firefox browser and go to this site it will not respond beyond the first page and eventually report that something on the page is slowing the browser. If this does not happen, everything works normally and very quickly.

The only way I can continue is to close the browser completely and relaunch. Even if I wait a minute or so, when I relaunch it tells me Firefox is already running and asks if I wish to close it. If I let it close the browser, the new launch normally works perfectly.

When the problem occurs, opening other tabs and closing the original one does not seem to make a difference. It still does not work properly.

I am not sure when this started, and I have only experienced this problem on this one site. When I have tried using the Chrome browser I have not seen this happening on this site. I don't like the Chrome browser but have it installed to allow streaming my screen to a Chromecast dongle.

The Firefox browser in the Windows 64-bit version 92.0.

This start happening a few weeks ago (it is now mid September 2021). I am not sure whether something has changed in Firefox or in the Quora site. I have seen this problem on both my Windows 8.1 Pro and Windows 10 Pro PCs.

Asked by str8chat 1 வாரத்திற்கு முன்பு

Last reply by str8chat 3 நாட்கள் முன்பு

Firefox 92, troubleshoot mode messed up my addons, trying to get them back

Someone in Bugzilla instructed me to use Troubleshoot Mode for a separate problem, so I did. After reverting back to normal mode, I find that my addons are gone. Then I… (மேலும் படிக்க)

Someone in Bugzilla instructed me to use Troubleshoot Mode for a separate problem, so I did. After reverting back to normal mode, I find that my addons are gone. Then I checked about:profiles. I find that one profile (default-release) has my tabs in normal colors (gray) and no addons, while another profile (default) has my addons, but the tabs are strangely white, which I don't want. How do I get the addons to appear while having normal tab color (gray)?

Asked by wkrp 2 நாட்கள் முன்பு

Last reply by wkrp 1 நாள் முன்பு

chosen primary password not working anymore...

A week ago I started using a primary password for FF. I learned it by heart, also copied it to my iPhone in a safe notation (I have access to the notation using my finger… (மேலும் படிக்க)

A week ago I started using a primary password for FF. I learned it by heart, also copied it to my iPhone in a safe notation (I have access to the notation using my finger print). It worked just fine for the first days. Today I tried to use the primary password again, in order to enter a website, but somehow FF denies me entrance, again and again. No spelling issues or missing characters, because I copy the primary password from my iPhone notation and paste it into the primary password field on my Mac. In FF Lockwise (on my iPhone) I can also still see my primary FF password, which is exactly the same. Typing it down character by character doesn’t solve the problem, nor does restarting FF. Caps lock is off. No issues with my keyboard. In my privacy and security setting I cannot to stop FF from asking my primary password, because (of course also there) it won’t recognize the primary password I enter...

There is no one who knows about my primary password nor has anyone access to my computer or iPhone. So there is no way I could explain somebody to have been able to change my primary password. Could anybody please explain to me what might be going on? Did other people experience the same issue? What steps should I take to try to solve it?

And I surely wish not to need to reset my primary password, because I will lose all my saved passwords from FF... Happily I still have access to FF Lockwise on my iPhone (using my finger print). So I could still copy each password and save it somewhere else. But that would mean quite a lot of work. Besides of that I don’t trust it to work better next time I set up a primary FF password…

I hope I explained my problem well enough. Thanks in advance for trying to help me out!

Asked by Eran FF sync 6 நாட்கள் முன்பு

Last reply by Eran FF sync 3 நாட்கள் முன்பு