Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

already running

  • 50 பதிலளிப்புகள்
  • 32 இந்த பிரச்னைகள் உள்ளது
  • 41 views
  • Last reply by Tom716

Yes, ever since the update to Firefox 29.0 the other day, I often get the "already running but not responding" message on trying to start the program, and thus have either to kill the service in task manager or reboot. I've already changed the properties of the profile to uncheck read only and already disabled an add-on (tab mix plus). My other add-ons are Better Privacy, AdBlock Plus, and Fire FTP, and darned if I am going to go without any of them. I can't help thinking there's just a serious bug in this new rollout. It's especially frustrating as I've used and supported Firefox and Thunderbird for so long now. I feel I'm being chased to Chrome! (I run Windows Vista, no firewall. The other suggested fix, deleting the lock file, is recommended, I see, only if the message persists after reboot, obviously not my issue.)

All Replies (20)

You have tried to reset Firefox, or with a newly created profile?

zoli62 மூலமாக திருத்தப்பட்டது

Reset how? (Pretty awful bug if you have basically to start all over again with installing add-ons and replicating your settings and menus. And obviously after all I've already tried I'm skeptical that it will help. I sure wish I could go back to v28. I've already complained that the new drop-down menu is useless because "customize" has such a limited range of things to add to it, without the ones I use most. Alas, after all these years, Firefox blew it.)

Thanks. Maybe I will, but as I say it's a dreadful thought recreating (say) my ftp connection and all the "learning" that AdBlock Plus has done over years. And the timing of the issue to coincide with the upgrade in versions of Firefox is just too important to overlook. Firefox should be looking to its development, not just giving advice to others to get with the system.

jhaber3:

Firefox ESR isn't recommended for personal/home users but rather large organizations.
Other users have reported this as an issue but we're not sure what's causing it as in recent bug reports they're been no clear STR. There's been several solutions made which I can give them to you and see if they fix your issue.

  1. Disable any Norton extensions you have
  2. Set network.seer.enabled to false

Mozilla engineers and QA are aware of this and they are looking into releasing a fix. Please don't ask for an ETA as I don't know :)

Thank you. (I actually was wondering if you had given me the wrong link by accident, since ESR didn't seem to apply to me.) I have rebooted and deleted parent.lock just in case it'll help, and I have just set network.seer.enabled to false. I don't run any Norton products. I haven't yet tried resetting Firefox, out of concern for my saved data, but we'll see. Meanwhile I'm sure glad they're working on it!

In case it's helpful in diagnosis and improvements, the problem has persisted since disabling network.seer.

Can you try the steps listed here:


Can you try to start Firefox in Safe Mode to see if Firefox works properly with no error? You can start Firefox in Safe Mode below:

  • Windows/Mac: Go to Help > Restart with add-ons disabled
  • Linux: Run firefox -safe-mode in the Terminal/Konsole

If Firefox opens up fine with no problems, it's probably one of your extensions that's causing the issue. You can re-enable your add-ons one by one until you find the one that causes the issue upon being re-enabled.

Moses, review the thread and you'll see we went through all the proposed solutions on that page, which I'd already read twice, except for disabling AdBlock and ftp, and if I can't block ads or run ftp in maintaining my Web site (as much as a dozen times a day), I guess I'll have to find another browser, so tough. That's not trouble shooting but blaming the user. (I did, recall, disable Tab Mix Plus, and I'll live without it if I have to.) Not that you shouldn't be testing allowed extensions as they come up (akin, I guess, to the phone app model), and testing new versions against popular extensions, but anyway. I haven't tried safe mode, but if all that means is adds and no ftp, forget it.

Safe Mode wasn't meant to be ran forever. It's a troubleshooting step that disables all of your extensions if one of them is causing the issue.

I'm positive you haven't tried this
Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

Does this also happen if you aren't restarting Firefox immediately, but have given Firefox enough time to close properly?

Are there still Firefox processes showing in the Windows Task Manager (Processes tab) when this happens or is this an issue with the parent.lock file or other profile issues (i.e. you need to delete the parent.lock file file to be able to restart Firefox)?

Moses, fair points, and I'll consider it, although as I say much of the time I run Firefox it's precisely to ftp documents! If it helps, I don't get the error every time. Say, it appeared to close just now and reopen quite well twice, but then to give me the error message on clicking a link to this very thread in an email in Thunderbird. (Could that be a clue?) I was going to say I'd disable ftp, and if that did the trick, then I'd try reinstalling it. But then this mishap right now I just mentioned may rule that out. Make sense?

Cor-el, not relevant, on several scores, alas. Your advice is way off here. (1) The program closes, without obvious sign of a problem, and I almost never try to reopen within several minutes. (2) If you trouble to read above, you'll see that I'd already deleted parent.lock at least once. (3) Manually shutting the firefox process works (although it's obviously not something you want to be doing), which rules out that there's another process related to an add-on running that's causing this.

I guess I feel especially bad not just because I work with the Web and coding, ftp, and the like is my life, but also because I'm an early supporter. I rebelled against IE with Netscape and then Firefox, Outlook with Thunderbird, and have stuck with them a long time. So it feels awful to see an upgrade causing me potentially to have to do without either my work or the browser, a nasty choice. The idea that my profile suddenly turned out to be corrupt the moment you decided to upgrade is so unscientific that I can't credit that you're taking this seriously.

Maybe just a bad suggestion, but rather than our doing without ftp, has Mozilla considered our doing without the upgrade until it can get this fixed? Could I download an earlier version?

I was trying to figure out under which conditions this occurs and whether there is some hanging involved (Firfox isn't closing properly) or if there is a profile related issue.

If Firefox isn't closing properly then you need to find out what is causing this hang.

You can try to set the network.seer.enabled pref to false on the about:config page.

C'mon, please, pretty please, can you at least read the history. I disabled network.seer several posts and several hours above. I'm trying not to make my use of a browser my life.

May I offer an update, in case it helps? Rather than disable all add-ons and restore them singly, I started this morning to disable them individually, to minimize the inconvenience. (I know that's less definitive proof of what does not cause trouble, since multiple add-ons could all be causing trouble, but then you really do have a problem bigger than the add-ons.)

I started by disabling Better Privacy. I stuck with it for a few hours, long enough for the problem to recur several times, so I enabled it again. Next I disabled AdBlock Plus, and I've been without it for at least two hours. At this point, it's no doubt only a tentative conclusion, but I'd had no recurrrence.

Of course, it's also not fun, not only because of the visual clutter but also because I've had to deny already a good 50 new cookie requests. I also worry what I'll do when I naturally want to enable it again before the problem is resolved.

I have not yet tried disabling ftp, but it may not be necessary. We'll see. I also don't know why the problem doesn't happen every single time. Could blocking only certain items cause Firefox not to close? But I can't think of why. Good luck.

Alas, the conflicts are back, twice in 20 minutes, so I guess that doesn't solve it. I'm not ruling out that a conflict with AdBlock isn't a factor, as it took 4 hours for the issue to resurface. But it clearly isn't enough. We've just plain a buggy program. Sorry!

Create a new profile as a test to check if your current profile is causing the problem.
Don't install extensions or make major changes for now.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem

  1. 1
  2. 2
  3. 3