Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I restore closed tabs as in previous versions of Firefox?

  • 20 பதிலளிப்புகள்
  • 14 இந்த பிரச்னைகள் உள்ளது
  • 5714 views
  • Last reply by user633449

Prior to upgrading to Firefox 29, I was able to restore closed browser tabs by using the Ctrl+Shift+T combination. Since upgrading, however, I seem to be unable to do so. Even right-clicking on a tab and selecting "Undo Close Tab" fails to work.

Is this a bug? Have you changed the way this is accomplished? Or has that functionality been removed?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

The problem is that sessionstore.js (which stores all your recently closed windows and tabs, etc.) got corrupted (most likely by an add-on) and Firefox didn't know what to do with it. We will be releasing an update soon to fix this so that if that file gets corrupted again Firefox will be able to fix itself :)

Read this answer in context 👍 4

All Replies (20)

The functionality is the same, so it's odd it isn't working for you. Can you try to open Firefox in safe mode and see if it works there? Troubleshoot Firefox issues using Safe Mode

I've done as requested and the issue exists there as well.

Edit: Double post. Please ignore.

EmeraldKnight மூலமாக திருத்தப்பட்டது

Restoring a session isn't quite what I intend to do, but thank you for the response! The issue in question is that in an active session, I cannot restore a tab that I have just closed out of.

You can check browser.sessionstore.* prefs including browser.sessionstore.resume_from_crash on the about:config page and reset browser.sessionstore prefs that are user set (bold) via the right-click context menu to the default value to make sure that Session Restore is enabled and working properly.

No dice. Restoring the only changed sessionstore value didn't work.

You can also check that you do not run Firefox in permanent Private Browsing mode (Never remember history).

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"

That's also not the issue. In fact, I haven't changed any of my settings since updating; the settings I'm currently using worked for previous versions of Firefox.

Click History, then come down to Recently Closed Tabs and select from the list of tabs.

Tony98 மூலமாக திருத்தப்பட்டது

That's interesting... The "Tabs From Other Devices", "Restore Previous Session", "Recently Closed Tabs", and "Recently Closed Windows" options are all grayed out for some reason, so I'm unable to use them.

The options are usually active if relevant, and greyed out if not relevant.

As long as you closed one or more tabs during the current session, the option to re-open them should become available to you.

Are you closing your browser completely, or just a few specific tabs during an active session?

Only a few specific tabs. I've tried closing a few tabs and an extra window or two to make sure of it, and the options still remain greyed out.

Then you can restore your closed tab by history menu. Select recently closed tab.

Your close tab will restore as long as it wasn't too many hours pass since you load it.

Can you please create a new profile and try there? Profile Manager - Create, remove, or switch Firefox profiles I'm trying to narrow this down as I've seen a few other complaints of this in 29

Vicky: As already covered, the options are greyed out no matter what, so I cannot do that.

Tyler: Interesting. It works on a new profile, but not on this one. Let me know if there is any information regarding my configuration that I can provide to assist you further.

EmeraldKnight:

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

It's weird that Safe Mode doesn't work yet a new profile does. There's probably something else that's messing with Firefox besides the usual extensions/plug-ins.

Ah, I just realized that Firefox has it's on safe mode. I just realized this using the "Restart with Add-ons Disabled" option. I had interpreted the earlier instruction as starting Windows in safe mode. Silly me! The option ended up allowing me to use the options as well, it seems. I will be disabling all of my add-ons and manually activating them incrementally at my next convenience to see if any of them are causing a conflict, and I will update you on the results.

Alright, time for the update:

The issue is gone! Literally all I did was disable every extension, restart Firefox with the extensions disabled, then add each extension back incrementally, restarting Firefox where necessary.

I had expected to run into a problematic extension, but the weird thing is that all of my extensions that were enabled before are enabled now, yet there isn't a conflict like there was before.

I'm assuming there was some problem behind the scenes that a small refreshing of the extensions took care of. I would be really interested to hear a developer's assessment of the potential issue.

In any case, thanks for the assistance! The bits of help here and there gave me a push in the right direction!

தீர்வு தேர்ந்தெடுக்கப்பட்டது

The problem is that sessionstore.js (which stores all your recently closed windows and tabs, etc.) got corrupted (most likely by an add-on) and Firefox didn't know what to do with it. We will be releasing an update soon to fix this so that if that file gets corrupted again Firefox will be able to fix itself :)