Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Go to google.com and search for "fishersci ca", try to open first result in new tab, this opens a blank page

  • 14 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 88 views
  • Last reply by cor-el

Go to google.com and search for "fishersci ca", try to open first result in new tab, this opens a blank page. The same thing works perfectly in other browsers like Chrome or Safari

Many Thanks.

All Replies (14)

Try clear your recent history:

Check if your anti-virus are blocking Firefox to conect to this page.

Also:

Please update to Firefox 28 (Update Firefox to the latest release) and try again.

I have tried this many times, doesn't work

In safe mode you can see the website?

Tried in safe mode, private browsing, still same experience :(

Clear recent history

   Firefox in safe mode
   Plugin check
   Newest Firefox 
   Private browsing mode
   Cookies enabled \ disabled \ cleared
   Safe mode

I have tried all of the above options but still I am facing the same problem

When i went to the site I also cant get the page but I just select the url in urlbar and press Enter and then I get the page, try in your browser!

I think the page address has a problem. I looked at an empty page. Then I went to the main page; https://www.fishersci.ca and it redirected me to https://www.fishersci.ca/home.do

Everything works perfectly in Chrome or Safari browser, what could be wrong with Firefox

This looks like a problem with the referrer.
If the link is coming from the Google search page then I get an empty page unless I block the referrer.
The link that Google uses to do a safe browsing check seems to confuse the fishersci.ca site or the server is infected and blocks users coming via Google.

Blocking JavaScript and thus disallowing Google from modifying the link works as well disabling the referrer that is send.

Note that you can see the referrer in "Tools > Page Info > General".

cor-el மூலமாக திருத்தப்பட்டது

I can guarantee that server is not infected and does not block any requests coming from Google.

Actually, there are many users who are facing this issue. 99% of users are using Firefox with default settings. Will you be able to tell me precise settings on Firefox that needs tweaking. Thanks

I have found one solution, not sure if its the right one. in about:config page, setting network.http.sendSecureXSiteReferrer to "false", works.

I am able to see the page new tab.

Still I could not find the root cause

This would still sound like an issue with the DNS server of the website or otherwise, so maybe contact the hosting company and ask them to look into this.