X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Poor Firefox performance after applying recent Microsoft Updates (Win 7 x64); any solutions?

  • 10 replies
  • 12 இந்த பிரச்னைகள் உள்ளது
  • Last reply by kcconlin9319
பதிவிடப்பட்டது

Recently I updated to Firefox 27 and noticed really horrible performance (Task Manager shows FF pegging one core, frequent "Firefox is not responding messages", even lagging keystrokes in the URL bar). This is on an Ideapad s205 (AMD E450 APU, Win 7 x64, 8GB RAM, SSD) that has always had pretty decent web browsing performance for a low-end machine.

Initially I blamed FF because the poor performance coincided with the update to version 27, but now I believe the root cause to be a recent Microsoft update. The reason for that is that my wife has a laptop with an even lower-end APU (C60 APU, 5400rpm hard drive, 4GB RAM, Win 7 x64), and she was getting much better performance with FF27 until I applied a backlog of some 90+ updates. Now she's suffering from the same poor performance I am and she's pretty p*ssed at me.

Interestingly, I have two WIn 7 x64 Intel desktops that also have FF 27 and are fully patched, and the performance is just fine. Perhaps this problem is specific to AMD APUs.

Any thoughts? I've tried turning off the Azure backend per some comments in this forum, but that made little or no difference.

Thanks!

Recently I updated to Firefox 27 and noticed really horrible performance (Task Manager shows FF pegging one core, frequent "Firefox is not responding messages", even lagging keystrokes in the URL bar). This is on an Ideapad s205 (AMD E450 APU, Win 7 x64, 8GB RAM, SSD) that has always had pretty decent web browsing performance for a low-end machine. Initially I blamed FF because the poor performance coincided with the update to version 27, but now I believe the root cause to be a recent Microsoft update. The reason for that is that my wife has a laptop with an even lower-end APU (C60 APU, 5400rpm hard drive, 4GB RAM, Win 7 x64), and she was getting much better performance with FF27 until I applied a backlog of some 90+ updates. Now she's suffering from the same poor performance I am and she's pretty p*ssed at me. Interestingly, I have two WIn 7 x64 Intel desktops that also have FF 27 and are fully patched, and the performance is just fine. Perhaps this problem is specific to AMD APUs. Any thoughts? I've tried turning off the Azure backend per some comments in this forum, but that made little or no difference. Thanks!

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Success! FF 32 appears to have resolved my performance issues. Thanks!

Read this answer in context 0

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 5.1.7.17873
  • 5.1.30214.0
  • Google Update
  • Shockwave Flash 12.0 r0
  • Picasa plugin
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • Next Generation Java Plug-in 10.51.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Garmin Communicator Plug-In 4.1.0.0
  • GEPlugin
  • VLC media player Web Plugin 2.1.0
  • NPWLPG

பயன்பாடு

  • Firefox 27.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0
  • Support URL: https://support.mozilla.org/1/firefox/27.0.1/WINNT/en-US/

நீட்சிகள்

  • Adblock Plus 2.5.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • All-in-One Sidebar 0.7.21 ({097d3191-e6fa-4728-9826-b533d755359d})
  • BetterPrivacy 1.68 ({d40f5e7b-d2cf-4856-b441-cc613eeffbe3})
  • FireFTP 2.0.18 ({a7c6cf7f-112c-4500-a7ea-39801a327e5f})
  • FoxyProxy Basic 3.2.4 (foxyproxy-basic@eric.h.jung)
  • Garmin Communicator 4.1.0 ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E})
  • Ghostery 5.1.2 (firefox@ghostery.com)
  • IE View 1.5.6 ({6e84150a-d526-41f1-a480-a67d3fed910d})
  • Image Zoom 0.6.3 ({1A2D0EC4-75F5-4c91-89C4-3656F6E44B68})
  • Myibidder (Myibay) Bid Sniper for eBay 1.3.7 (firefox1@myibay.com)
  • NoScript 2.6.8.17 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Skype Click to Call 7.0.14735.1561 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • WebDAV Launcher 1.0.7 (webdavlauncher@benryan.com)
  • Android Desktop Notifications 1.2.1 (jid0-105eGBfutA8RahNXKJRXP7CPNs0@jetpack) (Inactive)
  • Greasemonkey 1.15 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781}) (Inactive)
  • HTTPS-Everywhere 3.4.5 (https-everywhere@eff.org) (Inactive)
  • Liquid Words 9.11 ({9A752782-D706-479b-98F8-3F66BF921692}) (Inactive)
  • Perspectives 4.4 (perspectives@cmu.edu) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 6320M
  • adapterDescription2:
  • adapterDeviceID: 0x9806
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 384
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedGfxCard']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 6-7-2011
  • driverDate2:
  • driverVersion: 8.862.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedGfxCard']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 6320M Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.parent_directory: Z:\TEMP\kcconlin9319
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 184320
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140212131424
  • browser.startup.homepage_override.buildID: 20140212131424
  • browser.startup.homepage_override.mstone: 27.0.1
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 27.0.1
  • gfx.blacklist.direct2d: 4
  • gfx.blacklist.layers.direct3d9: 4
  • gfx.content.azure.enabled: False
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.cookieBehavior: 1
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1394946230
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.npdueng: 0
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1394243605

Misc

  • User JS: No
  • Accessibility: No
guigs 1072 தீர்வுகள் 11697 பதில்கள்
பதிவிடப்பட்டது

Hi, One, sorry that your wife is pissed, being a woman I know how ugly that can get. :-/ But she is your wife and I will try to help you make her happy. ;-)

Two, there are also some workarounds to turn off hardware acceleration, but if this has already been tired please ignore the common response instructions for this below:

There is also some troubleshooting steps that can be made for the Firefox is not responding message: Firefox hangs or is not responding - How to fix and to top it off how to make it faster: Quick fixes if your Firefox slows down

Not sure if you also read this, https://support.mozilla.org/en-US/que.../972037 includes some new profile options and webgl driver updates.

_____________

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

Hi, One, sorry that your wife is pissed, being a woman I know how ugly that can get. :-/ But she is your wife and I will try to help you make her happy. ;-) Two, there are also some workarounds to turn off hardware acceleration, but if this has already been tired please ignore the common response instructions for this below: There is also some troubleshooting steps that can be made for the Firefox is not responding message: [[Firefox hangs or is not responding - How to fix]] and to top it off how to make it faster: [[Firefox is slow - How to make it faster]] Not sure if you also read this, [https://support.mozilla.org/en-US/questions/972037] includes some new profile options and webgl driver updates. _____________ Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: *Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options. *In the Firefox options window click the ''Advanced'' tab, then select "General". *In the settings list, you should find the ''Use hardware acceleration when available'' checkbox. Uncheck this checkbox. *Now, restart Firefox and see if the problems persist. Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Did this fix your problems? Please report back to us! Thank you.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Minimal if any improvement. Tabs still seem to take forever to load; "Connecting" appears in the tab title, the rotating ring steps badly, and in really bad cases "Mozilla Firefox (Not Responding)" pops up in the window frame. Gmail complains it's having trouble connecting to Google Servers ("Something's not right. We're having trouble connecting to Google. We'll keep trying..."). During connection, Task Manager shows the CPU pegged for a while, then CPU use seems to slowly taper off. Facebook and Yahoo mail behave similarly, in fact any page that seems to have a lot of back & forth with the server(s) is affected. My wireless link isn't the issue; directly connecting to my router using Gb Ethernet doesn't help. Thanks for looking into this! Very aggravating.

Minimal if any improvement. Tabs still seem to take forever to load; "Connecting" appears in the tab title, the rotating ring steps badly, and in really bad cases "Mozilla Firefox (Not Responding)" pops up in the window frame. Gmail complains it's having trouble connecting to Google Servers ("Something's not right. We're having trouble connecting to Google. We'll keep trying..."). During connection, Task Manager shows the CPU pegged for a while, then CPU use seems to slowly taper off. Facebook and Yahoo mail behave similarly, in fact any page that seems to have a lot of back & forth with the server(s) is affected. My wireless link isn't the issue; directly connecting to my router using Gb Ethernet doesn't help. Thanks for looking into this! Very aggravating.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Same behavior with FF 28 unfortunately.

Same behavior with FF 28 unfortunately.
jscher2000
  • Top 10 Contributor
8839 தீர்வுகள் 72249 பதில்கள்
பதிவிடப்பட்டது

To rule out one problem, which is an issue with the protected mode feature of the Flash player plugin, try disabling that feature. The following pages provide different ways to do that:

To rule out one problem, which is an issue with the protected mode feature of the Flash player plugin, try disabling that feature. The following pages provide different ways to do that: * Adobe support article under the heading "Last Resort": [http://forums.adobe.com/message/4468493#TemporaryWorkaround Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?] * Manual steps: https://support.mozilla.org/questions/968190?page=5#answer-509209 * Batch file to automate the manual steps: https://support.mozilla.org/questions/982093#answer-518078
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Thanks for the suggestion, but no change in behavior with protected mode off.

Thanks for the suggestion, but no change in behavior with protected mode off.
jscher2000
  • Top 10 Contributor
8839 தீர்வுகள் 72249 பதில்கள்
பதிவிடப்பட்டது

You could try researching and rolling back some of your Windows updates. This isn't the best site for diagnosis or recommendations on that. You could try:

You could try researching and rolling back some of your Windows updates. This isn't the best site for diagnosis or recommendations on that. You could try: * http://windowssecrets.com/category/patch-watch/ * http://windowssecrets.com/forums/forumdisplay.php/52-Windows-7-Forum
guigs 1072 தீர்வுகள் 11697 பதில்கள்
பதிவிடப்பட்டது

jscher2000- is the cache normally that big? [ browser.cache.disk.capacity: 358400 browser.cache.disk.parent_directory: Z:\TEMP\kcconlin9319 browser.cache.disk.smart_size.first_run: False browser.cache.disk.smart_size.use_old_max: False browser.cache.disk.smart_size_cached_value: 184320 browser.places.smartBookmarksVersion: 4 ]

  • looking for hints in info
jscher2000- is the cache normally that big? [ browser.cache.disk.capacity: 358400 browser.cache.disk.parent_directory: Z:\TEMP\kcconlin9319 browser.cache.disk.smart_size.first_run: False browser.cache.disk.smart_size.use_old_max: False browser.cache.disk.smart_size_cached_value: 184320 browser.places.smartBookmarksVersion: 4 ] *looking for hints in info

guigs மூலமாக திருத்தப்பட்டது

jscher2000
  • Top 10 Contributor
8839 தீர்வுகள் 72249 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

Hi guigs2, I'm not sure what to expect for cache values. Mine are:

  • browser.cache.disk.capacity;256000 (default)
  • browser.cache.disk.smart_size.enabled;true (default)
  • browser.cache.disk.smart_size_cached_value;358400 ("user set" but I think this was computed automatically)
Hi guigs2, I'm not sure what to expect for cache values. Mine are: * browser.cache.disk.capacity;256000 (default) * browser.cache.disk.smart_size.enabled;true (default) * browser.cache.disk.smart_size_cached_value;358400 ("user set" but I think this was computed automatically)
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

No improvement with FF 29. One site that really seems to trigger the problem is Newegg; I clicked on this link for a wireless card:

http://www.newegg.com/Product/Product.aspx?Item=N82E16833106190

...and had to wait several minutes for the page to load (Chrome loaded it in seconds). While the page was loading, Task Manager showed the CPU pegged at 100% and RAM usage climbed from about 400MB to over 800MB before going back down. Reloading the same page seemed to take even longer. The links to product reviews take forever.

No improvement with FF 29. One site that really seems to trigger the problem is Newegg; I clicked on this link for a wireless card: http://www.newegg.com/Product/Product.aspx?Item=N82E16833106190 ...and had to wait several minutes for the page to load (Chrome loaded it in seconds). While the page was loading, Task Manager showed the CPU pegged at 100% and RAM usage climbed from about 400MB to over 800MB before going back down. Reloading the same page seemed to take even longer. The links to product reviews take forever.
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Success! FF 32 appears to have resolved my performance issues. Thanks!

Success! FF 32 appears to have resolved my performance issues. Thanks!