Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 27 updated automatically; since then it is very slow to open pages, very often freezes (page goes white), and it is often impossible to scroll.

  • 16 பதிலளிப்புகள்
  • 56 இந்த பிரச்னைகள் உள்ளது
  • Last reply by John99

Firefox updated itself automatically from the previous version to version 27. I repeat, it did everything by itself. Since then, even when only one page/tab is open, it is very, very slow to change pages (say, from inbox to open an e-mail), frequently whites out, refuses to scroll, or scrolls a line only when the wheel is rotated several times, and often refuses to open pages without several refreshes. I have used Firefox for many years, and this is the first time I have had such problems. (Internet Explorer does not have these issues). It seems to be getting worse day by day. (Pages failing to load until refreshed started within the past week, and now it is happening more than 50% of the time.) I am going blind, and this is just becoming terribly frustrating. If the version has so many bugs, why was it released? (I am running Windows 7, with everything up-to-date. I have not changed any settings, and, as mentioned above, Firefox worked perfectly before the automatic update to version 27 installed itself a couple of weeks ago.)

All Replies (16)


Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

Thank you for your reply. I am sorry to say, however, that emptying the cache and cookies made no difference at all -- in fact, Firefox froze up for almost a half hour when I tried to empty the cache and cookies. (By the way, this was suggested in some replies to other people who had experienced similar problems, and I tried it before, but...nothing.) Whiteouts, problems with scrolling, problems opening pages have been happening just as frequently since. Might you have any other suggestions of things I could try? I really prefer Firefox (and have for a number of years) -- or, at least I did until this started happening. I used to be able to go through a news site and open all the stories I wanted to read in tabs, but that is not possible any more since this update installed itself. (Honestly, one thing that is really annoying is that this time I let it do it all by itself. Usually I manually install, so if I had done something to screw it up, that would be ok, but I let it do its own thing, and end up with this.)

Anyway, thanks for trying. I just hope someone has an idea that will work! -- Daniel

Open your task manager and set the priority of your firefox browser to high,this helped me

Thank you for your time, but changing the priority to the highest setting did not do anything but make everything else start to work erratically. Lowering it to above-average lets other processes work, but Firefox stays the same. This is frustrating.

Anyway, have a good week....

-- Daniel

Try going to your window firewall setting and then go to advance settings. Next click on inbound rules and then new rule to add firefox. I did that and my firefox works like normal now.

Thanks for taking the time to make your suggestion. I tried it when your reply showed up, but over the past 5 or 6 hours nothing has changed. Since yesterday, in addition to the rest (it now takes 2 or 3 refreshes before pages display), particularly on my e-mail (yahoo mail) the pages suddenly change to huge sized type (they open normally, and then blink and change to what looks like 42 point type); also, compose pages have begun to format themselves -- doing things like hyphenating words at the end of the line (according to what rules of orthography I know not -- certainly not as the dictionary divides words into syllables). Does any of this ring a bell with anyone? It appears to be a problem that is getting worse and worse. (I have run anti-virus scans, anti-spyware scans, anti-malware scans, all with the most recent definitions, and nothing of that sort is showing up.) Grrrrrr!

-- Daniel

d_m_burkus மூலமாக திருத்தப்பட்டது

Try disabling all your addons and if that fixes it.. enable them all one by one until you find the culprit.

Are you still having problems or did you sort this out ?

My computer has developed other very serious issues (which may or may not have had a connection with the original problem), primarily shutting down suddenly and without warning. This has already destroyed the original C: drive (on which Mozilla was installed) as well as my removable back-up drive. I am now using what originally was the D: drive as the C: drive, but can stay on line only briefly (a matter of a minute or two only), so can not tell if the situation has been resolved (by installing Firefox on a new drive) or not. Sorry.

-- Daniel M. Burkus

It is possible that your security software (firewall, anti-virus) blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full, unrestricted, access to internet for Firefox and the plugin-container process and the updater process.


Do a malware check with several malware scanning programs on the Windows computer.
Please scan with all programs because each program detects different malware.
All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

Thank you. I have had to start using a new drive as my D: drive, so everything had to be reinstalled from scratch. I do not notice the problem now, but on the other hand I am not able to use Firefox long enough for the issue to reveal itself. Still, I will look into your suggestions: they may impact on whatever it is that is messing up the machine in the first place.

Thank you for your help.

-- Daniel M. Burkus

Checking the security software and for malware would seem a good idea. Another couple of points.

Determining if Version Change was significant.
You could try temporarily installing Firefox portable ESR (Fx24) as an additional browser. It is easy to install and does not interfere with the standard Firefox Release already in use. It may make for an interesting comparison. It may even help with getting to the bottom of this problem.

Computer Overheating.
With very high CPU usage the computer's temperatures could well be rising and the sudden shut off be the result of that. Installing temperature monitoring software may assist you in predicting and maybe avoiding sudden shut offs. Presumably fans are working ok and the ventilation is not getting obstructed by dust or any external blockages.

Thank you, John.

    John, I honestly do not know what is happening.  I guess I should mention that I am going blind (cataracts -- left eye has been totally blind since 2011, and right eye is getting worse all the time), and this mess has caused my stress level to skyrocket, meaning that the disease has progressed more rapidly in the past couple of months (since this issue began -- like a cascade, starting with the Firefox problem through the machine itself; yes, I wondered if some sort of malware was not installed simultaneously with the automatic update, but whatever it is has destroyed my C drive and my "My Book" external hard drive on which all of my files were backed up) than in the whole year before.
    The CPU overheating is probably not the issue (at least through programs that I know are running); but coming to that conclusion as a possibility a while ago, I removed the side panel so that the interior will not get too hot.
    Someone is supposed to test the Power Supply to see if there is some problem there, but I do not know when that will be.  Since the machine shuts down unpredictably, I can not really do much testing until this issue is resolved.  Then the rest will be attended to in due course.
    Thank you for your help.  Please have a good day.

-- Daniel M. Burkus

Sorry about your health issues. As you have sight problems you may be interested in

Presumably you have an official copy of Firefox if so the upgrade is almost certainly not going to cause malware issues. The change could however be a factor to be taken into consideration when looking for the cause of your problems.

This is not a forum for discussing hardware issues, but overheating can certainly result from Firefox use and then result in the computer shutting down so it is not entirely out of scope.

There is free software around that is able to monitor sensor temperatures and even fan speeds. Over heating may not explain freezing or other problems but it certainly could result in cutting out. Some modern hard drives monitor temperature and other usage stats

This is data you may be able to find and review with some suitable utility.

I do know from experience removing the side of a unit may sometimes actually result in some components running hotter.

Returning to report what I did. The PC got so bad I decided to reformat the hard drive and reinstall Windows 7 (Ultimate). Someone (in TechSuportForum) suggested using Darik's Boot and Nuke (2.2.6.i586). It took more than 15 hours to finally get it to run to completion (PC kept shutting down, but apparently it was slowly eating away at whatever the problem was). Anyway, after the complete reinstallation of Windows, I added Firefox and the other programs. And the shut-down problem started again! So I removed Firefox and installed FirefoxPortable. And the problem appears to be solved. I have not had any issues since the change.

It is a pity, though. Why would they design a program that makes problems for their customers? I have used Firefox as my browser of preference for years. Why? Did whatever additions they made improve things so much? Maybe they need to be reminded that not everyone uses the most up-to=date operating system and can afford to buy a new computer every 6 months so it has the power (or whatever) to run their upgrade. I tried Windows 8.1 and hate it -- the high contrast b/s really exacerbated my eye problems, so I am back to Windows 7. Maybe people like me just do not matter to Mozilla?

Anyway, thank you all for your help and suggestions. Not quite in the order that they were made, but eventually the problem has been resolved. Please have a good day.

-- Daniel M. Burkus

Glad you partly solved your problem. Thanks for posting back.

You may note Mozilla Firefox is still supporting XP and providing those users with a secure browser, their own Software Company is not doing so.

Firefox portable is a build of the ordinary Firefox. If Firefox portable works Firefox itself would probably work if you used the Firefox Reset

If it is the Firefox Portable ESR that works then it may well be a bug in recent Firefox's that will need fixing.

There is a Bug Report filed that may be relevant but seems not to be getting any attention at present. If you think that is what may be affecting you then the following actions may be worth considering