Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Add-Ons Page Does Not Recognize that I Am Using Firefox

  • 10 பதிலளிப்புகள்
  • 3 இந்த பிரச்னைகள் உள்ளது
  • 21 views
  • Last reply by Val (BlacklightHalo)

I am trying to add the YouTube Search Engine to my search-bar, and when I go to the page to add it, The page gives me an error, "Error - you must be using a Mozilla-based web-browser (such as Firefox) to use this add-on." Really?

file:///home/user/Documents/Firefox Screenshot.jpeg

Of course, *this* part of the site seems convinced that I'm using Firefox.

file:///home/user/Documents/Firefox Screenshot 2.jpeg

All Replies (10)

You cannot host images off your desktop computer.

The first post in thread does not have a image attachment feature however you can add images in replies after. Or host online at a image host site like <strike>tintpic</strike> tinypic.

What site are you trying to add this from?


Your useragent appears to be ok. Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0

James மூலமாக திருத்தப்பட்டது

What or how were you trying to add the search engine? I us Add to Search Bar without any problem.

This issue can be caused by an extension that <strike>isn't</strike> is preventing this from working properly. (sorry for the confusion)

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

See also the Firefox Health Report on the about:healthreport page.

You can set the Boolean pref browser.slowStartup.notificationDisabled to true on the about:config page to disable this notification.

cor-el மூலமாக திருத்தப்பட்டது

@James - I never said anything about hosting images off my computer. o.O I said I'm trying to add the "YouTube Search" engine to the Search Bar in Firefox, and it keeps giving me an error message which says I need to be using a mozilla based browser, like Firefox (which obviously I already am) in order to add it.

@cor-el - Your advice is confusing me a bit. You say to start in Safe Mode, but you say *not* to click the "Reset" button on the Safe Mode start window (which is how you start in Safe Mode.) How do I get into safe mode without clicking the reset button in the dialogue box?

The window that opens when you start Firefox in Safe Mode has two choices, either to continue in safe mode (Start in Safe Mode) with the current profile or reset Firefox which will create a new profile. As you want to check for issues in your current profile, you need to click the button to continue in Safe Mode.

You can use one of these to start Firefox in Safe Mode:

  • On Windows, hold down the Shift key while starting Firefox with a double-click on the Firefox desktop shortcut
  • On Mac, hold down the Options key while starting Firefox
  • Help > Restart with Add-ons Disabled

That worked, thank you. =)

Val (BlacklightHalo) மூலமாக திருத்தப்பட்டது

I assume that you are talking about a Persona (lightweight theme). You should be able to find this theme in "Firefox/Tools > Add-ons > Appearance" and re-enable it, as this probably doesn't have anything to do with this issue.

Did Safe Mode help with this issue?

If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit)

Val (BlacklightHalo) I was referring to the file:///home/user/Documents/Firefox Screenshot.jpeg and file:///home/user/Documents/Firefox Screenshot 2.jpeg in your post. I see you figured out how to attach images to post.

If all else fails, do this. Go to the page of the add-on you want. Look for the Add button. Normally you would click on in for the add-on to be installed automaticlly, BUT instead right click and select Save Link As. Later, open your download folder, hold down the left button on the add-on, and move it onto the browser window. If there is still a problem, try again after you Start Firefox in Safe Mode.

@cor-el - No I was talking about the theme that my Linux Desktop is set to use under "System Settings> Application Appearance," which was applied to my Firefox as well, and then stopped being as such after I used the Safe Mode fix. However, it went back when I restarted my computer.

@james - Ah, I see. And yeah I did figure it out, thanks.