Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

File type .cbv displays contents rather than gives download options

  • 21 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 8 views
  • Last reply by AliceWyman

I've just changed website hosting supplier; both old and new suppliers run Linux services. My site is scottishcca.co.uk - a correspondence chess site - and I'm using Win7 and Firefox 26.0. There's a page (members/downloads) where members can download e-magazines and files of chess games - the page is password protected using htaccess/htpasswd which works ok. Each e-magazine has 4 download links: pdf, zip and pgn all work correctly, but cbv does not - it just displays file contents in the browser page. What should happen is that the browser should bring up a dialogue box asking if the file should be opened with ChessBase 11 Database Software (which is associated with the .cbv file type on my computer - I checked my Default Program settings). The .pgn file type is also associated with ChessBase 11 Database Software and works correctly - the dialogue box allows me to open or save. All the links work correctly when I use Google Chrome. I'm puzzled - advice please! Iain

தீர்வு தேர்ந்தெடுக்கப்பட்டது

I think I have a fix for this. I went back to my new hosting supplier (easyspace) and received this reply: 'Hi Iain, I have done some research on this for you and have a suggestion for you to try. It is possible that Firefox is not recognising the MIME Type of application/cbv as it is not an IANA registered MIME Type. You could instead try application/octet-stream which is a generic MIME Type for non-text files. This idea came to me while reading the page at https://developer.mozilla.org/en/docs/Properly_Configuring_Server_MIME_Types and this document may give you more of an idea as to why this is not working in Firefox. Can you give this a try please and let me know how you get on. Best Regards, Gerry Munn Support Services I implemented Gerry's suggestion via .htaccess in my root directory and everything now works (after clearing Firefox cache). Maybe you could send Gerry a certificate of proficiency!

Read this answer in context 👍 0

All Replies (1)

iain.mackintosh,

Thanks for the followup. I marked your last reply as the solution.

  1. 1
  2. 2