X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

How do I stop yahoo from re-setting as my default homepage?

  • 10 replies
  • 14 இந்த பிரச்னைகள் உள்ளது
  • Last reply by hskoppek
பதிவிடப்பட்டது

I am operating OSX 10.8.5 and Firefox 26

Recently (without having installed new software or extensions) my homepage setting in firefox default to yahoo. Yahoo also showed up as one of my search engines w/o me having installed it. I deleted it and everything was fine for a while. But now instead of showing my windows and tabs from last time, it just shows yahoo instead.

This is very annoying, because I keep loosing all my pinned tabs. None of the solution discussed above are helpful and the problem persists even in the safe mode.

Below is the troubleshooting info from "Firefox about:support"

I am operating OSX 10.8.5 and Firefox 26 Recently (without having installed new software or extensions) my homepage setting in firefox default to yahoo. Yahoo also showed up as one of my search engines w/o me having installed it. I deleted it and everything was fine for a while. But now instead of showing my windows and tabs from last time, it just shows yahoo instead. This is very annoying, because I keep loosing all my pinned tabs. None of the solution discussed above are helpful and the problem persists even in the safe mode. Below is the troubleshooting info from "Firefox about:support"

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Is there any chance that you installed a customized version of Firefox optimized for Yahoo? See http://downloads.yahoo.com/firefox/

Yahoo-customized versions of Firefox are mentioned in the article Remove a toolbar that has taken over your Firefox search or home page. If you have one (they're offered for both Windows and Mac) you'll have to replace it the "official" version of Mozilla Firefox.

In any case, you could trash Firefox (remove it from your desktop/dock/Applications folder) and then reinstall Mozilla Firefox by downloading a fresh copy from mozilla.org - see How to download and install Firefox on Mac. Your Firefox user profile is stored in a separate location - see the Profiles article - so your bookmarks, passwords, and other user data should be preserved.

You could also try a Firefox Reset - see Refresh Firefox - reset add-ons and settings

Read this answer in context 1

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Displays Java applet content, or a placeholder if Java is not installed.
  • Shockwave Flash 11.9 r900
  • Version 4.9.1.16010
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

பயன்பாடு

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:26.0) Gecko/20100101 Firefox/26.0

கூடுதல் தகவல்

Application Basics
------------------
Name: Firefox
Version: 26.0
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:26.0) Gecko/20100101 Firefox/26.0
Extensions
----------
Name: 1Password
Version: 4.0.1
Enabled: true
ID: onepassword4@agilebits.com
Name: Adblock Plus
Version: 2.4.1
Enabled: true
ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Name: ColorfulTabs
Version: 22.1
Enabled: true
ID: {0545b830-f0aa-4d7e-8820-50a4629a56fe}
Name: Forecastfox
Version: 2.2.2
Enabled: true
ID: {0538E3E3-7E9B-4d49-8831-A227C80A7AD3}
Name: Pocket
Version: 3.0.4
Enabled: true
ID: isreaditlater@ideashower.com
Name: Undo Closed Tabs Button
Version: 3.8.6
Enabled: true
ID: undoclosedtabsbutton@supernova00.biz
Important Modified Preferences
------------------------------
accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.smart_size_cached_value: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.places.smartBookmarksVersion: 4
browser.search.useDBForOrder: true
browser.sessionstore.upgradeBackup.latestBuildID: 20131205075310
browser.startup.homepage: http://nl.search.yahoo.com/?type=576859&fr=spigot-yhp-ffmac
browser.startup.homepage_override.buildID: 20131205075310
browser.startup.homepage_override.mstone: 26.0
browser.tabs.onTop: false
dom.mozApps.used: true
extensions.lastAppVersion: 26.0
gfx.blacklist.webgl.msaa: 4
keyword.URL: http://nl.search.yahoo.com/search?fr=spigot-adr-ffmac&ei=utf-8&ilc=12&type=576859&p=
network.cookie.prefsMigrated: true
places.database.lastMaintenance: 1390912204
places.history.expiration.transient_current_max_pages: 100664
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
print.macosx.pagesetup-2: PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0iVVRGLTgiPz4KPCFET0NUWVBFIHBsaXN0IFBVQkxJQyAiLS8vQXBwbGUvL0RURCBQTElTVCAxLjAvL0VO
print.print_bgcolor: false
print.print_bgimages: false
print.print_colorspace:
print.print_command:
print.print_downloadfonts: false
print.print_duplex: 1
print.print_evenpages: true
print.print_in_color: true
print.print_margin_bottom: 0.5
print.print_margin_left: 0.5
print.print_margin_right: 0.5
print.print_margin_top: 0.5
print.print_oddpages: true
print.print_orientation: 0
print.print_page_delay: 50
print.print_paper_data: 0
print.print_paper_height: 11.00
print.print_paper_name:
print.print_paper_size_type: 1
print.print_paper_size_unit: 0
print.print_paper_width: 8.50
print.print_plex_name:
print.print_resolution: 133866944
print.print_resolution_name:
print.print_reversed: false
print.print_scaling: 1.00
print.print_shrink_to_fit: true
print.print_to_file: false
print.print_unwriteable_margin_bottom: 57
print.print_unwriteable_margin_left: 25
print.print_unwriteable_margin_right: 25
print.print_unwriteable_margin_top: 25
privacy.sanitize.migrateFx3Prefs: true
storage.vacuum.last.index: 0
storage.vacuum.last.places.sqlite: 1390945388
Graphics
--------
Device ID: 0x 863
GPU Accelerated Windows: 1/1 OpenGL (OMTC)
Vendor ID: 0x10de
WebGL Renderer: NVIDIA Corporation -- NVIDIA GeForce 9400M OpenGL Engine
windowLayerManagerRemote: true
AzureCanvasBackend: quartz
AzureContentBackend: quartz
AzureFallbackCanvasBackend: none
AzureSkiaAccelerated: 0
JavaScript
----------
Incremental GC: true
Accessibility
-------------
Activated: false
Prevent Accessibility: 0
Library Versions
----------------
NSPR
Expected minimum version: 4.10.2
Version in use: 4.10.2
NSS
Expected minimum version: 3.15.3.1 Basic ECC
Version in use: 3.15.3.1 Basic ECC
NSSSMIME
Expected minimum version: 3.15.3.1 Basic ECC
Version in use: 3.15.3.1 Basic ECC
NSSSSL
Expected minimum version: 3.15.3.1 Basic ECC
Version in use: 3.15.3.1 Basic ECC
NSSUTIL
Expected minimum version: 3.15.3.1
Version in use: 3.15.3.1

iamjayakumars 492 தீர்வுகள் 5972 பதில்கள்
பதிவிடப்பட்டது

type about:config in URL and filter > browser.startup.hompage and change the value as about:home

Set your Homepage

type '''about:config''' in URL and filter > '''browser.startup.hompage''' and change the value as '''about:home''' Set your Homepage *https://support.mozilla.org/en-US/kb/How%20to%20set%20the%20home%20page
jscher2000
  • Top 10 Contributor
8792 தீர்வுகள் 71910 பதில்கள்
பதிவிடப்பட்டது

First, to manually restore your previous session until this is solved, you can use the History menu > Restore Previous Session.

Second, how long does the change last in the user interface? By that, I mean, if you select "When Firefox starts: Show my windows and tabs from last time" and OK the change:

  • If you go back into the Preferences dialog, does it show your changed setting?
  • Does it work for even one startup?
  • The setting lasts but actually it is ignored?
First, to manually restore your previous session until this is solved, you can use the History menu > Restore Previous Session. Second, how long does the change last in the user interface? By that, I mean, if you select "When Firefox starts: Show my windows and tabs from last time" and OK the change: * If you go back into the Preferences dialog, does it show your changed setting? * Does it work for even one startup? * The setting lasts but actually it is ignored?
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

in response to iamjayakumars:

That is exactly what I have done three times, but it keeps resetting to Yahoo !!!!

in response to iamjayakumars: That is exactly what I have done three times, but it keeps resetting to Yahoo !!!!

hskoppek மூலமாக திருத்தப்பட்டது

பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

to jscher2000:

a) no idea whether it kept showing in the preference dialogue box after I restarted Firefox or the entire system

b) It has worked for several start-ups. At first with no problem at all. After it happened the third time, I had to restore tabs, by clicking on the Firefox screen "Restore previous session".

c) not sure what you mean by "The setting lasts but actually it is ignored? "

to jscher2000: a) no idea whether it kept showing in the preference dialogue box after I restarted Firefox or the entire system b) It has worked for several start-ups. At first with no problem at all. After it happened the third time, I had to restore tabs, by clicking on the Firefox screen "Restore previous session". c) not sure what you mean by "The setting lasts but actually it is ignored? "
Diego Victor 658 தீர்வுகள் 4175 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that turns off some settings and disables most add-ons (extensions and themes).

(If you're using an added theme, switch to the Default theme.)

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu by clicking on the Restart with Add-ons Disabled... menu item:
FirefoxSafeMode

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Thank you.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that turns off some settings and disables most add-ons (extensions and themes). ''(If you're using an added theme, switch to the Default theme.)'' If Firefox is open, you can restart in Firefox Safe Mode from the Help menu by clicking on the '''Restart with Add-ons Disabled...''' menu item:<br> [[Image:FirefoxSafeMode|width=520]]<br><br> If Firefox is not running, you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem. Thank you.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

to Diego Victor:

tried that yesterday and the problem persisted.

Right now Firefox is behaving O.K. again, i.e. my pinned tabs remain and Firefox shows all the windows and tabs from the last time.

However, in the past it has defaulted to yahoo after some time for no apparent reason.

to Diego Victor: tried that yesterday and the problem persisted. Right now Firefox is behaving O.K. again, i.e. my pinned tabs remain and Firefox shows all the windows and tabs from the last time. However, in the past it has defaulted to yahoo after some time for no apparent reason.
cor-el
  • Top 10 Contributor
  • Moderator
17578 தீர்வுகள் 158993 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

If you do not keep changes after a restart or otherwise have problems with preferences, see:

If you do not keep changes after a restart or otherwise have problems with preferences, see: *http://kb.mozillazine.org/Preferences_not_saved
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Hi cor-el, Checking the Mozilla Profile was quite startling: I do have a Mozilla folder, but it is empty. It contains only one other folder "Extensions", which is empty, too. Searching for "prefs" delivers no results. Searching for "Mozilla" delivers no results. I'm confused.

At the moment Firefox works OK, but just noticed that Yahoo appeared as my homepage in the preference settings (Just changed it back to Firefox). This is weird, because I do not use Yahoo whatsoever.

Hi cor-el, Checking the Mozilla Profile was quite startling: I do have a Mozilla folder, but it is empty. It contains only one other folder "Extensions", which is empty, too. Searching for "prefs" delivers no results. Searching for "Mozilla" delivers no results. I'm confused. At the moment Firefox works OK, but just noticed that Yahoo appeared as my homepage in the preference settings (Just changed it back to Firefox). This is weird, because I do not use Yahoo whatsoever.
AliceWyman
  • Moderator
240 தீர்வுகள் 2597 பதில்கள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Is there any chance that you installed a customized version of Firefox optimized for Yahoo? See http://downloads.yahoo.com/firefox/

Yahoo-customized versions of Firefox are mentioned in the article Remove a toolbar that has taken over your Firefox search or home page. If you have one (they're offered for both Windows and Mac) you'll have to replace it the "official" version of Mozilla Firefox.

In any case, you could trash Firefox (remove it from your desktop/dock/Applications folder) and then reinstall Mozilla Firefox by downloading a fresh copy from mozilla.org - see How to download and install Firefox on Mac. Your Firefox user profile is stored in a separate location - see the Profiles article - so your bookmarks, passwords, and other user data should be preserved.

You could also try a Firefox Reset - see Refresh Firefox - reset add-ons and settings

Is there any chance that you installed a customized version of Firefox optimized for Yahoo? See http://downloads.yahoo.com/firefox/ Yahoo-customized versions of Firefox are mentioned in the article [[Remove a toolbar that has taken over your Firefox search or home page]]. If you have one (they're offered for both Windows and Mac) you'll have to replace it the "official" version of Mozilla Firefox. In any case, you could trash Firefox (remove it from your desktop/dock/Applications folder) and then reinstall Mozilla Firefox by downloading a fresh copy from mozilla.org - see [[Install Firefox on Mac]]. Your Firefox user profile is stored in a separate location - see the [[Profiles|Profiles]] article - so your bookmarks, passwords, and other user data ''should'' be preserved. You could also try a Firefox Reset - see [[Reset Firefox – easily fix most problems]]
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Thanks AliceWyman

I'll look into it as soon as I have time.

Thanks AliceWyman I'll look into it as soon as I have time.