X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Why won't Firefox run a video, but Chrome does?

  • 25 replies
  • 21 இந்த பிரச்னைகள் உள்ளது
  • Last reply by jscher2000
பதிவிடப்பட்டது

I was trying to view a video using Firefox, but the window where the video should play never loaded. It just remained a black image. So I tried the same page using Chrome, just to make sure the site was good, and the video did play using the Chrome browser.

The site I was trying to view in Forefox, but would not play the video, was:

http://www.thedailyshow.com/full-episodes/wed-january-15-2014-robert-gates

I do have flash player 11.9.900.700 plugin (add-o)n installed and activated.

I don't know what else to try to verify, or even if that video is a flash video.

I was trying to view a video using Firefox, but the window where the video should play never loaded. It just remained a black image. So I tried the same page using Chrome, just to make sure the site was good, and the video did play using the Chrome browser. The site I was trying to view in Forefox, but would not play the video, was: http://www.thedailyshow.com/full-episodes/wed-january-15-2014-robert-gates I do have flash player 11.9.900.700 plugin (add-o)n installed and activated. I don't know what else to try to verify, or even if that video is a flash video.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

I think I have solved the problem of the video not displaying at www.thedailyshow.com.

I went to the Flash Global Settings update page on Macromedia.com which is located here:

http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager03.html

I checked a box that says: "Allow third-party Flash content to store data on your computer".

After that I had to click to another tab (leave that one) to apparently 'activate'/'refresh the Flash settings for '3rd party data storage'.

I then just refreshed the page I had open on 'www.thedailyshow.com' and voila - the video played!

(BTW, that checkbox box to allow 3rd party content to store data, is on the second tab in a '3 inch square box' in the middle of that page, and is titled "Adobe Flash Player settings Manager".

There are 8 tabs in this Manager's box, the second to the right looks like a yellow folder with a green arrow pointing into it and a earth sphere behind it.

I only added this detail because that '3 inch box' looks like a static image, but actually is click-able dialouge to change the settings for Flash player.

The web page at 'www.thedailyshow.com' uses flash player to display the video.)

I hope this is the end of this problem.

I hope maybe this helps someone else.

Do you guys think it is a problem, security wise, to enable 3rd party content to store data on my computer?

Thanks !

Read this answer in context 0

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Shockwave Flash 11.9 r900
  • NPRuntime Script Plug-in Library for Java(TM) Deploy

பயன்பாடு

  • Firefox 26.0
  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:26.0) Gecko/20100101 Firefox/26.0
  • Support URL: https://support.mozilla.org/1/firefox/26.0/WINNT/en-US/

நீட்சிகள்

  • Browsing Protection 1.10 (litmus-ff@f-secure.com)
  • Pin It button 1.1 (pinterest@robertnyman.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • YesScript 1.9.1 (yesscript@userstyles.org)
  • Adblock Plus 2.4.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}) (Inactive)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)
  • YouTube HTML5 Switch v0.1.7 (jid0-coCUQ7NySNPcj72dA3557kKXGZU@jetpack) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 6150SE nForce 430
  • adapterDescription2:
  • adapterDeviceID: 0x03d0
  • adapterDeviceID2:
  • adapterDrivers: nvd3dum
  • adapterDrivers2:
  • adapterRAM: 128
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 7.0.6002.23200
  • driverDate: 1-31-2013
  • driverDate2:
  • driverVersion: 9.18.13.783
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedGfxCard']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 6150SE nForce 430 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.newtab.url: http://www.google.com
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131205075310
  • browser.startup.homepage_override.buildID: 20131205075310
  • browser.startup.homepage_override.mstone: 26.0
  • browser.tabs.onTop: False
  • dom.ipc.plugins.java.enabled: True
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 26.0
  • font.internaluseonly.changed: False
  • gfx.direct2d.disabled: True
  • gfx.direct3d.checkDX10: False
  • layers.acceleration.disabled: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1390029043
  • places.history.expiration.transient_current_max_pages: 77117
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.java: 0
  • plugin.state.npgoogleupdate: 0
  • plugin.state.npitunes: 0
  • plugin.state.npmcafeemss: 0
  • plugin.state.npmotive: 0
  • plugin.state.npmvtplugin: 0
  • plugin.state.nppdf: 0
  • plugin.state.npqtplugin: 0
  • plugin.state.nprlsecurepluginlayer: 0
  • plugin.state.npwpf: 0
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1390019470

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17466 தீர்வுகள் 157836 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

You can check for a possibly colored Lego icon on the left end of the location bar as an indication that Firefox is blocking a plugin.


You can try these steps in case of issues with web pages:

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
You can check for a possibly colored Lego icon on the left end of the location bar as an indication that Firefox is blocking a plugin. *https://support.mozilla.org/kb/why-do-i-have-click-activate-plugins *http://kb.mozillazine.org/Issues_related_to_plugins#Click_to_Play ---- You can try these steps in case of issues with web pages: Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *Hold down the Shift key and left-click the Reload button *Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *Press "Command + Shift + R" (Mac) Clear the cache and cookies only from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox/Tools > Options > Privacy > Cookies: "Show Cookies" Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I have checked and plugin is NOT being blocked.

Also tried reloading the page each way you suggested, with no resolution to problem.

I would clear the cache/cookies, but first I need to ask will that clear the navigation history for each page on all my open tabs? (I have many open and do not want to lose that history).

An additional piece of info I forgot to add, is even though I cannot see the video on that web page with Firefox, I can see videos on youtube with Firefox! (And that web page video does display in Chrome). Does this fact lead you to any other diagnosis?

I have checked and plugin is NOT being blocked. Also tried reloading the page each way you suggested, with no resolution to problem. I would clear the cache/cookies, but first I need to ask will that clear the navigation history for each page on all my open tabs? (I have many open and do not want to lose that history). An additional piece of info I forgot to add, is even though I cannot see the video on that web page with Firefox, I can see videos on youtube with Firefox! (And that web page video does display in Chrome). Does this fact lead you to any other diagnosis?

mnalep மூலமாக திருத்தப்பட்டது

jscher2000
  • Top 10 Contributor
8684 தீர்வுகள் 70998 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

For me, the site immediately starts playing the first of two ads. Do any of your add-ons possibly block "pre-roll" video ads?

For me, the site immediately starts playing the first of two ads. Do any of your add-ons possibly block "pre-roll" video ads?
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

The add on's that I have that I think could block anything are: 'YesScript', 'AddBlockPlus', 'Browsing Protection' (which is part of my anti virus from F-secure, which is the anti virus software provided by my provider - WOW internet/cable).

I tried disabling all three of these (above), and then opened another window but still no video.

Other than that I have Java, Shockwave, Pinit, and Troubleshooter (from Mozilla). No others.

Since you can view the video, I wonder what I have on my Firefox (version 26, btw) versus in yours?

The add on's that I have that I think could block anything are: 'YesScript', 'AddBlockPlus', 'Browsing Protection' (which is part of my anti virus from F-secure, which is the anti virus software provided by my provider - WOW internet/cable). I tried disabling all three of these (above), and then opened another window but still no video. Other than that I have Java, Shockwave, Pinit, and Troubleshooter (from Mozilla). No others. Since you can view the video, I wonder what I have on my Firefox (version 26, btw) versus in yours?

mnalep மூலமாக திருத்தப்பட்டது

jscher2000
  • Top 10 Contributor
8684 தீர்வுகள் 70998 பதில்கள்
பதிவிடப்பட்டது

Hi mnalep, just in case... Often when you disable an extension a link will appear above the extension to restart Firefox. In that case, the disablement doesn't take effect until after you click the link and Firefox exits and restarts.

Hi mnalep, just in case... Often when you disable an extension a link will appear above the extension to restart Firefox. In that case, the disablement doesn't take effect until after you click the link and Firefox exits and restarts.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Jscher2000, I have disabled extensions YesScript', 'AddBlockPlus', 'Browsing Protection' , "browsing Protection', 'Pinit, and 'troubleshooter' - and then closed and restarted Firefox. Still no video.

The only thing I did not see a disable function for were 'Java deploment Toolkit' and 'shockwave flash'.


Does this help - I notice a comments at the bottom of the window that lingered for a while: "retreiving data from facebook.com" displayed for maybe 30 seconds, and then that "waiting for daapi.flux.com" was trying to load for a long time, maybe 60 seconds or more, and many more before those, but then still get a no video showing. Just informing you in case that means anything.

Jscher2000, I have disabled extensions YesScript', 'AddBlockPlus', 'Browsing Protection' , "browsing Protection', 'Pinit, and 'troubleshooter' - and then closed and restarted Firefox. Still no video. The only thing I did not see a disable function for were 'Java deploment Toolkit' and 'shockwave flash'. Does this help - I notice a comments at the bottom of the window that lingered for a while: "retreiving data from facebook.com" displayed for maybe 30 seconds, and then that "waiting for daapi.flux.com" was trying to load for a long time, maybe 60 seconds or more, and many more before those, but then still get a no video showing. Just informing you in case that means anything.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Also, I just realized that several plugins I had installed at some past time are not activated, and I wonder if that may be why that video does not display?

The plugins that are set as 'never activate' are:

Java Platform SE 7 U45 10.45.2.18,

Google Update 1.3.22.3,

Adobe Acrobat 11.0.2,

Itunes Application Developer,

Motive Plugin,

Quicktime Plugin,

RocketLife Secure Plugin Layer,

Windows Presentation Foundation.

Also, I just realized that several plugins I had installed at some past time are not activated, and I wonder if that may be why that video does not display? The plugins that are set as 'never activate' are: Java Platform SE 7 U45 10.45.2.18, Google Update 1.3.22.3, Adobe Acrobat 11.0.2, Itunes Application Developer, Motive Plugin, Quicktime Plugin, RocketLife Secure Plugin Layer, Windows Presentation Foundation.
jscher2000
  • Top 10 Contributor
8684 தீர்வுகள் 70998 பதில்கள்
பதிவிடப்பட்டது

Hi mnalep, I don't think any of those other plugins are needed to play the Flash video. You might want to enable Acrobat, but to get it up to the current release, go into Adobe Reader or Adobe Acrobat and use Help > Check for Updates there.

When I look at the traffic from that page to different ad servers, there are so many that I can't tell which ones really are critical...

Do you have any entries in your Windows hosts file, or in any external filtering software (parental control, privacy, web filter, etc.) that might be blocking the ad servers?

Hi mnalep, I don't think any of those other plugins are needed to play the Flash video. You might want to enable Acrobat, but to get it up to the current release, go into Adobe Reader or Adobe Acrobat and use Help > Check for Updates there. When I look at the traffic from that page to different ad servers, there are so many that I can't tell which ones really are critical... Do you have any entries in your Windows hosts file, or in any external filtering software (parental control, privacy, web filter, etc.) that might be blocking the ad servers?
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I looked in my c:\windows\system32\drivers\hosts file. The entries in there were:

127.0.0.1 quantserve.com

127.0.0.1 pixel.quantserve.com

127.0.0.1 edge.quantserve.com

127.0.0.1 localhost

1 localhost

I commented those first three out (by placing the pound sign # in front of them), resaved hosts, and opened a new firefox window, but still not video playing.


I assume I have the correct hosts file? (although from my memory, not always good, I thought it was .hosts?)

I've never set parental controls up. I will poke around in my f-secure antivirus to see if any ad servers being blocked. I will try and see if my firewall limits anything, but I don't think I ever set anything there either.

BTW, I don't need to reboot to activate changes in the hosts file, do I?

I looked in my c:\windows\system32\drivers\hosts file. The entries in there were: 127.0.0.1 quantserve.com 127.0.0.1 pixel.quantserve.com 127.0.0.1 edge.quantserve.com 127.0.0.1 localhost ::1 localhost I commented those first three out (by placing the pound sign # in front of them), resaved hosts, and opened a new firefox window, but still not video playing. I assume I have the correct hosts file? (although from my memory, not always good, I thought it was .hosts?) I've never set parental controls up. I will poke around in my f-secure antivirus to see if any ad servers being blocked. I will try and see if my firewall limits anything, but I don't think I ever set anything there either. BTW, I don't need to reboot to activate changes in the hosts file, do I?

mnalep மூலமாக திருத்தப்பட்டது

பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Well I found my firewall setting under F-secure antivirus.

I was not sure I understood what the software was showing/telling me.

Then I noticed different profiles were selectable for the firewall. The one I was set on was called "office".

One of the profiles was called 'allow all'. So I picked that one temporarily, and tried to view that video, but no luck. I also tried a profile called 'home', which did not help either.

Well I found my firewall setting under '''F-secure antivirus'''. I was not sure I understood what the software was showing/telling me. Then I noticed different profiles were selectable for the firewall. The one I was set on was called "'''office'''". One of the profiles was called ''''allow all''''. So I picked that one temporarily, and tried to view that video, but no luck. I also tried a profile called ''''home'''', which did not help either.

mnalep மூலமாக திருத்தப்பட்டது

jscher2000
  • Top 10 Contributor
8684 தீர்வுகள் 70998 பதில்கள்
பதிவிடப்பட்டது

Could I suggest another Firefox experiment? To test how Firefox runs "uncustomized" on your system:

Create a new Firefox profile

A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also should have completely fresh settings databases and a fresh cache folder.

Exit Firefox and start up in the Profile Manager using Start > search box (or Run):

firefox.exe -P

Any time you want to switch profiles, exit Firefox and return to this dialog.

You'll click the Create Profile button. I recommend using the default location suggested, and to avoid data loss, not re-using any existing folder. Then start Firefox in the new profile you created.

Does the Daily Show video play in the new profile on first run? If it plays on first run, if you exit Firefox and start it again, does it still play?

When returning to the Profile Manager to switch back to your regular profile, you might be tempted to use the Delete Profile button. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong.

Could I suggest another Firefox experiment? To test how Firefox runs "uncustomized" on your system: '''Create a new Firefox profile''' A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also should have completely fresh settings databases and a fresh cache folder. Exit Firefox and start up in the Profile Manager using Start > search box (or Run): firefox.exe -P Any time you want to switch profiles, exit Firefox and return to this dialog. You'll click the Create Profile button. I recommend using the default location suggested, and to avoid data loss, not re-using any existing folder. Then start Firefox in the new profile you created. Does the Daily Show video play in the new profile on first run? If it plays on first run, if you exit Firefox and start it again, does it still play? When returning to the Profile Manager to switch back to your regular profile, you might be tempted to use the Delete Profile button. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

The only other place I could think to look was under firefox/tools/options/security - and I did have the first 3 boxes checked.

The 2nd and 3rd boxes indicated for Firefox to block "reported attack sites" and block "reported web forgeries". I tried unchecking those, but that did not help when I went to the tab and tried that video web page again. (I did not restart Firefox though to test).

The only other place I could think to look was under firefox/tools/options/security - and I did have the first 3 boxes checked. The 2nd and 3rd boxes indicated for Firefox to block "reported attack sites" and block "reported web forgeries". I tried unchecking those, but that did not help when I went to the tab and tried that video web page again. (I did not restart Firefox though to test).
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I can try that.

Will starting up in a new profile 'delete' and tabs or history in my current profile (session.

I can try that. Will starting up in a new profile 'delete' and tabs or history in my current profile (session.
jscher2000
  • Top 10 Contributor
8684 தீர்வுகள் 70998 பதில்கள்
பதிவிடப்பட்டது

Hi mnalep, creating a new profile creates an independent settings folder. When you go back and start Firefox in your current profile, it will be just as you left it.

Hi mnalep, creating a new profile creates an independent settings folder. When you go back and start Firefox in your current profile, it will be just as you left it.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

OK, I tried that. Ran "firefox.exe -P", and created a new Default User profile.

It was indeed a new profile, as my open tabs were not in this new session.

I went to that page again,

http://www.colbertnation.com/full-episodes/wed-january-15-2014-gabriel-sherman

and once again no video played.

OK, I tried that. Ran "firefox.exe -P", and created a new Default User profile. It was indeed a new profile, as my open tabs were not in this new session. I went to that page again, http://www.colbertnation.com/full-episodes/wed-january-15-2014-gabriel-sherman and once again no video played.
jscher2000
  • Top 10 Contributor
8684 தீர்வுகள் 70998 பதில்கள்
பதிவிடப்பட்டது

Hi mnalep, thanks for testing the new profile. That continues to point to something external to Firefox, but I don't know why it only affects Firefox. Hopefully someone else has a thought on that.

Hi mnalep, thanks for testing the new profile. That continues to point to something external to Firefox, but I don't know why it only affects Firefox. Hopefully someone else has a thought on that.
cor-el
  • Top 10 Contributor
  • Moderator
17466 தீர்வுகள் 157836 பதில்கள்
பதிவிடப்பட்டது

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Cor-el, I booted to windows safe mode with networking, still no video.

Cor-el, I booted to windows safe mode with networking, still no video.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

It just occured to me to try this page on a 2nd pc I have. On that pc I can see the video using firefox.

The 2nd pc is running windows xp, while the 1st that won't view the video is under windows vista.

I started poking around looking for differences. I did find a few things and I wonder what you both thought.

1) When I right click on the video window, and then select Global Settings, and then click the Advanced Tab, there is a difference. On the Xp computer it shows I have the Activex Version (of Flash Player) set to 11.9.900.170. It shows the same version for Plug-In version. However, on my Vista computer that Global setting says 'Not installed' for the Activex version. Could that be an issue?

2) I noticed that in my addons on the XP computer, I have a plugin called windows media player, which I do not have on my Vista computer. Might that be related? (The Plugin is actually called "Windows Media PLayer Plug-In Dynamic Link Library 3.2.2.629" and shows as a File name of 'npdsplay.dll"

3) I clicked on the a link at the bottom of the 'thedailyshow.com' that was labeld "Ad Choices" (It's the last link at the bottom of the page under the column called "Legal & Business". That took me to a page from 'srp.Viacom.com/sitefaq.html" that had a link to 'www.aboutads.info'. Clicking on that link opens a page that starts running a 'Check' of the Advertising companies that are either 'opted into' or 'Existing Opt Outs'. I saw that the XP computer that does run the video, had Zero (0) - 'Existing Opt Out' advertising sites, but my Vista computer had Thirteen (13) sites marked to Opt out of. I wanted to test opting back in, but there seems to be no mechanism on that page to 'opt back into' for those 13 advertisers. Do you know how this page works, or think that by opting out of those 13 sites that prevents Firefox from playing the videos?

I am wondering what both your PC's have for these three things? BTW, Thanks for helping !

It just occured to me to try this page on a 2nd pc I have. On that pc I can see the video using firefox. The 2nd pc is running windows xp, while the 1st that won't view the video is under windows vista. I started poking around looking for differences. I did find a few things and I wonder what you both thought. 1) When I right click on the video window, and then select Global Settings, and then click the Advanced Tab, there is a difference. On the Xp computer it shows I have the Activex Version (of Flash Player) set to 11.9.900.170. It shows the same version for Plug-In version. However, on my Vista computer that Global setting says 'Not installed' for the Activex version. Could that be an issue? 2) I noticed that in my addons on the XP computer, I have a plugin called windows media player, which I do not have on my Vista computer. Might that be related? (The Plugin is actually called "Windows Media PLayer Plug-In Dynamic Link Library 3.2.2.629" and shows as a File name of 'npdsplay.dll" 3) I clicked on the a link at the bottom of the 'thedailyshow.com' that was labeld "Ad Choices" (It's the last link at the bottom of the page under the column called "Legal & Business". That took me to a page from 'srp.Viacom.com/sitefaq.html" that had a link to 'www.aboutads.info'. Clicking on that link opens a page that starts running a 'Check' of the Advertising companies that are either 'opted into' or 'Existing Opt Outs'. I saw that the XP computer that does run the video, had Zero (0) - 'Existing Opt Out' advertising sites, but my Vista computer had Thirteen (13) sites marked to Opt out of. I wanted to test opting back in, but there seems to be no mechanism on that page to 'opt back into' for those 13 advertisers. Do you know how this page works, or think that by opting out of those 13 sites that prevents Firefox from playing the videos? I am wondering what both your PC's have for these three things? BTW, Thanks for helping !

mnalep மூலமாக திருத்தப்பட்டது

cor-el
  • Top 10 Contributor
  • Moderator
17466 தீர்வுகள் 157836 பதில்கள்
பதிவிடப்பட்டது

You usually opt-out via a special cookie stored on the computer, so you may have cookies stored from those advertising companies.

You can inspect and manage the permissions for all domains on the about:permissions page or for the domain in the currently selected tab via these steps:

  • Click the "Site Identity Button" (globe/padlock) on the location bar
  • Click "More Information" to open Page Info
  • Go to the Permissions tab
  • Tools > Page Info > Permissions

You can try to remove all cookies and possibly reset permissions.

You can delete the permissions.sqlite file to reset all permissions.

You can use this button to go to the Firefox profile folder:


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem.

You usually opt-out via a special cookie stored on the computer, so you may have cookies stored from those advertising companies. You can inspect and manage the permissions for all domains on the <b>about:permissions</b> page or for the domain in the currently selected tab via these steps: *Click the "Site Identity Button" (globe/padlock) on the location bar *Click "More Information" to open Page Info *Go to the Permissions tab *Tools > Page Info > Permissions *https://support.mozilla.org/kb/how-do-i-manage-website-permissions You can try to remove all cookies and possibly reset permissions. *http://kb.mozillazine.org/Cookies *https://support.mozilla.org/kb/Deleting+cookies You can delete the permissions.sqlite file to reset all permissions. You can use this button to go to the Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox ----- Create a new profile as a test to check if your current profile is causing the problems. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer some files from an existing profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox