Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I've updated to FF26 and get the follow error message "Secure Connection Failed" why is that?

  • 20 பதிலளிப்புகள்
  • 267 இந்த பிரச்னைகள் உள்ளது
  • 13486 views
  • Last reply by jscher2000

ever since I've updated to FF26 some of the sites won't come up and show the following error message:

Secure Connection Failed

An error occurred during a connection to www.facebook.com. SSL peer rejected a handshake message for unacceptable content. (Error code: ssl_error_illegal_parameter_alert)

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site.

it does not happens all the time but most of the times. this also occurs on google.com, twitter.com and many more. what to do?

roey_nissim மூலமாக திருத்தப்பட்டது

All Replies (20)

Hi roey, If your getting the error there must be a installation problem or your date is set to old check that is upto date your system and this doesn't work re install firefox ...and download from the mozilla site http://www.mozilla.org/en-US/

Can i reinstall on top of my installation?

OK I reinstalled FF 26 and the problem still there

That particular error — Error code: ssl_error_illegal_parameter_alert — seems rare on the forums. In one past thread, it was caused by the filtering program NetNanny. See: SSL error illegal handshake.

If no external software is a logical culprit, check these:

(1) Proxy

Try bypassing any proxy server/service by setting "No Proxy" here:

orange Firefox button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings" button

(2) Extensions

Firefox's Safe Mode is a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

I cleared all my cache and set to no proxy and still has the problem, I think it has to do with Kaspersky Security

Hi roey_nissim, there is a thread on the Kaspersky forums mentioning this particular error code: Firefox 26 and HTTPS scan "problem" - Kaspersky Lab Forum.

Yes I read this post (that's how I knew it has to do with FF and Kaspersky) problem is I use Kaspersky Endpoint 8 (business) and not Kaspersky 2013

Roey

Do you have the option to turn off the feature of Kaspersky scanning your SSL traffic? Usually that can be turned off (e.g., in ESET and BitDefender).

I have this problem too. And I use Kaspersky Endpoint 8 (business). I can't disable this due to corporate security policies. In previous versions of FF error was not present.

I have this problem without any Kaspersky being used. The only antivirus is "Microsoft Security Essentials". The problem happens on regular Windows Server 2008 Standard

Anyway there is a bugreport with more details about the problem (but no solution so far unfortunately): https://bugzilla.mozilla.org/show_bug.cgi?id=951156

I may have this problem with no linux anti-virus installed. Linux Fedora-19/20 (20 is latest), Firefox 26 is able to reliably access the Wikipedia only in safe mode. The only add-on installed and available in not-safe mode is Adblock Plus.

Hi DougHuffman, what error do you get trying to access Wikipedia in regular mode? Is it a security error or page not found, etc.? Could you try adding an exception in Adblock Plus to see whether that makes a difference?

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

A freeze and crash of the FF browser with no crash reported and no Crash Reporter apparent in the installation.

If the comment about "Forget About This Site" is directed at me, thanks. My preferred configuration of FF is extreme privacy and security, never remembering anything except bookmarks.

As far as I can tell, it is the presence of any hypothetically effective add-on that causes/contributes to the crash. While I was installing, testing and removing add-ons, Adblock Plus seemed the least likely to cause a crash, my notes said 'inconsistent'.

Thanks for y'all's interest.

What kind of error do you get?

Does Firefox show the usual net error page or do you get another error?

What does it say under the technical details if you get the error page?

Perhaps I do not understand your question.

Firefox freezes and crashes, as far as I can tell, completely, without Crash Reporter appearing, and with no data recorded in about:crashes. A manual restart is required.

Fedora linux has an Automatic Bug Reporting Tool that does note the crash and which upload is typically tens of megaBytes that I am not competent to read. The data is on Bugzilla Fedora under my name.

What, please, is "the error page"?

Hi DougHuffman, I suggest you start a new thread. This is getting very far from the original question about a certificate error.

https://support.mozilla.org/en-US/questions/new/desktop/fix-problems

Scroll down past the suggestions to continue with the 3-part form.

Hi roey_nissim, for version 8.x, Kaspersky will provide a patch, and users trying it have reported that it fixes the problem, but it needs to be requested through your company's support account: http://forum.kaspersky.com/index.php?showtopic=282684