Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I know that I did not change anything in my Toshiba laptop, before Thankgiving I couldn't get my Firefox to come up, now I have to give my putter permission to

  • 9 பதிலளிப்புகள்
  • 4 இந்த பிரச்னைகள் உள்ளது
  • 613 views
  • Last reply by Wesley Branton

My user control asks if I want to allow Firefox. I went into my user control and it hadn't changed. Never had this problem before and I have been using Firefox for a long time. How do I fix this???

தீர்வு தேர்ந்தெடுக்கப்பட்டது

I am glad to hear that your problem has been resolved.

I hope you continue using our products and thank you for contacting Mozilla Support.

Read this answer in context 👍 0

All Replies (9)

Are you running your computer as the administrator?


I've also noticed that there is a user.js file located inside of your Firefox application data.
This is usually created by a third party program and can effect how Firefox operates.
Please delete this file.


WARNING: Removing folders/files can cause damage to other programs and the Windows operating system. use caution when manually deleting folders/files. Creating a backup of any deleted files is highly recommended!

I found these with a google search on "UAC Firefox":

Chosen solution
Check that you do not run Firefox as Administrator.

Right-click the Firefox desktop shortcut and choose "Properties".
In the Compatibility tab, make sure that Privilege Level: "Run this program as Administrator" is not selected.
You also need to check the Properties of the firefox.exe program in the Firefox program directory. 
1. Right click your shortcut for FireFox, not the actual exe but the shortcut.
2. Select "properties"
3. This should bring you to the "Shortcut" tab.
4. Click advanced and uncheck "run as adminitrator"

Does that help?

I checked and (run as administrator) was not checked, I could live with it, but it's annoying. What else can I try?

The Troubleshoot and diagnose Firefox problems article has other suggestions.

Please review your settings for other users using the computer.
Ensure that they have full access to Firefox.

One reason I suggested the Troubleshoot and diagnose Firefox problems article is because it includes things like troubleshooting extensions. This is from /questions/696275#answer-149331 Firefox will not open without User Account Control asking if I will allow it to make changes on my computer.
Quote: Depends on the configuration of your machine's other settings. In my case, and with a Dell Vostro laptop, all I had to do was disable the "Digital Persona Extension" in Tools -> Add-ons -> Extensions section. There was no need to adjust anything else with UAC or the firefox.exe or its shortcut properties. :)

It might also help if you could give the exact text of the message that you are seeing each time you start Firefox and include a screenshot, if possible. See How do I create a screenshot of my problem?

AliceWyman மூலமாக திருத்தப்பட்டது

Hi Alice,

    I no longer get the little windows permission box coming up since I went into the start menu and clicked on the default programs. Ounce in there it was all changed, so I put it back to where it had been. It was under the program access and defaults. I did have a (user.js) which I deleted from putting it into my search programs.

As always, Pat

Pat, Thanks for reporting back that you fixed the problem by reconfiguring your "Program Access and Defaults" settings in the Windows Start menu's "Default Programs" options.

Something on that is mentioned in http://kb.mozillazine.org/Default_browser#Using_Set_Program_Access_and_Defaults ...and there's a Windows XP screenshot in this article that shows the Set Program Access and Defaults option with the "custom" category selected.

I'll mark your last reply as the solution. Thanks for posting back!

தீர்வு தேர்ந்தெடுக்கப்பட்டது

I am glad to hear that your problem has been resolved.

I hope you continue using our products and thank you for contacting Mozilla Support.