Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox won't load certain pages (such as Google.com) but works in windows safe mode with networking.

  • 22 பதிலளிப்புகள்
  • 58 இந்த பிரச்னைகள் உள்ளது
  • 9440 views
  • Last reply by cor-el

Firefox safe mode does not solve the issue. Disabled and also uninstalled antivirus and firewall and did not help. Disabled all startup items except the ones known not to cause the problem. Other browsers such as Chrome has no problems. Mozilla Thunderbird also will not connect.

All Replies (20)

Hi,

I've tried the link suggested with these results:

Firefox connection settings - I do not connect using a proxy. IPv6, DNS Prefetching, clearing history - tried all the solutions with no luck. I've completed a scan for malware using Malwarebytes with no detections.

Internet Security software blocking Firefox - I have disabled and even uninstalled the antivirus and firewall with no luck.

Would you know if there is a way to compare the programs/processes running in normal mode with windows safe mode because Firefox works fine in windows safe mode?

Have you looked for any suspicious addons in the addon manager (Firefox button/ Orange button => Addons)?

I recognize all the addons I have so I don't think it is the problem. Furthermore, I have started Firefox in safe mode and the problem persists.

Do a malware check with some malware scanning programs on the Windows computer.
Please scan with all programs because each program detects different malware.
All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

I have finished scanning for malware with those programs with no changes to Firefox. Is there anything else I can check?

Hello idgassfy, any luck if you update your drivers ? in windows safe mode only the next devices and drivers starts :

  • Floppy disk drives (internal and USB)
  • Internal CD-ROM drives (ATA, SCSI)
  • External CD-ROM drives (USB)
  • Internal DVD-ROM drives (ATA, SCSI)
  • External DVD-ROM drives (USB)
  • Internal hard disk drives (ATA, SATA, SCSI)
  • External hard disk drives (USB)
  • Keyboards (USB, PS/2, serial)
  • Mice (USB, PS/2, serial)
  • VGA display cards (PCI, AGP)
  • Network Adapters (wired Ethernet and wireless 802.11x)
  • Dynamic Host Configuration Protocol (DHCP)
  • DNS
  • Network Connections
  • TCP/IP-NetBIOS Helper
  • Windows Firewall


thank you

ARAMVA097, the link you provided gave me a hint with "The problem only happens on a secure (https) website", however I don't get the error messages that are suggested.

On a side note, this could also explain why Thunderbird doesn't work for me either, so the problem affects all Mozilla products which probably eliminates any solutions for Firefox only.

Ideato, I don't see anything in the drivers that may be causing the problem

Hello idglassfy,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information.
Note: This will cause you to lose any Extensions and some Preferences.

  • Open websites will not be saved in Firefox versions lower than 25.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

Thank you.

Hi idgassfy, regarding HTTP vs. HTTPS sites, does it work/fail even on the same page? You can test with this page (it works with either):

http://jeffersonscher.com/res/jstest.php

https://jeffersonscher.com/res/jstest.php

It is possible that your security software (firewall, anti-virus) blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:


See also;

patrickmc- resetting firefox was one of the first things I did and it did not solve the problem

jscher2000 - the http site works but the https site does not work

cor-el - using Enum Process, I was able see what processes were running. I disabled and even uninstalled my antivirus and firewall programs but this still did not solve the issue

At any point did you try reinstalling Firefox? To remove stray components that might have been dropped into the Firefox program folder at some point, you can rename that folder before running the installer again. This probably requires administrator privileges.

  • Exit Firefox and rename the program folder, for example: C:\Program Files (x86)\Mozilla Firefox to C:\Program Files (x86)\OldFox
  • Run the installer

Note: I am not suggesting to remove your personal data, or to run any uninstallers, or to run any cleaners, etc. This is purely meant to refresh the program files. Nevertheless, you might want to make a backup of your settings folders, both your active profile folder and the older ones on your desktop in the Old Firefox Data folder (if you still have that from your Reset).

I have tried your suggestion to reinstall Firefox with no luck.

I know you said you do not connect using a proxy, but if you didn't try manually switching from "Use system proxy settings" (default setting) to "No proxy" I suggest trying that.

orange Firefox button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings" button

I tried changing the proxy setting, still no luck.

I have no capabilities to do any functions, no tool options, gear options, no way to access history on Firefox, so all of the instructions here are useless.

When I try to get a google homepage, it gives me instructions for google chrome instead of Firefox. Why would Firefox do that if I'm trying to use firefox? This is baffling.

There is no capability to do or fix anything on firefox. I have downloaded it several times and all I get is a glitch shell of what this browser should be. What on earth has happened?

  1. 1
  2. 2