Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Shift+Ctrl+T does not work anymore. I tried uninstalling and reinstalling and it still won't work. I can't find any other answers.

  • 11 பதிலளிப்புகள்
  • 38 இந்த பிரச்னைகள் உள்ளது
  • 8898 views
  • Last reply by bbrez1

Today, I noticed that opening a previously closed tab will not work anymore. This feature is crucial to my work. I've tried uninstalling Firefox and reinstalling and it did not help. Under History, Recently Closed Tabs and Recently Closed Windows are grayed out. I have my history settings set to remember.

I cannot figure out what's wrong and I need my Shift+Ctrl+T back.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Your System Details List shows that you have set the two prefs that control restoring closed tabs and windows are set to 0:

  • browser.sessionstore.max_tabs_undo: 0
  • browser.sessionstore.max_windows_undo: 0

You can reset all browser.sessionstore.*prefs that appear bold (user set) to the default value via the right-click context menu.

You can check if you have an user.js file in the Firefox profile folder that sets prefs like browser.sessionstore.resume_session_once pref to true.

Note that your System Details List shows that you have a user.js file in the profile folder to initialize some prefs on each start of Firefox.

The user.js file is only present if you or other software has created it, so normally it wouldn't be there. you can check its content with a plain text editor if you didn't create this file yourself.

The user.js file is read each time you start Firefox and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

Read this answer in context 👍 2

All Replies (11)

My guess is that one of your installed extensions is at fault.


Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

jeanajellybean, what local do you have for Firefox as this should be fine in say en-US.

The issue is fixed in upcoming Firefox 26.0 and not 25.0/25.0.1

For reading as Bugzilla is not a discussion forum.

Bug 858975 - Shortcut key for Inspector is conflicting with shortcut key for undo close tab

James மூலமாக திருத்தப்பட்டது

I'm in US on 25.01. When is 26.0 coming out?

December 10.

James மூலமாக திருத்தப்பட்டது

The non-keyboard ways are:

  • right-click any open tab > Undo Close Tab
  • History menu > Recently Closed Tabs (choose from list)

the-edmeister: forgot to respond. Tried safe-mode. Didn't do anything.... any other ideas?

jscher2000: Those are grayed out. They are not available options.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Your System Details List shows that you have set the two prefs that control restoring closed tabs and windows are set to 0:

  • browser.sessionstore.max_tabs_undo: 0
  • browser.sessionstore.max_windows_undo: 0

You can reset all browser.sessionstore.*prefs that appear bold (user set) to the default value via the right-click context menu.

You can check if you have an user.js file in the Firefox profile folder that sets prefs like browser.sessionstore.resume_session_once pref to true.

Note that your System Details List shows that you have a user.js file in the profile folder to initialize some prefs on each start of Firefox.

The user.js file is only present if you or other software has created it, so normally it wouldn't be there. you can check its content with a plain text editor if you didn't create this file yourself.

The user.js file is read each time you start Firefox and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

Finally figured out to go to about:config. That would have been helpful.

jeanajellybean மூலமாக திருத்தப்பட்டது

I've recently had the same issue with the US english version of 26.0, and just figured out what was causing it for me: the Tabmix Plus add-on.

I checked the settings mentioned and found the following which I believe are the defaults (by entering about:config in the address bar and pressing <enter>):

   browser.sessionstore.max_tabs_undo: 10
   browser.sessionstore.max_windows_undo: 3 

I launched into safe mode (shift + launch firefox), and found ctrl+shift+t worked as it should to reopen the last closed tab. So I went disabling extensions- all at first, then re-enabled a few at a time and tested each time. Whittled it down to tabmix plus. I tried changing the tab reopening options (including disabling the tabmix plus option altogether), but nothing seemed to work. So I've just left it disabled. May just uninstall, but will likely notify the developer first. I may not need the extension anymore, since this was one of the main features I liked about it, IIRC.

Even if you are not using this extension, if you are experiencing this issue, the troubleshooting process above is still worth your time- especially if the feature works for you in safe mode, but not under normal launch.

Cheers,

Jeff