Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Stop Firefox from opening Google in every new window. I want earlier used pages instead.

  • 3 பதிலளிப்புகள்
  • 6 இந்த பிரச்னைகள் உள்ளது
  • 3113 views
  • Last reply by Ed

Normally I have a specific starting page. From there on I open 4-5 other pages in the same window. This was easy before Firefox 25, as the previous pages were displayed. With the new version this possibility has vanished and been replaced with a Google page. I want to get rid of this page and get the earlier used pages back to click on. If that is not possible, I'd like to get a blank page.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Hello,

I'm not aware of any changes made to the Home Page or the New Tab Page in Firefox 25. It may be that something else has caused the issue.

The New Tab Page is the page that is displayed when you open a new tab in Firefox. By default it should show a number of thumbnail images of websites you have visited recently or have pinned there. More info here:

Customize items on your Firefox New Tab page

This feature has not changed in v25 of Firefox. If you are seeing a Google search page instead of the default New Tab page then something is wrong.

You can reset the setting for the New Tab page by following these instructions:

  • In the URL bar, type about:config and press Enter.
  • The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise! to continue to the about:config page.
  • Type 'browser.newtab.url' in the search box.
  • Right-click the browser.newtab.url preference and choose Reset. It should then change back to the default which is 'about:newtab'.
  • Click OK and close the about:config tab.

You may find that this works for a while but that eventually the problem comes back. I think it is likely that some malware is hijacking your browser and making changes to the settings. This is why the change has been made without your permission in the first place.

You can try these free programs to scan for malware, which work with your existing antivirus software:

I also suggest you do the following:

  • a complete scan with your current anti-virus software.
  • Look at your Firefox Add-ons and Remove any which you didn't install yourself - Disable or remove Add-ons
  • Look at your list of Windows Startup applications and disable any which you think might be related or look suspicious.
  • Look at your list of Windows installed applications and uninstall any that you think might be related or look suspicious.

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

Read this answer in context 👍 1

All Replies (3)

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Hello,

I'm not aware of any changes made to the Home Page or the New Tab Page in Firefox 25. It may be that something else has caused the issue.

The New Tab Page is the page that is displayed when you open a new tab in Firefox. By default it should show a number of thumbnail images of websites you have visited recently or have pinned there. More info here:

Customize items on your Firefox New Tab page

This feature has not changed in v25 of Firefox. If you are seeing a Google search page instead of the default New Tab page then something is wrong.

You can reset the setting for the New Tab page by following these instructions:

  • In the URL bar, type about:config and press Enter.
  • The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise! to continue to the about:config page.
  • Type 'browser.newtab.url' in the search box.
  • Right-click the browser.newtab.url preference and choose Reset. It should then change back to the default which is 'about:newtab'.
  • Click OK and close the about:config tab.

You may find that this works for a while but that eventually the problem comes back. I think it is likely that some malware is hijacking your browser and making changes to the settings. This is why the change has been made without your permission in the first place.

You can try these free programs to scan for malware, which work with your existing antivirus software:

I also suggest you do the following:

  • a complete scan with your current anti-virus software.
  • Look at your Firefox Add-ons and Remove any which you didn't install yourself - Disable or remove Add-ons
  • Look at your list of Windows Startup applications and disable any which you think might be related or look suspicious.
  • Look at your list of Windows installed applications and uninstall any that you think might be related or look suspicious.

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

Thanks eddyc,

that was the solution to the problem. Only this weekend I used Microsoft Safety Scanner as well as Avast and neither showed any malware in the computer. Nevertheless, I'll try a coupple of the others as well.

Many thanks, Tjabbe.

Ok good. I'm glad it is resolved.

The scanners I've had most success with are Malwarebytes and Hitman Pro. If both of those say that your computer is clean then I think you should be ok.