X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Firefox always opens all previous tabs when starting

  • 6 replies
  • 5 இந்த பிரச்னைகள் உள்ளது
  • Last reply by cor-el
பதிவிடப்பட்டது

I've been using Firefox for quite a while, but it has recently begun opening every previously open tab when I restart a session. I only want the tabs I selected for my home page to open. I've tried going to the options and selecting "Show a blank page" on startup, but even that is ignored and all of the prior tabs open on each new start. I've rebooted the computer and restarted Firefox, but the problem remains.

I've been using Firefox for quite a while, but it has recently begun opening every previously open tab when I restart a session. I only want the tabs I selected for my home page to open. I've tried going to the options and selecting "Show a blank page" on startup, but even that is ignored and all of the prior tabs open on each new start. I've rebooted the computer and restarted Firefox, but the problem remains.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Sorry mjuby I missed seeing that you had already tried the fix.

I suggest disabling all your add-ons and testing again. Does that help?

Disable or remove Add-ons

If that doesn't help then please try a Firefox Reset. This puts Firefox back to its default settings. Your bookmarks, history etc will be saved but you will need to reinstall your add-ons.

Refresh Firefox - reset add-ons and settings

Read this answer in context 0

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Shockwave Flash 11.9 r900
  • 5.1.20913.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.8
  • LogMeIn, Inc. Remote Access Components
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

பயன்பாடு

  • Firefox 25.0
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0
  • Support URL: https://support.mozilla.org/1/firefox/25.0/WINNT/en-US/

நீட்சிகள்

  • LogMeIn, Inc. Remote Access Plugin 1.0.0.1024 (LogMeInClient@logmein.com)
  • Norton Toolbar 2013.4.4.3 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62})
  • Norton Vulnerability Protection 12.0.3.2 - 1 ({BBDA0591-3099-440a-AA10-41764D9DB4DB})
  • RoboForm Toolbar for Firefox 7.9.2.5 ({22119944-ED35-4ab1-910B-E619EA06A115})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Adblock Plus 2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}) (Inactive)
  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • NoScript 2.6.8.4 ({73a6fe31-595d-460b-a920-fcc0f8843232}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GT 610
  • adapterDescription2:
  • adapterDeviceID: 0x104a
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.16384
  • driverDate: 10-23-2013
  • driverDate2:
  • driverVersion: 9.18.13.3165
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 610 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131025151332
  • browser.startup.homepage: http://finance.yahoo.com/portfolio/tpf_cOZSwp6xjr1kdsY-/view/v3|http://www.cnbc.com/|http://www.usawks.org/
  • browser.startup.homepage_override.buildID: 20131025151332
  • browser.startup.homepage_override.mstone: 25.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 25.0
  • font.internaluseonly.changed: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1383234501
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.downloads: False
  • privacy.clearOnShutdown.formdata: False
  • privacy.clearOnShutdown.history: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.promptOnSanitize: False
  • privacy.sanitize.sanitizeOnShutdown: True
  • security.mixed_content.block_active_content: False
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1383227222

Misc

  • User JS: Yes
  • Accessibility: Yes
Ed 82 தீர்வுகள் 595 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

Hello,

Please make sure that you have not activated Firefox's restore tabs feature. See the article here:

Configuring session restore

If it is enabled then you can disable it by following the instructions in that article.

I hope that helps. Let me know if not.

Hello, Please make sure that you have not activated Firefox's restore tabs feature. See the article here: [https://support.mozilla.org/en-US/kb/restore-previous-session#w_configuring-session-restore Configuring session restore] If it is enabled then you can disable it by following the instructions in that article. I hope that helps. Let me know if not.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

eddyc,

Thanks for the response. However, as I noted in my original description, I have already selected "Show a blank page" on startup. Originally I had selected "Show my home page," but I changed to "Show a blank page" to try and stop all previous tabs from opening. At no time have I selected "Show my windows and tabs from last time."

eddyc, Thanks for the response. However, as I noted in my original description, I have already selected "Show a blank page" on startup. Originally I had selected "Show my home page," but I changed to "Show a blank page" to try and stop all previous tabs from opening. At no time have I selected "Show my windows and tabs from last time."
Ed 82 தீர்வுகள் 595 பதில்கள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Sorry mjuby I missed seeing that you had already tried the fix.

I suggest disabling all your add-ons and testing again. Does that help?

Disable or remove Add-ons

If that doesn't help then please try a Firefox Reset. This puts Firefox back to its default settings. Your bookmarks, history etc will be saved but you will need to reinstall your add-ons.

Refresh Firefox - reset add-ons and settings

Sorry mjuby I missed seeing that you had already tried the fix. I suggest disabling all your add-ons and testing again. Does that help? [[Disable or remove Add-ons]] If that doesn't help then please try a Firefox Reset. This puts Firefox back to its default settings. Your bookmarks, history etc will be saved but you will need to reinstall your add-ons. [[Reset Firefox – easily fix most problems]]
பதிவிடப்பட்டது

உதவிகரமான பதில்

Disabling the Add-ons didn't help, but the Firefox reset fixed the problem.

Thank you!

Disabling the Add-ons didn't help, but the Firefox reset fixed the problem. Thank you!
Ed 82 தீர்வுகள் 595 பதில்கள்
பதிவிடப்பட்டது

Great. Thanks for letting me know and thanks for using Firefox!

Great. Thanks for letting me know and thanks for using Firefox!
cor-el
  • Top 10 Contributor
  • Moderator
17407 தீர்வுகள் 157253 பதில்கள்
பதிவிடப்பட்டது

Note that this issue can be caused by a user.js file (that shows as present in the System Details List) that sets the browser.sessionstore.resume_session_once to true on the about:config page.
You can check this if you still have the "Old Firefox Data" folder on the desktop.

Note that this issue can be caused by a user.js file (that shows as present in the System Details List) that sets the <b>browser.sessionstore.resume_session_once</b> to true on the <b>about:config</b> page.<br /> You can check this if you still have the "Old Firefox Data" folder on the desktop. *http://kb.mozillazine.org/Preferences_not_saved