Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unable to view photos on Instagram properly

  • 37 பதிலளிப்புகள்
  • 541 இந்த பிரச்னைகள் உள்ளது
  • 445 views
  • Last reply by drisley77

When viewing a user's photos on instagram.com/user, I click on one photo and it opens in a new tab (as opposed to popping up in the same tab in middle of the screen). Then, when I 'X' out the new tab and return to the old one with the rest of the photos, I cannot click on anymore. I have to refresh the page each time I want to view a new photo. This does NOT occur when I view the instagram.com/user page using Internet Explorer. Shockwave Flash and all other plug-ins are up to date. I just noticed this issue with Firefox's newest upgrade.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Firefox 23 "unprefixed" the requestAnimationFrame() function. This means that parts of the script that previously didn't run in Firefox now run in Firefox, and the developers might not have tested that.

Now... is there a workaround? Hmmm...

Read this answer in context 👍 11

All Replies (20)

Clear the cache and the cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

I cleared the cache and removed cookies. This did not fix the problem.

The problem also occurs while in Safe Mode, so it is not caused by any extensions. My theme is set to default.

Any other suggestions?

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

I unchecked the "Use hardware acceleration when available" checkbox, as it was, in fact, checked. I then restarted Firefox, and the problem still occurs.

I have already visited the first link and determined that the problem occurs while in Safe Mode, so it is not caused by extensions. My theme is set to default.

I visited the second link, and while I have Windows 8 and the instructions were suited for Windows 7 (there is no "Windows Update") I opened the "Action Center" and it states all drivers are up-to-date and there is no need for any other sort of update.

My problem still occurs. Any other suggestions?

kobe மூலமாக திருத்தப்பட்டது

Created a new profile, problem persists.

I just purchased this new laptop with Windows 8 approximately 60 days ago, so there isn't much on it really. I recently upgraded Firefox and I have not noticed any other issues aside from this one.

No, problem persists.

The problem DOES NOT occur in Internet Explorer, as I previously mentioned. This problem only occurs when using Firefox, and is caused by something unique to the browser.

If you feel strongly about that, write a bug at bugzilla.

Can you post a link to a publicly accessible page that doesn't require authentication (signing on)?

instagram.com/instagram

On Instagram's user page, linked above, again when I click on a photo it opens in a new tab. When I close that tab, I can no longer click on any Instagram photos.. I must refresh the page to click another (which will also open in a completely new tab).

After I have clicked on one photo and try to click on another, I even try "Ctrl +click" and it still will not be viewed. I must refresh the page.

circean மூலமாக திருத்தப்பட்டது

Clicking an image on the page causes a script error (tested in Firefox 23 on Windows 7). This is breaking the page's normal behavior:

Timestamp: 8/11/2013 5:03:35 PM
Error: NS_ERROR_XPC_NOT_ENOUGH_ARGS: Not enough arguments [nsIDOMWindow.requestAnimationFrame]
Source File: http://d36xtkk24g8jdx.cloudfront.net/bluebar/d8a6bc2/cache/modules/lib/fullpage/transitions.js
Line: 11

Now... is there is a workaround? Hmmm...

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Firefox 23 "unprefixed" the requestAnimationFrame() function. This means that parts of the script that previously didn't run in Firefox now run in Firefox, and the developers might not have tested that.

Now... is there a workaround? Hmmm...

Would you suggest I report this to bugzilla? Or to Instagram?

I'd report it to Instagram first. The site probably updates frequently, whereas a fix to Firefox is likely to take at minimum of 6 weeks.

(Also, I can't figure out a way to "hide" the change from the site.)

Thanks very much for all your help! Will do!

There is already a bug about this.

  • Bug 871318 - Image slideshow on Instagram profiles is broken with NS_ERROR_XPC_NOT_ENOUGH_ARGS: Not enough arguments [nsIDOMWindow.requestAnimationFrame]

Good to know. I have reported it to Instagram as well.

I have the exact same issue as the original post. Instagram opens the first image in a new tab, then from that point on, you can't open any more images unless you refresh the page.

Also, I think related, Apple's download page for iTunes, which uses a popup/javascript, won't work on this Firefox 23.01 either. I've tried safe mode, new profile, everything. You click on DOWNLOAD and are forwarded to the THANK YOU page, but no download for iTunes. http://www.apple.com/ca/itunes/download/

I can only use the download page with Internet Explorer.

  1. 1
  2. 2