X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Certain embedded YouTube Videos won't play in FireFox 23

  • 34 replies
  • 154 இந்த பிரச்னைகள் உள்ளது
  • Last reply by cor-el
பதிவிடப்பட்டது

I have YouTube videos embedded on my website and some of them will play and some will not. This happens on both PC and MAC so is not OS specific and all the embedding coding on the website is the same. When I first embedded the videos they all worked, now only certain ones play. The ones that will not play have a black screen and audio only plays.

I have YouTube videos embedded on my website and some of them will play and some will not. This happens on both PC and MAC so is not OS specific and all the embedding coding on the website is the same. When I first embedded the videos they all worked, now only certain ones play. The ones that will not play have a black screen and audio only plays.

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Shockwave Flash 11.8 r800
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • 5.1.20513.0
  • Version 3.17.0.12440
  • Google Talk Plugin Video Accelerator version:0.1.44.24
  • Picasa plugin.
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • Amazon MP3 Downloader Plugin 1.0.17
  • DivX VOD Helper Plug-in
  • DivX Plus Web Player version 2.2.1.2
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Plug-in for Starfield utilities
  • iPhoto6

பயன்பாடு

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:23.0) Gecko/20100101 Firefox/23.0

கூடுதல் தகவல்

பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Again thanks to cor-rel, weevie833, frstsytems and everyone else who has posted. Tried all of the above and still no luck. I am working on both Mac 10.8.4 and a PC running XP. The videos work in every other browser but FF and I can't believe that this isn't a little bigger problem than the few of us on this post are having problems with. Also the idea of going in and having to shut off Flash of any other plugin or add-on to get video to work seems a little extreme even if this were a solution. No one visiting a site would take the time to do this just to view a video on someones website to glean some information. I am sure this will be fixed by FF but it just seems to be taking longer than it should considering video is such an integral part of everyone's online experience these days. Hopefully this will be resolved soon. lajollacreative.com

Again thanks to cor-rel, weevie833, frstsytems and everyone else who has posted. Tried all of the above and still no luck. I am working on both Mac 10.8.4 and a PC running XP. The videos work in every other browser but FF and I can't believe that this isn't a little bigger problem than the few of us on this post are having problems with. Also the idea of going in and having to shut off Flash of any other plugin or add-on to get video to work seems a little extreme even if this were a solution. No one visiting a site would take the time to do this just to view a video on someones website to glean some information. I am sure this will be fixed by FF but it just seems to be taking longer than it should considering video is such an integral part of everyone's online experience these days. Hopefully this will be resolved soon. lajollacreative.com
weevie833 0 தீர்வுகள் 5 பதில்கள்
பதிவிடப்பட்டது

What he said! This needs to be remedied quickly!

What he said! This needs to be remedied quickly!
Robert Lang 0 தீர்வுகள் 5 பதில்கள்
பதிவிடப்பட்டது

weevie833 Here are your steps:

1. Grab the embed code for which ever video you want to display from Youtube. There is a link for this underneath the video on Youtube. Copy it and paste it in your html editor box on whichever CMS you are using. Or if you are still making webpages with a html auditor, just copy and paste like you have always been doing.

Here is an example of ebed code:

[embed]<iframe width="896" height="510" src="http://www.youtube.com/embed/iZ9WP9aiflY?feature=player_embedded&rel=0" frameborder="0" allowfullscreen></iframe>[embed]

2. You will find all embed codes to be of a non-secured nature (http protocol) All you have to do once you paste your embed code into your html author tool of choice as mentioned in #1, is type in a small "s" (no quotes). Save and publish. Now look at your page. The video displays.

I am using the latest FF build, V.23.0.1. Also, frsystems has pointed out, disable old addons. FF already does this when you update. But check your addons anyways.

My advice (take it or leave it): I can tell you from tens years of using FF, it is a voluntary by donations funded product. It has been very effective in some cases. I used Netscape for six years before FF. But as of the last few years, Google Chrome is a my browser of choice. I hated switching. I switched, because FF is a slow cow. Chrome is gaining market share, because it is structured differently.

Specifically, you can see this with your own eyes when you use the task manager in Windows. And look at the processes tab. Sort by name. FF uses one program to hold all the RAM memory in. It uses a lot of threads to keep it going. But it is never enough. As time moves on, FF uses more and more RAM. This is known as, a "memory leak." This is notorious with FF for the past five plus years. Have you noticed the message at the bottom of FF now when a page takes too long to load? FF's solution is for you to disable some addons. This is service? This is supposed to be a fix?

On the other hand, Chrome uses just as much RAM, but with one huge difference. It creates a separate process for each tab opened, as if it were another entirely separate software application. This allows Chrome to take advantage of the number of threads it requires and assign them to each tab. It is programmed to use threads per tab, not the entire browser application. Whereas, FF can't do this and hits the threads limit programmed in FF.

Thread limits are necessary, because without them, your OS would freeze or lock up. Further, when you close tabs in Chrome, it releases the RAM used for that tab back into your system. Whereas FF does not do this. At first I was upset Chrome was doing this. But realized when I added up the RAM used, it was the same. But the thread count was much much higher! Which is why Chrome is so fast compared to FF. Threads are like pipelines. The more threads a program has, the faster it can process data.

I can assure you I am not a fan of "one browser fits all." I am a programmer and designer, who must please four main browsers on every product build. If I could, I would use just one browser and be done with it. But this is not how the consumer world uses browsers. Depending how a person was sold whichever OS they bought, determines their initial choice. Most have I.E. and Safari. Only after learning about browsers with more choices, do they find FF. But many switch again to Chrome, because it is at least 200% faster! Due to allocating thread resources per tab.

So, if you are recommending browsers, I suggest you try Chrome and prove it to yourself. See how fast it will load pages for you. That is the real test. Your students will love it. And you can import all your bookmarks as with any browser platform. To date, I see all four browsers for the above reasons mentioned. I have to, because consumers use all four browsers. Apparently Opera is also supposed to be fast. But Chrome is backed up by a lot of money, and it will never be a dog product. It has all the addons I use in FF. Almost that is. As the years progress here, Chrome will outpace FF, until they structure their product like Chrome has.

weevie833 Here are your steps: 1. Grab the embed code for which ever video you want to display from Youtube. There is a link for this underneath the video on Youtube. Copy it and paste it in your html editor box on whichever CMS you are using. Or if you are still making webpages with a html auditor, just copy and paste like you have always been doing. Here is an example of ebed code: [embed]<iframe width="896" height="510" src="http://www.youtube.com/embed/iZ9WP9aiflY?feature=player_embedded&rel=0" frameborder="0" allowfullscreen></iframe>[embed] 2. You will find all embed codes to be of a non-secured nature (http protocol) All you have to do once you paste your embed code into your html author tool of choice as mentioned in #1, is type in a small "s" (no quotes). Save and publish. Now look at your page. The video displays. I am using the latest FF build, V.23.0.1. Also, frsystems has pointed out, disable old addons. FF already does this when you update. But check your addons anyways. My advice (take it or leave it): I can tell you from tens years of using FF, it is a voluntary by donations funded product. It has been very effective in some cases. I used Netscape for six years before FF. But as of the last few years, Google Chrome is a my browser of choice. I hated switching. I switched, because FF is a slow cow. Chrome is gaining market share, because it is structured differently. Specifically, you can see this with your own eyes when you use the task manager in Windows. And look at the processes tab. Sort by name. FF uses one program to hold all the RAM memory in. It uses a lot of threads to keep it going. But it is never enough. As time moves on, FF uses more and more RAM. This is known as, a "memory leak." This is notorious with FF for the past five plus years. Have you noticed the message at the bottom of FF now when a page takes too long to load? FF's solution is for you to disable some addons. This is service? This is supposed to be a fix? On the other hand, Chrome uses just as much RAM, but with one huge difference. It creates a separate process for each tab opened, as if it were another entirely separate software application. This allows Chrome to take advantage of the number of threads it requires and assign them to each tab. It is programmed to use threads per tab, not the entire browser application. Whereas, FF can't do this and hits the threads limit programmed in FF. Thread limits are necessary, because without them, your OS would freeze or lock up. Further, when you close tabs in Chrome, it releases the RAM used for that tab back into your system. Whereas FF does not do this. At first I was upset Chrome was doing this. But realized when I added up the RAM used, it was the same. But the thread count was much much higher! Which is why Chrome is so fast compared to FF. Threads are like pipelines. The more threads a program has, the faster it can process data. I can assure you I am not a fan of "one browser fits all." I am a programmer and designer, who must please four main browsers on every product build. If I could, I would use just one browser and be done with it. But this is not how the consumer world uses browsers. Depending how a person was sold whichever OS they bought, determines their initial choice. Most have I.E. and Safari. Only after learning about browsers with more choices, do they find FF. But many switch again to Chrome, because it is at least 200% faster! Due to allocating thread resources per tab. So, if you are recommending browsers, I suggest you try Chrome and prove it to yourself. See how fast it will load pages for you. That is the real test. Your students will love it. And you can import all your bookmarks as with any browser platform. To date, I see all four browsers for the above reasons mentioned. I have to, because consumers use all four browsers. Apparently Opera is also supposed to be fast. But Chrome is backed up by a lot of money, and it will never be a dog product. It has all the addons I use in FF. Almost that is. As the years progress here, Chrome will outpace FF, until they structure their product like Chrome has.
weevie833 0 தீர்வுகள் 5 பதில்கள்
பதிவிடப்பட்டது

I am a big fan of Chrome personally, and I made the switch years ago. But Chrome does not play well with Moodle LMS. Also, as an institution, we need a sustainable solution that does not involve directing instructors (who are nominally tech literate) to place an "s" in the right place. Thanks for your input.

I am a big fan of Chrome personally, and I made the switch years ago. But Chrome does not play well with Moodle LMS. Also, as an institution, we need a sustainable solution that does not involve directing instructors (who are nominally tech literate) to place an "s" in the right place. Thanks for your input.
Robert Lang 0 தீர்வுகள் 5 பதில்கள்
பதிவிடப்பட்டது

Well I'm not sure you are able to get around this then, because the embed code YouTube serves up is non-secured as a default. This issue btw, is only present in FF, not Safari, I.E., or Chrome.

For FF to work, you are going to have to wait for an update once again. And this will only happen if you contact them about your issue. In the meantime, you have a solution to this issue. Your choice. Use it or wait, while none of your videos display correctly.

Well I'm not sure you are able to get around this then, because the embed code YouTube serves up is non-secured as a default. This issue btw, is only present in FF, not Safari, I.E., or Chrome. For FF to work, you are going to have to wait for an update once again. And this will only happen if you contact them about your issue. In the meantime, you have a solution to this issue. Your choice. Use it or wait, while none of your videos display correctly.
weevie833 0 தீர்வுகள் 5 பதில்கள்
பதிவிடப்பட்டது

Gee, robertlang. You don't have to be a schmuck about it. I'm working in the trailing edge of public college technology literacy. I don't control the wanton ways of 3000+ people and their browser problems, but I do the best I can. It's too bad these kinds of changes have such profound ramifications - even if our best interests are intended for a secure browsing experience. As others have commented, the fact that it involves YouTube is a MAJOR concern.

I's appreciate your input on these things, but without the snark.

Gee, robertlang. You don't have to be a schmuck about it. I'm working in the trailing edge of public college technology literacy. I don't control the wanton ways of 3000+ people and their browser problems, but I do the best I can. It's too bad these kinds of changes have such profound ramifications - even if our best interests are intended for a secure browsing experience. As others have commented, the fact that it involves YouTube is a MAJOR concern. I's appreciate your input on these things, but without the snark.
Robert Lang 0 தீர்வுகள் 5 பதில்கள்
பதிவிடப்பட்டது

Thats whats wrong with the written word, making statements of fact are viewed by others as subjective remarks. When they are not, they are facts. i.e., Your choices as previously outlined. You came here for solutions. You have one. You don't want to use it, fine.

There is no further solution for you. Either change the embed code, or wait for FF dev team to modify, or switch browsers, or continue without video via FF ( all other browsers work), or consider a different delivery container for your videos.

Now take a good look at the last paragraph. Can you see anything in that paragraph which is subjective? Is there anywhere I have mislead you? Is there anything you can see where I have been disrespectful to you in my answer?

Then it is you sir/madam who needs to check you attitude at the keyboard, before you come here and make subjective remarks towards other forum members, because you don't like my answer nor my delivery.

This issue is "on hold". There is no further developments from FF Dev Team at this time. Please be patient. The issue stands 'open" and unresolved until further notice. Until that time, you have many options. Whether you want to use any or all them is entirely at your discretion.

Thats whats wrong with the written word, making statements of fact are viewed by others as subjective remarks. When they are not, they are facts. i.e., Your choices as previously outlined. You came here for solutions. You have one. You don't want to use it, fine. There is no further solution for you. Either change the embed code, or wait for FF dev team to modify, or switch browsers, or continue without video via FF ( all other browsers work), or consider a different delivery container for your videos. Now take a good look at the last paragraph. Can you see anything in that paragraph which is subjective? Is there anywhere I have mislead you? Is there anything you can see where I have been disrespectful to you in my answer? Then it is you sir/madam who needs to check you attitude at the keyboard, before you come here and make subjective remarks towards other forum members, because you don't like my answer nor my delivery. This issue is "on hold". There is no further developments from FF Dev Team at this time. Please be patient. The issue stands 'open" and unresolved until further notice. Until that time, you have many options. Whether you want to use any or all them is entirely at your discretion.
MadAmster 0 தீர்வுகள் 4 பதில்கள்
பதிவிடப்பட்டது

I too had this problem. After trying all manner of repair methods I found on the net that didn't work, I uninstalled AdBlock Pro.

I can now view the previously unviewable videos.

I too had this problem. After trying all manner of repair methods I found on the net that didn't work, I uninstalled AdBlock Pro. I can now view the previously unviewable videos.
coreyworrell 0 தீர்வுகள் 1 பதில்கள்
பதிவிடப்பட்டது

Try adding wmode=transparent to the query string of the YouTube embed URL. That's what worked for me.

Try adding '''wmode=transparent''' to the query string of the YouTube embed URL. That's what worked for me.
iantresman 0 தீர்வுகள் 1 பதில்கள்
பதிவிடப்பட்டது

I solved this issue by clearing cookies on www.youtube.com

I solved this issue by clearing cookies on www.youtube.com
Ian.F 1 தீர்வுகள் 62 பதில்கள்
பதிவிடப்பட்டது

lajollacreative and all, hi.

I have only just encountered this thread and perhaps it is too late, but some months ago when I was still using FF23.0 I created a Bob Dylan website off-line for training purposes and encountered, apparently, the same problem as lajollacreative when attempting to play an embedded YouTube video using the code from YouTube.com, but I did solve it very simply; if the cause of my initial problem was the same as lajollacreative's I hope this will help.

Inserting YouTube Videos and why this does not always work:

1) The following code points to Bob Dylan's Unplugged 'Knockin' On Heaven's Door' YouTube Video.

Code from YouTube: <iframe width="480" height="360" src="//www.youtube-nocookie.com/embed/cJpB_AEZf6U" frameborder="0" allowfullscreen></iframe>

THIS WORKS ON THE W3C website (http://www.w3schools.com/html/html_youtube.asp) AS IT IS.

It will be noticed that the URL is missing the 'http:' and when used thus in my Dylan media webpage the YouTube player does not even open let alone play the intended video, unlike in the W3C website: this was true of other YouTube videos also. Evidently the code for any YouTube video is missing the 'http:' but when this is inserted into the code the video works whether using the <iframe>, <embed> or <object> tag code formats.

This said, not all videos will play due to restrictions imposed by the provider - but this is not because the said code is not working and in this latter case a rectangular video screen would appear with a message rather than seeing no screen at all or just a black, blank one. The Dylan unplugged video was a case in point, but it did now open. The following video, however, of another version of 'Knockin' on Heaven's Door' did play.

2) Code from YouTube with privacy-enhanced mode selected from the options:

<iframe width="640" height="360" src="//www.youtube-nocookie.com/embed/-jPg2M1UYgU" frameborder="0" allowfullscreen></iframe>

with 'http:' added,

<iframe width="640" height="360" src="http://www.youtube-nocookie.com/embed/-jPg2M1UYgU" frameborder="0" allowfullscreen></iframe>

I discovered as I wrote this contribution a solution to another problem involving, unexpectedly, https:// that was referred to in an earlier post:

like others recently, using both the latest Firefox and Chrome Youtube videos will not play on the YouTube website, but will do so when embedded in someone else's website, including my off-line Dylan site. When I took the about web address for the Dylan song with the http:// in it and placed it in the address bar it the address was changed in FF to https:// and the video played. So, I found a live version of Clapton's 'Layla' on YouTube that like everything else has refused to play for several weeks and typed https:// in front of the video address in the address bar and the video not only played on the YouTube website, but the playback was really good (I use a dongle and video often lags behind audio, but not now). Worked in Chrome too.

lajollacreative and all, hi. I have only just encountered this thread and perhaps it is too late, but some months ago when I was still using FF23.0 I created a Bob Dylan website off-line for training purposes and encountered, apparently, the same problem as lajollacreative when attempting to play an embedded YouTube video using the code from YouTube.com, but I did solve it very simply; if the cause of my initial problem was the same as lajollacreative's I hope this will help. ''Inserting YouTube Videos and why this does not always work'': 1) The following code points to Bob Dylan's Unplugged 'Knockin' On Heaven's Door' YouTube Video. Code from YouTube: <iframe width="480" height="360" src="//www.youtube-nocookie.com/embed/cJpB_AEZf6U" frameborder="0" allowfullscreen></iframe> THIS WORKS ON THE W3C website (http://www.w3schools.com/html/html_youtube.asp) AS IT IS. It will be noticed that the URL is missing the 'http:' and when used thus in my Dylan media webpage the YouTube player does not even open let alone play the intended video, unlike in the W3C website: this was true of other YouTube videos also. Evidently the code for any YouTube video is missing the 'http:' but when this is inserted into the code the video works whether using the <iframe>, <embed> or <object> tag code formats. This said, not all videos will play due to restrictions imposed by the provider - but this is not because the said code is not working and in this latter case a rectangular video screen would appear with a message rather than seeing no screen at all or just a black, blank one. The Dylan unplugged video was a case in point, but it did now open. The following video, however, of another version of 'Knockin' on Heaven's Door' did play. 2) Code from YouTube with privacy-enhanced mode selected from the options: <iframe width="640" height="360" src="//www.youtube-nocookie.com/embed/-jPg2M1UYgU" frameborder="0" allowfullscreen></iframe> with 'http:' added, <iframe width="640" height="360" src="http://www.youtube-nocookie.com/embed/-jPg2M1UYgU" frameborder="0" allowfullscreen></iframe> I discovered as I wrote this contribution a solution to another problem involving, unexpectedly, https:// that was referred to in an earlier post: like others recently, using both the latest Firefox and Chrome Youtube videos will not play on the YouTube website, but will do so when embedded in someone else's website, including my off-line Dylan site. When I took the about web address for the Dylan song with the http:// in it and placed it in the address bar it the address was changed in FF to https:// and the video played. So, I found a live version of Clapton's 'Layla' on YouTube that like everything else has refused to play for several weeks and typed https:// in front of the video address in the address bar and the video not only played on the YouTube website, but the playback was really good (I use a dongle and video often lags behind audio, but not now). Worked in Chrome too.
JHW_71 0 தீர்வுகள் 2 பதில்கள்
பதிவிடப்பட்டது

If You Tube videos or other embedded videos do not work when you click on them.

In the upper left corner of the URL link bar - there is a little gray shield.

LEFT CLICK IT and a drop down menu will appear - click on the selection that is marked KEEP BLOCKING - and choose - DISABLE PROTECTION ON THIS PAGE.

The videos should work now. It's a security feature that must be manually set by the user.

Hope it works! It did for me

If You Tube videos or other embedded videos do not work when you click on them. In the upper left corner of the URL link bar - there is a little gray shield. LEFT CLICK IT and a drop down menu will appear - click on the selection that is marked KEEP BLOCKING - and choose - DISABLE PROTECTION ON THIS PAGE. The videos should work now. It's a security feature that must be manually set by the user. Hope it works! It did for me

JHW_71 மூலமாக திருத்தப்பட்டது

anurag.sharma 0 தீர்வுகள் 1 பதில்கள்
பதிவிடப்பட்டது

"Mixed Content Blocking Enabled in Firefox 23!" Now because of this ..if you are having a site which is running on HTTPS and you have youtube video embedded as HTTP then ..it will not work..and you keep wondering Why youtube video is not working? its simply because of mix mode issue.. so change your youtube embedded urls as https and it will start working .. have fun..

[youtube url not working on https , youtube url not working in firefox , youtube embedded url not working in firefox]

"Mixed Content Blocking Enabled in Firefox 23!" Now because of this ..if you are having a site which is running on HTTPS and you have youtube video embedded as HTTP then ..it will not work..and you keep wondering Why youtube video is not working? its simply because of mix mode issue.. so change your youtube embedded urls as https and it will start working .. have fun.. [youtube url not working on https , youtube url not working in firefox , youtube embedded url not working in firefox]

anurag.sharma மூலமாக திருத்தப்பட்டது

cor-el
  • Top 10 Contributor
  • Moderator
17578 தீர்வுகள் 159013 பதில்கள்
பதிவிடப்பட்டது
See also: *https://developer.mozilla.org/Security/MixedContent/fix_website_with_mixed_content