X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

firefox closes all windows

  • 27 replies
  • 5 இந்த பிரச்னைகள் உள்ளது
  • Last reply by LoriH57
பதிவிடப்பட்டது

Ever since taking the latest update for Firefox, anytime I click on a link on a page that opens into a new window, if I try to "X" out that second window, it also closes the page I came from. If I manually open another window for whatever purpose, it seems to work fine. It's only when I get a new window from a link in the previous one. BOTH windows always shut down. Not tabs, but windows. It's very annoying if I wasn't done with the first page I was on. I even tried to minimize the second open window, then right clicking from my task bar to close it, but it will still also close the original window I was in when I clicked the link. This has happened on MANY websites I've visited from links.

Ever since taking the latest update for Firefox, anytime I click on a link on a page that opens into a new window, if I try to "X" out that second window, it also closes the page I came from. If I manually open another window for whatever purpose, it seems to work fine. It's only when I get a new window from a link in the previous one. BOTH windows always shut down. Not tabs, but windows. It's very annoying if I wasn't done with the first page I was on. I even tried to minimize the second open window, then right clicking from my task bar to close it, but it will still also close the original window I was in when I clicked the link. This has happened on MANY websites I've visited from links.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Looks like the reinstall did the trick. I'm glad it did, because I honestly didn't like the idea of having to go in and make all those changes being suggested. In my mind, we shouldn't have to do all that, just to get the browser to operate properly. So, I will mark this as being "solved", but will definitely report it again, if the problems re-surface.

Thanks!

Read this answer in context 1

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Google Update
  • Shockwave Flash 11.8 r800
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.20513.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • DivX Plus Web Player version 2.3.0.87
  • RealPlayer Download Plugin
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • NPWLPG
  • Adobe Shockwave for Director Netscape plug-in, version 12.0
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Yahoo Application State Plugin version 1.0.0.7
  • DivX VOD Helper Plug-in

பயன்பாடு

  • Firefox 22.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0
  • Support URL: http://support.mozilla.org/1/firefox/22.0/WINNT/en-US/

நீட்சிகள்

  • avast! Online Security 8.0.1489 (wrc@avast.com)
  • DoNotTrackMe 2.2.9.618 (donottrackplus@abine.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Updated Ad Blocker for Firefox 11+ 0.7.7 ({4DC70064-89E2-4a55-8FC6-E8CDEAE3618C})
  • WOT 20130515 ({a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7})
  • DivX Plus Web Player HTML5 <video> 2.1.2.172 ({23fcfd51-4958-4f00-80a3-ae97e717ed8b}) (Inactive)
  • Grammarly 2.32 (grammar.plugin@grammarly.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 210
  • adapterDescription2:
  • adapterDeviceID: 0x0a65
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 400
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 1-18-2013
  • driverDate2:
  • driverVersion: 9.18.13.1106
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 3
  • numTotalWindows: 3
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 210 )
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.blockautorefresh: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.link.open_newwindow: 2
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.restore_on_demand: False
  • browser.startup.homepage: http://my.yahoo.com/
  • browser.startup.homepage_override.buildID: 20130618035212
  • browser.startup.homepage_override.mstone: 22.0
  • dom.max_chrome_script_run_time: 0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 22.0
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1373752714
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.java: 0
  • plugin.state.npdeployjava: 0
  • plugin.state.nppl: 0
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1372256335

Misc

  • User JS: No
  • Accessibility: No
KatXat 0 தீர்வுகள் 3 பதில்கள்
பதிவிடப்பட்டது

Try the keyboard shortcut Ctrl+w (close tab). If the window you want to close has more than 1 tabs, press ctrl+w multiple times until you close the window.

Try the keyboard shortcut Ctrl+w (close tab). If the window you want to close has more than 1 tabs, press ctrl+w multiple times until you close the window.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

As I said, it's NOT the tabs. I don't like using tabs, therefore, I prefer things open into a new window. Closing the window is not the problem. As I also clearly said, when I do close the window, other windows close TOO!

As I said, it's NOT the tabs. I don't like using tabs, therefore, I prefer things open into a new window. Closing the window is not the problem. As I also clearly said, when I do close the window, other windows close TOO!
ideato 893 தீர்வுகள் 6250 பதில்கள்
பதிவிடப்பட்டது

Hello LoriH, Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Hello LoriH, '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * You can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. ''Once you get the pop-up, just select "'Start in Safe Mode"'' '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' Thank you.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Ok, I have it in safe mode but now, when I click a link TWO windows open for that same link. None of these things happened before latest update was rolled out.

Ok, I have it in safe mode but now, when I click a link TWO windows open for that same link. None of these things happened before latest update was rolled out.
ideato 893 தீர்வுகள் 6250 பதில்கள்
பதிவிடப்பட்டது

Hello,

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise!, to continue to the about:config page.

find/type (or copied from there) the: browser.link.open_newwindow , then double-click on it and change the value to 3 (the default), for some reason you have 2 !

exit firefox and restart it and check it again.

http://kb.mozillazine.org/Browser.link.open_newwindow


thanks again

Hello, # In the [[Location bar autocomplete|Location bar]], type '''about:config''' and press '''Enter'''. The about:config "''This might void your warranty!''" warning page may appear. # Click '''I'll be careful, I promise!''', to continue to the about:config page. find/type (or copied from there) the: '''browser.link.open_newwindow''' , then double-click on it and change the value to '''3''' (the default), for some reason you have 2 ! exit firefox and restart it and check it again. http://kb.mozillazine.org/Browser.link.open_newwindow thanks again
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

That worked for now. I'll keep trying to see what happens, because it never happened every single time I clicked a link. Just MOST of them. I will also have to wait and see if it closes other windows, which was the original problem. It was happening in different windows, not ones that had opened from the same link. But, maybe this fixed that too. I'll give it time before I say the problem is solved. LOL! Thanks!

That worked for now. I'll keep trying to see what happens, because it never happened every single time I clicked a link. Just MOST of them. I will also have to wait and see if it closes other windows, which was the original problem. It was happening in different windows, not ones that had opened from the same link. But, maybe this fixed that too. I'll give it time before I say the problem is solved. LOL! Thanks!

LoriH57 மூலமாக திருத்தப்பட்டது

ideato 893 தீர்வுகள் 6250 பதில்கள்
பதிவிடப்பட்டது

you are welcome

you are welcome
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I just clicked the link in the email notification to get to this thread and when I tried to "X" this window out, it also closed my email window entirely. So obviously, the problem is NOT fixed! SIGH!

I just clicked the link in the email notification to get to this thread and when I tried to "X" this window out, it also closed my email window entirely. So obviously, the problem is NOT fixed! SIGH!
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

good grief, this is starting to get ridiculous. I just clicked the icon to get a new window to open and FOUR windows popped up. Again, none of this happened until I took the latest update, recently. ----***Edited*** And then, after I posted this message, I "X" out the window and it again also closed the window with my email.

good grief, this is starting to get ridiculous. I just clicked the icon to get a new window to open and FOUR windows popped up. Again, none of this happened until I took the latest update, recently. ----***Edited*** And then, after I posted this message, I "X" out the window and it again also closed the window with my email.

LoriH57 மூலமாக திருத்தப்பட்டது

jscher2000
  • Top 10 Contributor
8878 தீர்வுகள் 72633 பதில்கள்
பதிவிடப்பட்டது

By the way, Ctrl+w generally works in a window as well as a tab, in case you want to test that keyboard shortcut suggestion to see whether it behaves differently than the "red X" button.

By the way, Ctrl+w generally works in a window as well as a tab, in case you want to test that keyboard shortcut suggestion to see whether it behaves differently than the "red X" button.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Coming to this page from the email notice did open two windows again, but Ctrl+w worked "this time". However, sometimes, clicking the "X" works, too. I'll just keep trying it throughout the day to see if/when it works. That would solve ONE problem, but not the fact that TWO windows keep opening when I click links.

Coming to this page from the email notice did open two windows again, but Ctrl+w worked "this time". However, sometimes, clicking the "X" works, too. I'll just keep trying it throughout the day to see if/when it works. That would solve ONE problem, but not the fact that TWO windows keep opening when I click links.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

The Cntrl+W seems to work ok for closing a single window (so far. I haven't closed that many today, since I've not had to open many). But I still have the second problem of two (and now sometimes even MORE) windows opening. This is not happening in Chrome or IE (Which I hate to use, but tried it, to see). Again, this problem never happened until after the latest update.

The Cntrl+W seems to work ok for closing a single window (so far. I haven't closed that many today, since I've not had to open many). But I still have the second problem of two (and now sometimes even MORE) windows opening. This is not happening in Chrome or IE (Which I hate to use, but tried it, to see). Again, this problem never happened until after the latest update.
jscher2000
  • Top 10 Contributor
8878 தீர்வுகள் 72633 பதில்கள்
பதிவிடப்பட்டது

Could you clarify the location of the links you are clicking: are these in a page open in a Firefox window/tab, or in another application (e.g., external email software, Adobe Reader, MS Word)?

Do you get different results between these (if the link is in a Firefox window/tab):

  • single left-click
  • Shift + left-click
  • right-click > Open Link in a New Window
Could you clarify the location of the links you are clicking: are these in a page open in a Firefox window/tab, or in another application (e.g., external email software, Adobe Reader, MS Word)? Do you get different results between these (if the link is in a Firefox window/tab): * single left-click * Shift + left-click * right-click > Open Link in a New Window
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

ALL links are opened in a Firefox window. I use Yahoo email and use Firefox for that, too. Sometimes it's a link directly in email, other times, I can be on a site, like CNN, Facebook, etc. etc. and click a link, all still in Firefox and about half the time now, more than one window will open to the exact same page. Most often, I just use single left click, but if I want to make sure the link opens into a new window, I sometimes right click to open a new one. Either way, it will open TWO, about half the time. A prime example is that THIS time, when I clicked the link in the email notice of a reply to come to this page, it only opened ONE window. Most of the time, it opens 2. It varies, but it's always in the Firefox browser.

ALL links are opened in a Firefox window. I use Yahoo email and use Firefox for that, too. Sometimes it's a link directly in email, other times, I can be on a site, like CNN, Facebook, etc. etc. and click a link, all still in Firefox and about half the time now, more than one window will open to the exact same page. Most often, I just use single left click, but if I want to make sure the link opens into a new window, I sometimes right click to open a new one. Either way, it will open TWO, about half the time. A prime example is that THIS time, when I clicked the link in the email notice of a reply to come to this page, it only opened ONE window. Most of the time, it opens 2. It varies, but it's always in the Firefox browser.
jscher2000
  • Top 10 Contributor
8878 தீர்வுகள் 72633 பதில்கள்
பதிவிடப்பட்டது

I'm running out of ideas...

Could it be a physical issue with the mouse or a configuration issue with the mouse driver? Microsoft has some more suggestions in this article: Troubleshoot mouse double-clicking when you single-click.

I'm running out of ideas... Could it be a physical issue with the mouse or a configuration issue with the mouse driver? Microsoft has some more suggestions in this article: [http://support.microsoft.com/kb/266738 Troubleshoot mouse double-clicking when you single-click].
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

My son is a computer tech and I finally talked to him about it. (It's not always easy to pin him down. LOL!) He too, suggested it could be the mouse. So, before I even knew to try what you've suggested, I tried another mouse (a wireless one, whereas my regular mouse is wired) and it still did the same thing. While it still "might" be something with the settings, it is only happening in Firefox. I have purposely tried using Chrome for some of my tasks today, and tried IE yesterday. Not once did I have the problem in either of those browsers. My son told me to try uninstalling and reinstalling FF again, thinking maybe some type of unusual glitch occurred during the last update. I won't have time to do that tonight, but I'll report back tomorrow when I do. Thanks again for all the suggestions. Hopefully this will resolve soon.

My son is a computer tech and I finally talked to him about it. (It's not always easy to pin him down. LOL!) He too, suggested it could be the mouse. So, before I even knew to try what you've suggested, I tried another mouse (a wireless one, whereas my regular mouse is wired) and it still did the same thing. While it still "might" be something with the settings, it is only happening in Firefox. I have purposely tried using Chrome for some of my tasks today, and tried IE yesterday. Not once did I have the problem in either of those browsers. My son told me to try uninstalling and reinstalling FF again, thinking maybe some type of unusual glitch occurred during the last update. I won't have time to do that tonight, but I'll report back tomorrow when I do. Thanks again for all the suggestions. Hopefully this will resolve soon.

LoriH57 மூலமாக திருத்தப்பட்டது

cor-el
  • Top 10 Contributor
  • Moderator
17764 தீர்வுகள் 160655 பதில்கள்
பதிவிடப்பட்டது

You can override how external links are opened via the browser.link.open_newwindow.override.external pref.

The meaning of the values of the browser.link.open_newwindow.override.external are the same as for browser.link.open_newwindow

  • 1: current tab; 2:new window; 3:new tab;
You can override how external links are opened via the browser.link.open_newwindow.override.external pref. The meaning of the values of the browser.link.open_newwindow.override.external are the same as for browser.link.open_newwindow *1: current tab; 2:new window; 3:new tab; *http://kb.mozillazine.org/browser.link.open_newwindow (3) *http://kb.mozillazine.org/browser.link.open_newwindow.restriction (0)
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I'm just going to try the reinstall first. In my mind, if I have to keep making changes to the browser configuration, (already made one change) then something is obviously wrong. There are 2 different problems happening, one with opening multiple windows, and then one with closing multiple ones, (and not just when it opens more than one, sometimes it closes totally unrelated windows). As I said before, this never happened until the latest update roll out, and it doesn't happen in any other browser. I will do the reinstall when I get home later and report back.

I'm just going to try the reinstall first. In my mind, if I have to keep making changes to the browser configuration, (already made one change) then something is obviously wrong. There are 2 different problems happening, one with opening multiple windows, and then one with closing multiple ones, (and not just when it opens more than one, sometimes it closes totally unrelated windows). As I said before, this never happened until the latest update roll out, and it doesn't happen in any other browser. I will do the reinstall when I get home later and report back.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

I reinstalled FF a little while ago and will just have to wait and see how it works. So far, everything I've clicked on has only opened ONE window, or has gone to the page, if not set to open separately. -----And, so far, it is only closing the window I "want" to close, but it's only been about 30 minutes, so I'm not ready to say that it's fixed, just yet.  :)

I reinstalled FF a little while ago and will just have to wait and see how it works. So far, everything I've clicked on has only opened ONE window, or has gone to the page, if not set to open separately. -----And, so far, it is only closing the window I "want" to close, but it's only been about 30 minutes, so I'm not ready to say that it's fixed, just yet. :)
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

So far today, things have gone well, so it looks like the reinstall might have solved both problems. If not, I'll report it again. Thanks!

So far today, things have gone well, so it looks like the reinstall might have solved both problems. If not, I'll report it again. Thanks!