Search Support

I've tried everything--Firefox simply won't open. I opened the troubleshoot articles, but none of the fixes did the trick?

  • 36 பதிலளிப்புகள்
  • 122 இந்த பிரச்னைகள் உள்ளது
  • 35095 views
  • Last reply by cor-el

Firefox will not open. I tried every single troubleshoot recommendation, and it still won't work. I thought it may be under the "corrupt profile data" troubleshoot article, but when I followed the recommendations to change to a new profile, the profile manager would not open or run on my computer--as if it never existed. I tried downloading a different browser, and as soon as I imported my firefox data, it started misbehaving in the exact same way.

This is getting extremely frustrating. Anybody know what to do?


Comment by a forum moderator

See list of helpful information and links in my post under HERE

John99 மூலமாக திருத்தப்பட்டது

All Replies (16)

That is three of you now very recently who have posted in this thread belonging to someone else but have not started your own question.

  1. Read this thread and follow the links to articles, does any of that advice help you and solve the problem ?
  2. Please then start your own thread using /questions/new if your problem

is unresolved.

  1. Normally I would say to follow the troubleshooting steps and include full system information from Firefox's troubleshooting information. Or the extension provided as you commence with the quesetion asking. Those prompts may not all be totally applicable if Firefox will not start but do your best.
  2. Post back in in this thread to confirm when you have done so and we will be able to find your answers.

eccotten,

  • Presumably Firefox continues to work in Windows safe mode with networking.
  • Did you try the clean reinstall involving deletion of the Firefox program files?

Here is another method of getting a type of Firefox working. Use the unofficial Firefox Portable. Install it as an additional browser.

I have managed to get my firefox working again by using 'Malwarebytes' it didn't have any effect first time when i tried all the listed fixes but after a second clean install and using that it now works. i have about a 10 second delay before it actually starts but other than that it's fine.

and as far as starting a new thread, have you seen how many threads are on here with the same problem??? if i start a new thread it will fill up with the same possible solutions as in every other thread.

darellen,
We are trying to prevent threads filling with me toos and unrelated posts !

Scanning for malware with multiple tools was already suggested on the first page of this thread. (Although malware may often slow down Firefox rather than prevents it working, because possibly malware may take advantage of a functioning firefox)

Now may be a good time to remind people to turn on telemetry to help Firefox developers.

We have KB articles and canned responses that cover most solutions. But the causes often differ even if the symptom is the same. It is much better and suggested in the forum guidelines to start your own thread.

  • That way we can address an individual user's problem.
  • Sometimes the problem is a new and specific cause.
  • Almost always the fault is with the particular setup and so the additional information provided in a new thread can be invaluable.

You obviously had a malware problem. You probably have a slow startup time but I am not sure which of the myriad of stats actually report the startup results averages for all users.

See also

You can use one of these to start Firefox in Safe Mode:

  • On Windows, hold down the Shift key while starting Firefox with a double-click on the Firefox desktop shortcut
  • On Mac, hold down the Options key while starting Firefox
  • Help > Restart with Add-ons Disabled

You can use the MSConfig program or the Autoruns utility to see which software and services are getting started (be cautious with disabling services).

if you're running xp just change the value of SynAttackProtect to 0, or you can just delete it you need to navigate the registry to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters voila! hope this would help you

Reyter, (and Everyone else)
I will repeat my advice.

  1. Please read the suggestions within this thread
  2. If the problem persists please start a new thread of your own by asking a question.
  • For this specific type of problem only please use this quick direct shortcut to start a question of your own HERE

I have no reason to expect any new version of Firefox will help you. You need to take action yourself to identify and fix this. We can offer advice but it is your choice whether to follow it or stick with a broken Firefox.

Comments from a forum moderator

  • Take extreme care with editing the Registry.Many of you will have no need to even consider a registry edit. EDITS COULD PREVENT THE COMPUTER FROM WORKING. ~J99


in registry, navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

try to delete SynAttackProtect

then restart your pc

John99 மூலமாக திருத்தப்பட்டது

This thread is contains posts by others claiming to have the same problem and asking for a solution, whereas in reality they my have the same symptom but need a different solution.

Note if Firefox does not run in Firfefox's safe mode but does run in Windows Safe mode the problem is probably not with the Firefox profile. It is more likely to be with some third party software, that may or may not involve Firefox plugins.

In such circumstances it is unlikely any of these will work

  • simply uninstalling and re-installingFirefox
  • deleting or changing Firefox profiles
  • waiting for a Firefox update

The problem could be security related software or malware. By all means scroll the thread and read the other suggestions,but do not expect to get a proper solution to your own problem by asking in someonelse's thread.

If you need a solution and have read the thread use this special direct and quick shortcut to start your own thread.


Also see

edit added point about IE default ~J99

John99 மூலமாக திருத்தப்பட்டது

ecotten,

We have not heard from you for a while.

Did you give up on Firefox?

Is Firefox still working in Windows Safe Mode but not in Firefox safe mode?

Obviously Windows safe mode is a diagnostic mode intended to help track down problems caused by additional software. It is not intended for day to day use with a browser.

Bye Bye Firefox

This is clearly a Firefox problem and they don't seem to be able to fix it. All those proposed solutions above are band-aids! The other popular browsers like IE and Chrome work OK for me in windows 7...

I really like Firefox but I'm not counting on this being fixed in the near future. I've switched to IE

mikesdebbp

This is clearly a Firefox problem 

It is more likely a problem on your machine or setup. Good luck with IE


Firefox has nearly 1/2 Billion users. I see no indication that many have such a problem with Firefox not starting. Even if it works for 99.99% and (1/10th) 00.001% have a problem with it not starting; that affects thousands of potential users.


If you need a solution and have read the thread use this special direct and quick shortcut to start your own thread.

John99 மூலமாக திருத்தப்பட்டது

In case anyone else is having this problem, I was, but I disabled Windows Defender and that fixed it straight away. Hope that helps!

Problem Solved!

My Firefox now opens.

I have had the same issues and tried everything that is suggested here. I could only open Firefox when my computer was started in safe mode.

I managed to get Firefox running again after running ‘Spybot – Search & Destroy’ on my PC. It found a lot of things which I removed. However, I couldn't remove one program 'Babylon Toolbar' without right clicking on the Spybot desktop icon and selecting 'run as administrator'. I restarted my PC, it scanned and then I clicked on 'search and destroy' to remove the software. Straight away Firefox reopened.

I also used MozBackup to back up both my Firefox and Thunderbird profiles and settings etc.

I hope that is of help as I know how frustrating it is and I much prefer to use Firefox than other browsers. I was very close to switching to Chrome!

Hi everyone. I had the same problem today (yesterday! it's now 3.25). The problem started out of the blue and Firefox just wouldn't launch. I tried all the things suggested- reinstalling, creating a new profile, clean reinstall, ran a virus check etc. Someone wrote to check for Firefox already running in the processes of task manager so I checked and it wasn't there. BUT I did notice something running called BitGuard. Checked it out online and no-one seemed to know what it was. I uninstalled it and, hey presto, up and running. I don't know if this is the same for others of you out there but I hope it helps. I've had a REALLY frustrating day!

cor-el மூலமாக திருத்தப்பட்டது

  1. 1
  2. 2