Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Java Plug-in for JRE7u21?

  • 40 பதிலளிப்புகள்
  • 85 இந்த பிரச்னைகள் உள்ளது
  • Last reply by swmartian

I go to a website that requires a Java plug-in. I downloaded the latest update (21) for Java 7 from Oracle but when I go to Add-Ons>Plugins in Firefox 20 the Java plug-in doesn't appear and when I do a search at the Get Add-ons nothing that mentions the Java Plug-in shows up. Where can I get the plug-in required to use with JRE7u21?

Mac OS 10.7.5, Firefox 20.0, Java Runtime Environment 7 update 21

All Replies (20)

Hey Romad, I had the exact same problem on my Windows 7 OS and I found the below firefox article which helped me out.

Even though I had installed the latest version of Java, I downloaded the Free Java from and installed it on my machine. After this, the plugin was correctly added to Firefox and the websites detected it just fine. Check it out. It might help you too.

ed_jones மூலமாக திருத்தப்பட்டது

Hi romad,

Most likely issue is with with the Firefox 32/64 bit selection. Open Firefox info panel (Cmd-I) and deselect "Open in 32-bit mode" tick box.

That worked for me!

The problem is a mismatch in 32 and 64 bit - I had this same problem and it took me all day to figure it out. I had Firefox 32 bit installed and Java 64 bit. The Firefox did not see the 64 bit Java. I uninstalled Firefox 32 bit, installed Firefox 64 bit and the Java Plugin was there.

For normal 32bit you can try this. I just tested and it works.

switching to 64bit will also break other 32bit plugin which you already have.

have latest java for mac and from sun and no java issues in safari put cannot run java sites in firefox and plug is not there. when i am asked by sites to find necessary plug in firefox says non suitable are available. have tried all solutions mentioned here and elsewhere. any clues? thank u

I dun really require the latest so if you are trying to have the latest there seems to be problem with the plugin. I only got it working on and off.

Try the 64bit I didnt try that.

thank u for reply. why are there no java issues with safari put no plugin displaying in firefox? cannot find 32/64 bit on/off in mac firefox.

berrimaglen மூலமாக திருத்தப்பட்டது

Its posted above by others Open Firefox info panel (Cmd-I) and deselect "Open in 32-bit mode" tick box.

Ask Firefox I have no idea

I should note that I am running Windows 7.

I had a similar problem on my wife's computer where the plugin was also missing fromthe list. It turned out that you need to delete a file in a profile folder, when relaunching firefox the file will be regenerated and the plugin should be displayed. Follow the guide in this link for instructions relevant to your operating system:

plugin doesn't appear

search for: "If the Java plugin does not appear in the Add-ons Manager"

ptr84 மூலமாக திருத்தப்பட்டது

What didn't work, did you get through the instructions? Where you able to delete the pluginreg.dat file in the firefox profile folder ?

Deleting the pluginreg.dat file made no difference; it didn't "regenerate" the missing plug-in when I relaunched FF22.

Ditto for me re plugin removal - i have to now use safari for java applets which is a pain switching back and forth. Do not understand why firefox have not found a real solution for this obviously widespread issue.


i realized exactly the same thing. Safari & Chrome refers 2 different versions of Java (atleast for applet.) I am customer of Bank Of Baroda in India. They extensively use applets for security. When i upgraded to Mac OS X Lion then the site blocked me. I upgraded to browser versions and all possible tweaks but it was not working. Then this latest Java was released (7.25.8) and when i upgraded my Lion for that Java, Safari started working fine. Hats off to seamless integration of Apple. But firefox is still in problem. I tried all possible things. I also tested Java Version of FireFox on and it shows latest version, but the applets of BOB, those run on Safari, don't run on Firefox... I was searching for solution and your thread was ray of light. There is nothing other than this on entire web. Is it some bug in firefox and can we report it?

    • And you know the best part is, it works perfectly on Crome even it's 32Bit! Whats wrong with Firefox??

This fix is only temporary, but it does work:

1. Uninstall the JavaAppletPlugin.Plugin by dragging it to the trash. 2. Reinstall Java with FF off 3. When FF restarts the plug in will be there 4. When you close FF and restart it - it will be gone again. Repeat 1-3 every single time you restart FF.

I hope everyone reading this thread will click on "I have this problem too" so that FF will get to work on a FIX!! I appreciate that both Apple and Firefox are overly watchful on security issues, but the severe security issue that Oracle presented with Java 7 has long since been fixed. Firefox can stop disabling the plugin!

  1. 1
  2. 2