Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

ordinal 459 could not be located in dynamic link library.urlmon.dll What the heck is this and how do I fix it?

  • 20 பதிலளிப்புகள்
  • 228 இந்த பிரச்னைகள் உள்ளது
  • Last reply by ED193728

I get the following message:the ordinal 459 could not be located in the dynamic link library. urlmon.dll. I get this when requesting list links within a genealogy program (not on the internet) Haven't noticed it on anything else yet because I have been obsessing over just that one program. At the same time I notice that my windows sidebar is not visible. Have not changed any settings. Java was disabled due to the recent exploitation. Would that have something to do with it. Or perhaps Firefox18 installed and then it went bad? Thanks in advance for any help. Running Vista.

All Replies (20)

A few users have reported this and it's apparently malware. Try to Scan for malware, and reset firefox. Troubleshoot Firefox issues caused by malware Refresh Firefox - reset add-ons and settings

I have Trend Micro and it just ran a scan yesterday. I will try one of the free malware one now, check if the problem still exists, then try the reset. Thank you. Will keep you posted if that is ok. Thanks

Thanks Tyler. Tried both of these. The malware program did find 4, deleted those and restarted. Still get the same message about ordinal 459. Then reset firefox, still didn't help. Any more advice?

I have this problem too. On January 14 I installed Microsoft security patch: Bulletin MS13-008 - Critical - Security Update for Internet Explorer (2799329) January 14, 2013 Version: 1.0. When I attempted to re-start my computer, as instructed, the computer locked up and I had to power off. When I re-powered, I got a pop-up Powered by Support Soft, “The ordinal 459 could not be located in the dynamic link library urlmon.dll”. Clicking on the “x” in the box caused a “beeb” but the box would not go away. I wanted to use System Restore to go back to an earlier time, but the System Restore screen would not load. I used the Add/Remove utility to uninstall the security patch but still got the pop-up and no System Restore. Also, IE8 is locked up and will not open. How do I fix this problem? I am running Windows XP SP3 and Mozilla Firefox 17.0.

I am still having this problem also. Seems like it happened after that patch for IE.. I don't use IE at all and most updates on it fail. But I just noticed that patch did succeed. I will try to remove it and see what happens. When the pop up box comes on and won't close the only way to get rid of it is to close the program that I was using at the time. Goes to another box that says end now or cancel. I end now and the program closes. It is a genealogy program I am using at the time and it won't let me access the lists I need such as source and place etc. Hate to just shut it down like that. Have tried registering the urlmon.dll. Nope, didn't work. Tried malware programs, virus programs and still did not correct the problem. Get that same 459 message when I try to access Microsoft Help also. I have Vista and Firefox 18.

Skip, I tried to uninstall that patch. Can't do it. So I am going to try to restore. Have you come up with any new ideas?

I did a system restore and that took care of the problem for me. Hope you can find some solution also.

I have the exact same thing happening, I did a system restore and then the next day the problem happened again. It will just re-update itself and happen again. I don't know what is causing it though.

I will check again tomorrow to see if it reinstalled itself. I hope it doesn't. I do have the automatic updates turned off. I hope that works.

Same problem. System restore to earlier checkpoint works. However if VISTA restarts (maybe an update) the 459 problem returns. No solid fix yet. Plan to e-mail Intuit (I have Norton 360) and UniBlue

My System Restore utility does not work. I had hoped restoring to an earlier date would fix the problem.

So yesterday I had everything back to normal with a system restore. Shut down computer. After reading the replies this morning I checked the programs that I knew were affected and sure enough that ms13-008 had been reinstalled even though I had changed my settings to NOT download without permission. Then I checked in my Firefox internet options and found that there is the same option for automatic downloading and it was set on automatic. Changed that setting, made sure the settings in my control panel were identical and did another system restore. Since NOTHING had changed from when I shut down last night until this morning except for that ms13-008 being reinstalled I know for certain that it is the culprit. Vista (and maybe others) seems to think it needs to do that automatically. Really ticks me off. I am going to have to call them I guess. Since they don't seem to monitor their own support forums. They seem to think it is not their problem. Doesn't look like it now does it. @Skip, When I go to Start, programs, accessories, system tools, system restore, and click the button it seems to take quiet a few minutes before I see any activity that anything is happening. Maybe you should just try to wait about 5 minutes and see if a box comes up (finally) telling you it is working??? And the saga continues. Will see tomorrow what happens.

SUCCESS!!!! Finally. Since changing the network tab in Firefox to not automatically download any updates as well as changing it in the windows update that pesky ms13-008 did not reinstall this morning. Hopefully this will continue to take care of that problem.

The firefox setting on updates has nothing to do with Windows updates, so you should put it back to automatically install updates to stay secure

I found the MS13-008 patch had re-installed itself so I used the Add/Remove utility to uninstall the security patch again. Now no Support Soft pop-up. Windows Help and Support page re-appeared. Used System Restore to restore to January 9. Everything seems to be working as it should. I'm keeping my fingers crossed!

Had turned off the auto updates to. Stopped the problem. Concluded that something in IE 8 updating might be causing the 459 problem. Tried download+install of IE 9 64 bit and got installation failure. I can only guess the malware is responsible for that too. Still hunting for a fix or good malwear remover that will get rid of this little devil. Never can understand why some people get their jollies infec ting people's PCs.

If this issue is caused after you have applied MS13-008 which is a security update then I would think that this is a Firefox issue and that something changed and they have to find a new way to do what they where doing before the update.

However since the error message states it can't find the file urlmon.dll has anyone checked on why this file is missing or why it is not registered? Since URLMON.DLL is not updated by MS13-008 I would suspect this could be a coincidence.

Here is a related Microsoft KB article about that dll causing similar issues with IE and how to address it.

I mean a quick google of that exact error message "The ordinal 459 could not be located in the dynamic link library urlmon.dll" has results of this problem going back to at least 2011 long before MS13-008 was released. There are a number of solutions as well for different situations posted.

It may be worth checking some of those is the Microsoft KB above doesn't help.

And yet I am left thinking that Tyler's statement from January 16 about it being reported by other uses and apparently being caused by malware is the most likely reason for this issue. He does know Firefox rather well, and he is an employee of Mozilla. So I really would start with his suggestions of checking out their KB's he listed:

creepygnome மூலமாக திருத்தப்பட்டது

Decided that since everything is working correctly that I will update only those that do not relate to IE. So everything is set to manual update rather that automatic update. Thanks to everyone for the helpful replies.

I found it solved the problem when I installed Internet Explorer. I think the Explorer browser contains the missing dll and so this is a seemingly safe way to get it back in your computer. If you already have Internet Explorer installed you might try deleting it and reinstalling. Hope it works

guys how can i do a system restore ik it's a stupid question but idk how so please reply to me cuz i have the same probelm when i try to download from softonic so please reply and thanks