Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More -- cannot delete

  • 25 பதிலளிப்புகள்
  • 2 இந்த பிரச்னைகள் உள்ளது
  • Last reply by cor-el

it's that simple but I don't know what else it is doing to my computer. IF one googles this problem it is recognized and money solutions are offered but many are too complex for me, and the problems continue reeking havoc. Has screwed relationship with my printer and can't seem to dl from Microsoft.

but it all started out with this inability to change my home page back to what it was. it remains and what appears is a custom google search page as the home page.

I am temp. using I am already weary of using so much time on this problem. Help if you can.

All Replies (20)

The keyword.URL pref links to BTSearch:

Try to reset the prefs on the about:config page that refer to btsearch.

  • Open the about:config page via the location bar and do a search for btsearch via the Search bar at the top of the about:config page.
  • Reset all btsearch related prefs that appear bold (user set) via the right-click context menu to their default values.

If you do not keep changes after a restart then see:

Tried the about:config solution. Nope it is still there...............

I suggest that you visit a website specializing in malware removal. See Troubleshoot Firefox issues caused by malware

Here is a recent post by a Firefox user with a similar problem in the Bleeping Computer forums (do NOT follow those instructions, which are specific to that user. It's just an example of type of help you can get there):

P.S. For anyone needing help with unwanted toolbars that change your Firefox search or home page settings, see also:

AliceWyman மூலமாக திருத்தப்பட்டது

It is a shame that Mozilla does nothing to solve this issue or find a solution. This problem exist for months and it could be solved when it affected chrome... just by deleting it from the search engines, but with firefox it is different.. it keeps returning like a cat... and no anti-malware or anti virus detects it.... It is annoying... Do something... Thanks

To kondoril (or anyone else having problems):

The solution suggested in this thread is to follow the steps in the Refresh Firefox - reset add-ons and settings article. Cor-el suggested to Spirasol (the thread owner) to reset the keyword.URL preference, which should be easier in Firefox 19 with the fix for Bug 718088 - offer to re-set keyword.URL if it has a non-default value.

I suggested following the instructions in the Remove a toolbar that has taken over your Firefox search or home page and Troubleshoot Firefox issues caused by malware articles.

If you need more help you should start a new thread, which will show your own system details, since this one has system information specific for helping Spirasol.

Thank you

This is not a toolbar... I tried...

Reset ? and if this doesn't help ? then what ? re-visiting all the tabs / tab groups ?

did you hear about anyone who succeeded dealing with this issue by doing reset ?


I did the reset..

Total disaster !!

and.. it did not resolve anything... !!!

kondoril, The instructions in the Remove a toolbar that has taken over your Firefox search or home page article can also be used to remove extensions that are not toolbars, and it links to a search reset add-on to reset your home page and search.

If the other suggestions didn't help, what about Troubleshoot Firefox issues caused by malware ? Did you try running a malware removal tool or visiting a malware removal forum? That may be your best bet.

See this malwarebytes forum thread (do NOT follow those instructions, which are specific to that user. It's just another example of type of help you can get on a malware removal forum).

AliceWyman மூலமாக திருத்தப்பட்டது

(To repeat) If you need more help you should start a new thread, which will show your own system details, since this one has system information specific for helping Spirasol. You can use this link as a starting point:

Thank you.. but I really can't see the point This problem is the same and it happened to many people who are writing and asking for help since 7/12 and no one provided a real solution. This is a shame.. and even insulting.

Why make a browser if you don't try to protect it or fix it ?

So far, all the solutions caused more damage a work than this hijacker


Do you see any prefs coming up on the about:config if you search for btsearch?

You can also check if you have a mozilla.cfg file in the Firefox program folder.

  • (32 bit Windows) C:\Program Files\Mozilla Firefox\
  • (64 bit Windows) C:\Program Files (x86)\Mozilla Firefox\

Yes... there are 2-4 entries with btsearch.... and I presses reset for each... and I changed the home page to what I want...but it helps for the same session... but when Firefox is restarted they return

And Yes.. There is this cfg .. and it seems nasty ! I will delete it and see what happens !!! Thank you !!

You are great !! Thanks

This is the solution

deleting the file was not good cause Firefox needed it... but then I edited it and deleted all btsearch / custom search replacing them with blank or google...

now it is GONE !!!

Thank you

Some one must publish this

Thanks to cor-el for mentioning that a "mozilla.cfg" file in the Firefox installation directory can be used for locking preferences. I added that information to

You're welcome kondoril.

Note that if you delete the mozilla.cfg file in the Firefox program folder that you also need to check if there is a file in the defaults\pref folder that specifies to use the mozilla.cfg file.
Easiest is to delete the Firefox program folder and do a clean reinstall.

You can also use this file for your own purposes to initialize prefs.


These functions can be used in the mozilla.cfg file:

defaultPref();  // set new default value
pref();         // set pref, but allow changes in current session
lockPref();     // lock pref, disallow changes

cor-el மூலமாக திருத்தப்பட்டது

Thanks again As I wrote - I edited the file and deleted all the items that the malware had added. It is perfect now :-)

Do you still have a copy of all the content in the mozilla.cfg file?

Which files do you have in the \defaults\pref folder?

There should only be a channel-prefs.js file to specify the update channel.

pref("", "release");

The malicious *.cfg file content was:

pref("extensions.shownSelectionUI", true);
pref("extensions.autoDisableScopes", 0);
pref("browser.startup.homepage_override.mstone", "ignore");
pref("browser.newtab.url", "");
pref("", "Custom search");
pref("", "Custom search");
pref("keyword.URL", "");

I changed it to:

pref("extensions.shownSelectionUI", true);
pref("extensions.autoDisableScopes", 0);
pref("browser.startup.homepage_override.mstone", "ignore");
pref("browser.newtab.url", "about:blank");
pref("", "Google");
pref("", "Google");
pref("keyword.URL", "");

The "google" entry does nothing.. I know it now... but it doesn't cause any problem.. so...

I have the *.js file and it contains: pref("", "release"); just as you wrote


cor-el மூலமாக திருத்தப்பட்டது

  1. 1
  2. 2