X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Why is Firefox 17.0 now using SmearType, and how do I turn it off?

  • 5 replies
  • 21 இந்த பிரச்னைகள் உள்ளது
  • Last reply by cor-el
பதிவிடப்பட்டது

I updated to 17.0 today, and suddenly ClearType (what a joke!) is forced on, and I see no way to get rid of it. Seriously, ClearType is ugly and it makes it much harder to read webpages. This is the entire reason I refuse to install IE 9.0. Help?

OS: Windows 7 Pro 64-bit Browser: Firefox 17.0 32-bit Auto-updated 11/21/2012

ClearType was off in 16.0 and earlier. If it can't be turned I will have to revert.

I updated to 17.0 today, and suddenly ClearType (what a joke!) is forced on, and I see no way to get rid of it. Seriously, ClearType is ugly and it makes it much harder to read webpages. This is the entire reason I refuse to install IE 9.0. Help? OS: Windows 7 Pro 64-bit Browser: Firefox 17.0 32-bit Auto-updated 11/21/2012 ClearType was off in 16.0 and earlier. If it can't be turned I will have to revert.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Temporary solution is disabling hardware acceleration in FF options. See this thread: https://support.mozilla.org/pl/questions/942265

Read this answer in context 2

Additional System Details

நிறுவப்பட்ட நிரல்கள்

  • Shockwave Flash 11.5 r502
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • GEPlugin
  • 5.1.10411.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0

கூடுதல் தகவல்

Application Basics
Name
Firefox
Version
17.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
BetterPrivacy
1.68
true
{d40f5e7b-d2cf-4856-b441-cc613eeffbe3}
Clearly
7.3346.272.999
true
readable@evernote.com
DownloadHelper
4.9.11
true
{b9db16a4-6edc-47ec-a1f4-b86292ed211d}
DownThemAll!
2.0.15
true
{DDC359D1-844A-42a7-9AA1-88A850A938A8}
Evernote Web Clipper
5.4
true
{E0B8C461-F8FB-49b4-8373-FE32E9252800}
FEBE
7.0.3.5
true
{4BBDD651-70CF-4821-84F8-2B918CF89CA3}
LastPass
2.0.0
true
support@lastpass.com
NoScript
2.6.1
true
{73a6fe31-595d-460b-a920-fcc0f8843232}
NoSquint
2.1.6
true
nosquint@urandom.ca
User Agent Switcher
0.7.3
true
{e968fc70-8f95-4ab9-9e79-304de2a71ee1}
Web Developer
1.2.2
true
{c45c406e-ab73-11d8-be73-000a95be3b12}
Firebug
1.10.6
false
firebug@software.joehewitt.com
HTTPS-Everywhere
3.0.4
false
https-everywhere@eff.org
NicoFox
1.0b3
false
nicofox@littlebtc
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
1048576
browser.cache.disk.parent_directory
C:\Cache\Firefox
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
798720
browser.places.smartBookmarksVersion
4
browser.search.useDBForOrder
true
browser.startup.homepage
about:blank
browser.startup.homepage_override.buildID
20121119183901
browser.startup.homepage_override.mstone
17.0
browser.zoom.siteSpecific
false
extensions.lastAppVersion
17.0
font.internaluseonly.changed
false
font.minimum-size.x-western
9
general.useragent.extra.zencast
Creative ZENcast v2.01.01
gfx.direct3d.prefer_10_1
true
network.cookie.cookieBehavior
1
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1353447502
places.history.expiration.transient_current_max_pages
104858
places.history.expiration.transient_optimal_database_size
167772160
privacy.cpd.downloads
false
privacy.cpd.history
false
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.disable_button.openCertManager
false
security.disable_button.openDeviceManager
false
security.warn_viewing_mixed
false
Graphics
Adapter Description
Intel(R) HD Graphics 3000
Vendor ID
0x8086
Device ID
0x0112
Adapter RAM
Unknown
Adapter Drivers
igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Driver Version
9.17.10.2875
Driver Date
10-17-2012
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50
WebGL Renderer
Google Inc. -- ANGLE (Intel(R) HD Graphics 3000) -- OpenGL ES 2.0 (ANGLE 1.0.0.1242)
GPU Accelerated Windows
1/1 Direct3D 10
AzureCanvasBackend
direct2d
AzureFallbackCanvasBackend
cairo
AzureContentBackend
direct2d
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

ad_verbum 1 தீர்வுகள் 26 பதில்கள்
பதிவிடப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Temporary solution is disabling hardware acceleration in FF options. See this thread: https://support.mozilla.org/pl/questions/942265

Temporary solution is disabling hardware acceleration in FF options. See this thread: https://support.mozilla.org/pl/questions/942265
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Thank you. Firefox is readable again.

Thank you. Firefox is readable again.
cor-el
  • Top 10 Contributor
  • Moderator
17472 தீர்வுகள் 157915 பதில்கள்
பதிவிடப்பட்டது

Try can also try to set the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration enabled.

Try can also try to set the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration enabled. *http://kb.mozillazine.org/about:config
Matt_G 365 தீர்வுகள் 1860 பதில்கள்
பதிவிடப்பட்டது

உதவிகரமான பதில்

We have a patch in the works. It seems to be an azure issue. setting gfx.content.azure.enabled = False seems to work in the meantime. We aren't sure if the patch will be part of a chemspill or wait until 18. Thanks for being patient!

We have a patch in the works. It seems to be an azure issue. setting gfx.content.azure.enabled = False seems to work in the meantime. We aren't sure if the patch will be part of a chemspill or wait until 18. Thanks for being patient!
cor-el
  • Top 10 Contributor
  • Moderator
17472 தீர்வுகள் 157915 பதில்கள்
பதிவிடப்பட்டது

(see: Bug 814101 - Font Issue in FF 17 -- please do not comment in bug reports)

(see: Bug 814101 - Font Issue in FF 17 -- please do not comment in bug reports)