Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Updated to FF 13.0 and Yahoo Mail won't stay signed in-even after deleting cookies.

  • 47 பதிலளிப்புகள்
  • 91 இந்த பிரச்னைகள் உள்ளது
  • Last reply by SDBudde

I am using Firefox 13.0 Beta 2 and my Yahoo Mail account, which is set to sign in every two weeks, is requiring me to log in every 20-40 minutes. I experimented with my wife's account and it does the same thing.

All Replies (20)

you might want to try disabling the yahoo toolbar in firefox > addons > extensions & see if that makes any difference.

Websites remembering you and automatically log you on is stored in a cookie.

  • Create an allow cookie exception (Tools > Options > Privacy > Cookies: Exceptions) to keep such a cookie, especially for secure websites and if cookies expire when Firefox is closed.

Make sure that you do not run Firefox in Private Browsing mode.

Do not use Clear Recent History to clear the "Cookies" and the "Site Preferences"

Clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.

Thanks cor-el, but I had seen that on another thread and done all of the above with negative results.

You have created an allow exception for the site(s) that yahoo uses?

If clearing the cookies doesn't help then it is possible that the file cookies.sqlite that stores the cookies is corrupted.
Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox Profile Folder in case the file cookies.sqlite got corrupted.

I did change the exception setting and found a list of saved passwords. I deleted all of the yahoo passwords I found there and am going on two hours without having to sign in again. So far. So good.

Sorry it took me a while to get back here. I have been working and away from this computer. I was wrong...I'm still having the same issues. To update:

I was mistaken on having created the exceptions. I had just changed the settings. I added exceptions for: and

I searched the entire computer (including hidden files) and registry for the cookies.sqlite and related files and found nothing.

I also had disabled the yahoo toolbar and it didn't make any difference.

Between this and a separate networking issue, I'm about shoot the damn things and go back to pen and paper.

I'm going to let it go a couple of hours and see if it does it again. If so, I'm going to do a revo uninstall to make sure I kill everything and start over from scratch.

Here's the screenshots of the messages I get. I noticed that sometimes it just requires my password and after clicking on it (but not all the time) it will then require both my username and password. So basically I have to sign in twice on occasion before it will go to yahoo mail. The 999 message has only occurred once, but I attached it, too.

And BTW, you guys are a lot more help than yahoo is. They replied on Thursday and it said just to make sure I'm using the latest browser version. I sent a ton of into back and never got another reply.

LawDogRD10 மூலமாக திருத்தப்பட்டது

I tried to paste the troubleshooting information but it is too big and won't paste into MS Paint, either. If you need it, let me know how I can attach it.

UPDATE (WITH SKY HIGH BLOOD PRESSURE AND AM ABOUT TO BLOW): 30 minutes or so later and it required me to sign in again. I'm going to have to wipe it and start clean.

LawDogRD10 மூலமாக திருத்தப்பட்டது

Are you sure its not any addon or plugin of yours that causing the problem?

I don't really have any add-ons other than the yahoo toolbar, which I had disabled and it made no difference, I have a flash video downloader but it was added a long time ago and as far as I know, there have been no add-on or other extensions added. I just reinstalled it, so we'll see if that does it. Probably should have done that from the start.

also try disabling the browser plus plugin in addons > plugins - it seems to be yahoo specific too...

"BrowserPlus -- Improve your browser! --" is listed in your system details that you have submitted.

Yeah. I missed that. It seems the issue is taken care of since I reinstalled it. I used Revo and deleted everything, including all the registry keys.

Everything is working fine now. I appreciate your help and am going to consider it solved with the reinstall. Thanks!

LawDogRD10 மூலமாக திருத்தப்பட்டது

Well, I just found this help section and I too am having this problem. It seems its started when FF update the other day to 13.0

I used to be able to stay logged onto Yahoo for at least two weeks, but now its logging me off just about every 5 minutes. I'll keep the yahoo window open while I browse the internet, and if I have to go back to the yahoo tab, its already logged me out. Its never done this before. Also, I dont use the yahoo toolbar either.

I've done all of the "check list" of deleting cookies, making sure it remembers my password etc. I also did what others suggested above in this thread.

I'm stumped.

Thoughts anyone??

I'm back at square one again. The power went out yesterday, shutting the computer down, and now it is doing this again. I'm just going to uninstall and start clean again. I can't find any other solution that works.

Do you use Firefox? Cause like I said in my post, it started doing this after FF updated the other day. I'm wondering if thats the problem. Sorry to hear its still going on. Its extremely frustrating.

I also have this problem, on my home computer. Began when Firefox updated to v. 13 on the Beta channel. Keep getting "Sorry, your session has expired. To protect your account, you need to confirm your password periodically." When I click "Sign In Again", I get one of two log-in windows. If the one showing the "Keep me signed in." box appears (which I always leave checked), I need to click the "Sign In" button, but nothing appears to happen on the window. I have to close the window, then click the "Sign In Again" button, which will then show the other window without the check box. When I click "Sign In" there, the window clears and Yahoo mail shows up as normal. The window with the check box appears after longer times; the other window can appear several times in a few minutes, to let me read an email, then to let me delete it, or to open another folder, etc. Usually after several rounds of this, it settles down for 30 minutes or so, and I'm not asked to sign in again.

I have cleared all cookies, cache, disabled add-ins, etc., no change. On my work computer, I upgraded from v. 12 to the official 13 release, and it works OK there! So on my home computer I uninstalled Firefox, restarted, installed the official release, created a new profile, didn't install any add-ins, and still had the same problem! So I went back to using my original profile. Adblock Plus is installed on both computers. NoScript is on home computer, but was not installed/in use when tested with new profile. It's disabled on Yahoo pages as well.

Both computers are using Windows 7, all patches and updates applied. Work computer is "Professional", home computer is "Home Premium". Perhaps the biggest difference is home computer has the Windows firewall turned on, and is using Windows Security Essentials, work computer uses McAfee Endpoint Protection.

Hope all this helps someone find the solution to this irritating problem.

That's almost the identical situation to mine, except I'm using Vista. Both my desktop and laptop have the firewall turned on, so I doubt that's it. I'm fixing to uninstall and start over this afternoon...again.

  1. 1
  2. 2
  3. 3