Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 10 does not prompt for saving passwords

  • 15 பதிலளிப்புகள்
  • 15 இந்த பிரச்னைகள் உள்ளது
  • Last reply by ulmeter

Even though the setting to save passwords is checked and I am not in private browsing mode the "pop-up" prompt to save passwords does not appear anymore. Some sites do not allow this function however, it does not appear on any site (sites that work with a firefox 10 on a different computer and also chrome on the same computer).

தீர்வு தேர்ந்தெடுக்கப்பட்டது

You can also try disabling Use hardware acceleration when possible in Tools (Alt + T) > Options > Advanced > General.

Options > Advanced

Tools > Options

Read this answer in context 👍 3

All Replies (15)

Firefox > Options

Select Security tab

Next to [ ] Remember passwords for sites, click Exceptions and make sure no exceptions show up.

No exceptions show up. I figured out that it works in safe mode, i.e. the pop-up will appear beneath the key icon. No further updates yet.

If it works in safe mode, it's possible one of your extensions is hijacking the password manager (usually security software -- possibly something that was bundled with your new machine).

Go through the extensions in Tools > Add-ons and disable them to figure out which it is.

It is a clean install of firefox - so no add-ons installed. During the process, I have only installed Password editor, which did not affect the problem. I tried to disable all plug-ins in normal mode, also did not help.

Not quite what I asked. Often security software (such as Norton or Kaspersky) will install add-ons that you didn't explicitly approve.

Nothing is in my add-on list at least. Not sure what you were asking exactly then if not that what I answered.

Create a new profile as a test to check if your current profile is causing the problems.

See "Basic Troubleshooting: Make a new profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.


Thanks for the suggestion! I created a new profile and started firefox with the new profile - unfortunately also here the pop-up box is suppressed for some reason. As for the default profile, there is a key appearing next to the "go back" button but no question to save the password.

In the new profile, there was no extension installed (at least non visible in the list); however, several plug-ins. Again, disable all plug-ins does not help either.

I am running Avira and Zonealarm on this machine - I disabled realtime protection and switched off Zonealarm, but again, no luck. Maybe I should try to uninstall them, but actually I am running the same combination on my desktop computer (Avira, Zonealarm, and Firefox; also the same updated version of each program) and there it works just fine.

ulmeter மூலமாக திருத்தப்பட்டது

ZoneAlarm installs a ForceField plugin (npFFApi), so you can try to disable that plugin.
ZoneAlarm ForceField is known to interfere with a lot of things in Firefox.
You can try to ask advice in the ZoneAlarm forum.

Again. I disabled all plug-ins and therefore also the npFFApi. This did not work either. Also I am running the same combination of programs (avira, zonealarm, and firefox) on my desktop computer with the plug-in. There it works just fine. Nevertheless, I am going through this cumbersome test and will uninstall zonealarm today. I'll keep you posted.

I uninstalled Zonealarm and tried it - didn't work. Then I uninstalled Avira and Firefox and reinstalled a clean Firefox 10 (without having any firewall nor antirvirus installed) - still whenever I visit a site where passwords can be saved, the key symbol appears next to the history back button but the pop-up is simply missing...I think I have to switch to Chrome...

தீர்வு தேர்ந்தெடுக்கப்பட்டது

You can also try disabling Use hardware acceleration when possible in Tools (Alt + T) > Options > Advanced > General.

Options > Advanced

Tools > Options

Vivek மூலமாக திருத்தப்பட்டது

Thank you so much for this suggestion Vivek.Wilfred! That did the trick - my password pop-up is back!!! So bottom line, as I expected, it is neither zonealarm nor avira or AVG but simply an issue with a certain hardware driver. For all interested people who might have the same issue: I am running a Dell XPS 15 (L502). Thanks again to everyone who replied!

Thank you very much for posting the helpful details. Another user also had reported a similar issue; in that case after updating the graphics card drivers.

So updating is not always recommended, never change a running system!

ulmeter மூலமாக திருத்தப்பட்டது