Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

after updating to Firefox 8, I lost almost all the icons associated with my bookmarks. Bookmarks will work, but they show an empty square instead of the icon associated with the website they are linked to. What's the bug here??

  • 57 பதிலளிப்புகள்
  • 1040 இந்த பிரச்னைகள் உள்ளது
  • 3235 views
  • Last reply by the-edmeister

I had many sites bookmarked in Firefox 7. All these bookmarks were associated to icons linked to the sites. Almost all my bookmarks lost their icons (now replaced by an empty square) after updating to Firefox 8. Que pasa ??

All Replies (17)

I have this issue, too. I am not sufficiently development-savvy to answer all of the questions regarding what various icons were formerly linked to, but I can weigh in on two points:

1. I am not positive, but I think that I have some icons which have disappeared that were NOT the default "blank page" icon.

2. I think it's ridiculous that the default is now a blank box that LOOKS like something is missing. Even if the only thing I'm missing is "blank page" icons, I still think that the old "blank page" icon was far better than NOTHING. Why on earth was the default icon replaced by the dotted box, rather than just left alone?

we hope FF will make an update soon

Ahmad Maher மூலமாக திருத்தப்பட்டது

In reply to point 2 of the message of a2jc4life (and thousands of other users):

"I think it's ridiculous that the default is now a blank box that LOOKS like something is missing...."

I opened this bug. Who does not like this new favicon, could vote for the resolution of this bug.

https://bugzilla.mozilla.org/show_bug.cgi?id=702730

1. Same problem with missing icons. 2. Firefox, you should keep all my settings the same when upgrading unless I give the installation program permission to change things. With all due respect, you haven't been taking lessons from Microsoft Internet Explorer have you?

Used Check Places and it made no difference.

Very few of my bookmarks had "blank placemakers" before so I guess @Marooned's answer explains the problem?

"Looks like Firefox now only displays those icons defined in HTML

<link rel="shortcut icon" type="image/x-icon" href="path/to/favicon.ico"/>

and does not try to read default "favicon.ico". Additionally, FF stopped generating favicons from images if the link is a direct link to an image file.

The question is: bug or feature? "

Either way, it is hardly a big deal, just a minor irritation.

I am more than pleased that FF is now running fast enough and freezing less often to actually use it again (though that solution might lie in having disabled a load of add-ons and there being a duff one amongst them - or perhaps the oddly numbered version of Session Manager that didn't update when it should have?).

I agree this is a bug.

jdevlin மூலமாக திருத்தப்பட்டது

Since my toolbar is for icons to commonly used sites, I have eliminated the text to fit them all on the toolbar. Now all i have is a bunch of empty squares on my toolbar. I have to rollover the square to see what site it's for. This is incredibly stupid and a real pain in the ass. Please fix this.

I know it's not THE solution, however, after screening and cleaning bookmaks vith the extension 'CheckPlaces', many icons appeared (not all but a lot).

I will return to Firefox 8 when the .ico problem is solved. Firefox 7 rules!

I agree. I have same exact problem. Mozilla programmers can ask all the normal detailed specific trouble shooting questions they want but it's this simple. My favicons for bookmarks were present globally in Firefox before I upgraded to Firefox 8. After the upgrade the favicons are missing. Each favicon reappears on a one by one basis after I click the link once. But I have probably 300-400 bookmarks in my bookmark folder and I don't have the time to click each one once.

Same problem here, but when I looked at bookmarks again, I saw the the ONE I had tested had taken back its icon! So I started clicking my way across the toolbar and they all came back to life again. Problem solved itself.

This never happens to me! Problem solves itself! Wow!

FIREFOX 9.0 is out and apparently this hasn't been changed. So it looks like they plan on leaving it this way. Does anyone have a work around that works yet? For FF 9.0?

For replace the horrible default favicon (dotted square and empty) with a nice favicon. As it was in Firefox 7. The bug is this:

https://bugzilla.mozilla.org/show_bug.cgi?id=702730

In comment number 8 my patch for Firefox 9.0.1

After having applied the patch for FF 9.0.1 and Window XP 32bit Italian, the result was that the dotted blank square was replaced by a light blue rectangle with top right margin folded.

@robemark, My patch change the dotted blank square favicon with this favicon:

https://bug702730.bugzilla.mozilla.or.../attachment.cgi?id=574651

A sheet of paper with the top right corner folded.

I don't know this "Iceberg-" person and don't want to sound like I am questioning his integrity, but I question the wisdom of using a modified omni.jar package (which contains security files) from a stranger which is supplied from a non-secure source, and then having to replace that file every time Firefox is updated. AFAIAC, if you are capable of using a PC, you should be able to follow the instructions for doing this fix via a userChrome.css file, and be done with this issue once and for all.

  1. 1
  2. 2
  3. 3