On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Son's cyber school said we should use older version

  • 1 பதிலளி
  • 1 இந்த பிரச்சனை உள்ளது
  • 14 views
  • Last reply by the-edmeister

When we go to log in to my son's school, this message comes up, "This website currently only supports Microsoft Internet Explorer 7.0 or 8.0 (IE 9.0 is not supported) and Firefox 3.x. Your browser is currently not supported." How do I uninstall the current version and install the version that is compatible with his school?

When we go to log in to my son's school, this message comes up, "This website currently only supports Microsoft Internet Explorer 7.0 or 8.0 (IE 9.0 is not supported) and Firefox 3.x. Your browser is currently not supported." How do I uninstall the current version and install the version that is compatible with his school?

All Replies (1)

Install Firefox Portable 3.6.23 to your hard drive for use at that website. It won't affect your current version of Firefox.

http://portableapps.com/apps/internet/firefox_portable/localization#legacy36