X
Tap here to go to the mobile version of the site.

ஆதரவு மன்றம்

Most bookmark icons (favicon) are blank FF4.0-6.0

  • 25 replies
  • 73 இந்த பிரச்னைகள் உள்ளது
  • Last reply by Chris Ilias
பதிவிடப்பட்டது

why are suddenly all my bookmarks blank, (mostly imported from IE) instead of showing sites default favicon.

it used to be ok before

i would prefer to have this automatically loaded for all existing bookmarks

(also, once fixed can that be stored with my preferences to be synced online?)

why are suddenly all my bookmarks blank, (mostly imported from IE) instead of showing sites default favicon. it used to be ok before i would prefer to have this automatically loaded for all existing bookmarks (also, once fixed can that be stored with my preferences to be synced online?)

jbir359 மூலமாக திருத்தப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

jbir359 said:

i may have found the answer:

The problem was with Ad Muncher it has a setting which i was not aware of. i turned it off to check something else and suddenly favicons started showing up.

the setting is in AdMuncher's Options | filtering tab:

Prevent sites changing bookmark/address icons


un-checking it solved the problem! (for IE9 too) 
Read this answer in context 0

Additional System Details

பயன்பாடு

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

கூடுதல் தகவல்

the-edmeister
  • Top 25 Contributor
  • Moderator
5397 தீர்வுகள் 40134 பதில்கள்
பதிவிடப்பட்டது

https://addons.mozilla.org/en-US/firefox/addon/checkplaces/
This extension has a feature to restore missing Favicons .

Certain file types associated with Firefox bookmarks don't include the Favicons; the JSON bookmarks backup files and the Firefox Sync files don't include them - the HTML "export" files do. (That "image data" can be 95% or more, of the file size for bookmarks files. IOW, the files size would be 20+ times larger just by storing that silly image data.)

Plus, when bookmarks are imported from IE, none of the Favicons are carried forward. IE doesn't provide that feature in their HTM export feature because that isn't part of the "standard" - Firefox added that to their version of "Netscape bookmarks.html - 1" back in 2004.

https://addons.mozilla.org/en-US/firefox/addon/checkplaces/ <br /> This extension has a feature to restore missing Favicons . Certain file types associated with Firefox bookmarks don't include the Favicons; the JSON bookmarks backup files and the Firefox Sync files don't include them - the HTML "export" files do. ''(That "image data" can be 95% or more, of the file size for bookmarks files. IOW, the files size would be 20+ times larger just by storing that silly image data.)'' Plus, when bookmarks are imported from IE, none of the Favicons are carried forward. IE doesn't provide that feature in their HTM export feature because that isn't part of the "standard" - Firefox added that to their version of "Netscape bookmarks.html - 1" back in 2004.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

Thanks for the link to the add-on. it has promise!

It DID use to be ok for older versions of FF! (at least to 3.xx)

This information need not come from IE import, it is available on each sites URL

Size alone is a poor excuse. there is plenty of "fluff" on the system that never gets used or needed (i.e. language files and lots more).

On the other hand, this is very useful feature that saves time every day - it takes little time to recognize a site by its icon vs. having to read long lists of text and trying to remember who is who...

Thanks for the link to the add-on. it has promise! It DID use to be ok for older versions of FF! (at least to 3.xx) This information need not come from IE import, it is available on each sites URL Size alone is a poor excuse. there is plenty of "fluff" on the system that never gets used or needed (i.e. language files and lots more). On the other hand, this is very useful feature that saves time every day - it takes little time to recognize a site by its icon vs. having to read long lists of text and trying to remember who is who...

jbir359 மூலமாக திருத்தப்பட்டது

பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

after having this checkplaces add-on installed for a couple of days, it does not seem to rebuild all favicons, just a few here and there. to bad

after having this checkplaces add-on installed for a couple of days, it does not seem to rebuild all favicons, just a few here and there. to bad
cor-el
  • Top 10 Contributor
  • Moderator
17467 தீர்வுகள் 157838 பதில்கள்
பதிவிடப்பட்டது

Make sure that you do not run Firefox in permanent Private Browsing mode.

  • https://support.mozilla.com/kb/Private+Browsing
  • You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History"
  • To see all History and Cookie settings, choose: Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history
  • Deselect: [ ] "Permanent Private Browsing mode"

A possible cause is a problem with the file places.sqlite that stores the bookmarks and the history.

Make sure that you do not run Firefox in permanent Private Browsing mode. *https://support.mozilla.com/kb/Private+Browsing *You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History" *To see all History and Cookie settings, choose: Tools > Options > Privacy, choose the setting <b>Firefox will: Use custom settings for history</b> * Deselect: [ ] "Permanent Private Browsing mode" A possible cause is a problem with the file places.sqlite that stores the bookmarks and the history. *http://kb.mozillazine.org/Bookmarks_history_and_toolbar_buttons_not_working_-_Firefox

cor-el மூலமாக திருத்தப்பட்டது

பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

1. the only thing in privacy changed from default is checking of "tell website I do no t want to be tracked" (FF will remember history)

2. i have none of the symptoms described in "places.sqlite" link above. (bookmarks open normal etc.) But, all bookmarks' favicons (except for very few) look like a blank page, top right corner folded.

1. the only thing in privacy changed from default is checking of "tell website I do no t want to be tracked" (FF will remember history) 2. i have none of the symptoms described in "places.sqlite" link above. (bookmarks open normal etc.) But, all bookmarks' favicons (except for very few) look like a blank page, top right corner folded.
cor-el
  • Top 10 Contributor
  • Moderator
17467 தீர்வுகள் 157838 பதில்கள்
பதிவிடப்பட்டது

Did you try to remove places.sqlite as test to see if that works?

You can also check the icon prefs on the about:config page and reset them is any is user set (bold).

browser.chrome.favicons
browser.chrome.site_icons
browser.chrome.image_icons.max_size

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

  • Use the Filter bar at to top of the about:config page to locate a preference more easily.
  • Preferences that have been modified show as bold(user set).
  • Preferences can be reset to the default or changed via the right-click context menu.
Did you try to remove places.sqlite as test to see if that works? You can also check the icon prefs on the about:config page and reset them is any is user set (bold). browser.chrome.favicons browser.chrome.site_icons browser.chrome.image_icons.max_size To open the <i>about:config</i> page, type <b>about:config</b> in the location (address) bar and press the "<i>Enter</i>" key, just like you type the url of a website to open a website.<br /> If you see a warning then you can confirm that you want to access that page.<br /> *Use the Filter bar at to top of the about:config page to locate a preference more easily. *Preferences that have been modified show as bold(user set). *Preferences can be reset to the default or changed via the right-click context menu.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

i went into about:config and made sure all the mentioned items are default.

also, i tried to rename places.sqlite, restarting FF, then re-run the checkplaces add-on. nothing has really changed. in one of my bookmark folders i use often i have 3 icons for about 50 bookmarks...

(i have never done any editing of these items personally before)

i went into about:config and made sure all the mentioned items are default. also, i tried to rename places.sqlite, restarting FF, then re-run the checkplaces add-on. nothing has really changed. in one of my bookmark folders i use often i have 3 icons for about 50 bookmarks... (i have never done any editing of these items personally before)
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

since my earlier post I noticed that if I open a webpage from the Library window by double clicking there on some bookmarks, they get favicons immediately. (which brings the question why did Check Places add-in not add them to start with)

some others do not (they also do not display an icon next to their URL in the address bar)

I am not sure how to interpret this, have some sites stopped using faicons.ico? in the past 90% or more of my bookmarks had icons associated with them (some were kind of generic) now 90% do not have any icons.

since my earlier post I noticed that if I open a webpage from the Library window by double clicking there on some bookmarks, they get favicons immediately. (which brings the question why did Check Places add-in not add them to start with) some others do not (they also do not display an icon next to their URL in the address bar) I am not sure how to interpret this, have some sites stopped using faicons.ico? in the past 90% or more of my bookmarks had icons associated with them (some were kind of generic) now 90% do not have any icons.
cor-el
  • Top 10 Contributor
  • Moderator
17467 தீர்வுகள் 157838 பதில்கள்
பதிவிடப்பட்டது

Make sure that you do not run Firefox in permanent Private Browsing mode.

  • https://support.mozilla.com/kb/Private+Browsing
  • You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History"
  • To see all History and Cookie settings, choose: Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history
  • Deselect: [ ] "Permanent Private Browsing mode"
Make sure that you do not run Firefox in permanent Private Browsing mode. *https://support.mozilla.com/kb/Private+Browsing *You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History" *To see all History and Cookie settings, choose: Tools > Options > Privacy, choose the setting <b>Firefox will: Use custom settings for history</b> * Deselect: [ ] "Permanent Private Browsing mode"
the-edmeister
  • Top 25 Contributor
  • Moderator
5397 தீர்வுகள் 40134 பதில்கள்
பதிவிடப்பட்டது

As far as the CheckPlaces goes, did you select the "Load Favicons" option before running the "Check" routine?

See the screenshot below.

As far as the CheckPlaces goes, did you select the "Load Favicons" option before running the "Check" routine? See the screenshot below.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

1. as stated earlier, FF is not in private mode or permanent private mode. ("Remember History" is checked) only change form default is: "tell websites you do not want to be tracked" is checked

2. correct, CheckPlaces' "Load Favicons" option is/was checked

1. as stated earlier, FF is not in private mode or permanent private mode. ("Remember History" is checked) only change form default is: "tell websites you do not want to be tracked" is checked 2. correct, CheckPlaces' "Load Favicons" option is/was checked
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

in the FF video on Tab groups (https://support.mozilla.com/en-US/kb/what-are-tab-groups) icons for CNN and The New York Times tabs are clearly visible.

When I browse either of then I get nothing. why?

in the FF video on Tab groups ([https://support.mozilla.com/en-US/kb/what-are-tab-groups]) icons for CNN and The New York Times tabs are clearly visible. When '''I''' browse either of then I get nothing. why?
cor-el
  • Top 10 Contributor
  • Moderator
17467 தீர்வுகள் 157838 பதில்கள்
பதிவிடப்பட்டது

Do you see the favicons in Tools > Page Info > Media if you open a web page or is that entry grayed?

Do you see the favicons in Tools > Page Info > Media if you open a web page or is that entry grayed?
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

i can see the media in tools | page info

i can see the media in tools | page info

jbir359 மூலமாக திருத்தப்பட்டது

cor-el
  • Top 10 Contributor
  • Moderator
17467 தீர்வுகள் 157838 பதில்கள்
பதிவிடப்பட்டது

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

You can also try "Reset all user preferences to Firefox defaults" on the Troubleshoot Firefox issues using Safe Mode start window.

Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes). *Don't make any changes on the Safe mode start window. *https://support.mozilla.com/kb/Safe+Mode You can also try "Reset all user preferences to Firefox defaults" on the [[Safe mode]] start window. * http://kb.mozillazine.org/Resetting_preferences
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

FF is running now in safe mode (no add-ons), opening cnn.com shows no icon in the tab.

when i pull down the page info button (or hover over tab's icon) i see

"This web site does not supply any identity information"

FF is running now in safe mode (no add-ons), opening cnn.com shows no icon in the tab. when i pull down the page info button (or hover over tab's icon) i see "This web site does not supply any identity information"
Hasan 469 தீர்வுகள் 5600 பதில்கள்
பதிவிடப்பட்டது

Troubleshooting plugins

Check and tell if its working.

Troubleshooting plugins * https://support.mozilla.com/en-US/kb/Troubleshooting%20plugins Check and tell if its working.
பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

why would i try troubleshoot plug-ins if same problem occurs without any? (safe mode)

why would i try troubleshoot plug-ins if same problem occurs without any? (safe mode)
Hasan 469 தீர்வுகள் 5600 பதில்கள்
பதிவிடப்பட்டது

Plugins are not Disabled when you use Firefox Safe Mode. All available Plugins are used in Safe Mode. So you need check them out..

Check and tell if its working.

Plugins are not Disabled when you use Firefox Safe Mode. All available Plugins are used in Safe Mode. So you need check them out.. Check and tell if its working.

Hasan மூலமாக திருத்தப்பட்டது

பதிவிடப்பட்டது

கேள்வியின் உரிமையாளர்

ok, manually disabling all plug-ins and restarting FF made no difference. cnn.com still has no icon on the tab

ok, manually disabling all plug-ins and restarting FF made no difference. cnn.com still has no icon on the tab