Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does FireFox 4 (that's the Newest Version) keep crashing when i do a Google Search???

  • 8 பதிலளிப்புகள்
  • 167 இந்த பிரச்னைகள் உள்ளது
  • Last reply by Andyfoxer

I downloaded FireFox 4 on Friday 25 March 2011. It would run ok with my saved Bookmarks and is faster BUT when i do a Google Search, Firefox 4 ALWAYS freezes/crashes. Windows Task Manager displays the message "Not Responding".

Today, I have re-installed FireFox 3.6.16 because of the Freeze/Crash problem that i'm encountering with FireFox 4.

All Replies (8)

It might be a problem with Mcafee Site Advisor... Do you have it installed?

In my case I can only run Firefox 4 in safe mode. I have uninstalled all extensions, created new profile and no luck. Every time I start Firefox 4 normally it hangs a couple of seconds then it crashes. I am using XP x64 and I can provide full system spec if needed. ....really disappointed as I was looking forward to Firefox 4, but I have high hope it'll be fixed Cheers

No, I do not use McAfee Site Advisor.

It seems that other users are having the same "Freeze" problem with FireFox 4.

I also use XP and i'm also disappointed that FireFox 4 has this "Freeze/hang" problem.

Apparently I have found a workaround: 1) right click on Firefox.exe 2) compatibility tab..check-mark Run this program in compatibility.. and select windows 2000 3) apply

hopefully will work for other people. .......and hopefully it gets fixed

I run Windows 7 and Bullguard antivirus and firewall. Just like others F4 stops working when attempting to Go0gle. I downloaded and installed Firefox 3, it automatically replaced 4 and all is well again.

I had exactly the same problem - solved by disabling the Bullguard "safesite" plug in. works perfectly now looks better and is just noticably faster!

Didn't work for me but diabling the Bullguard "safesite" plug in solved the prob.