Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Is the newer Firefox version compatible with all Mac? My last download said it was not.

  • 22 பதிலளிப்புகள்
  • 376 இந்த பிரச்னைகள் உள்ளது
  • 1409 views
  • Last reply by HalFonts

I have MAC OS X 10.4.11

தீர்வு தேர்ந்தெடுக்கப்பட்டது

See:

No, Firefox 4 requires at least OS X 10.5 and an Intel Mac.

You can look at:

Read this answer in context 👍 20

All Replies (20)

தீர்வு தேர்ந்தெடுக்கப்பட்டது

See:

No, Firefox 4 requires at least OS X 10.5 and an Intel Mac.

You can look at:

Well, I think the Intel Mac requirement needs to be more prominently displayed. The download bar merely says it's a download for Mac OS X with a sub-note All Systems and Languages. My 10.1.11 rejected it. Poor execution by Mozilla, I think.

Yes agreed - now I have to see how to uninstall Firefox and see if it is possible to revert back to my older version.....as yet I haven't done this, so am using Safari instead - perhaps what Apple ultimately intended!

Ditto here. I can't find anyplace to re-install the older version. Can anyone help?

So how do you find the older version to install on Mac OS X 10.4.11?

I can't get the older version download to start. never mind i lied it downloaded

winston99 மூலமாக திருத்தப்பட்டது

There's also an outside group that is maintaining a version of Firefox 4 that works on PPC. You can get it here: http://www.floodgap.com/software/tenfourfox/

fairly annoyed about this lack of disclosure. The 'all systems and languages' was pretty reassuring. Mozilla needs a link for less than os 10.5 asap. safari isn't as bad as it used to be.

The older version fixed the problem. I downloaded it and it seems to work fine. Thanks to the ed-meister!

Indeed. When you go to http://www.mozilla.com/en-US/firefox/all.html to look at all the translations, the icon next to the Mac versions is the blue/light blue ying-yang symbol, which in the world of Mac means a Universal Binary (works on PowerPC and Intel). I know Firefox 4 just got released and the Web site may not be on the priority list, but all of those symbols are now inaccurate.

If you Mozilla folks drop PowerPC support from one beta to another, the minimum you should really do is provide a link to TenFourFox instead of letting PPC users download the Intel version and let them find out after installation and possibly deleting the old version that FF 4 doesn't work on PPC any morel!

I know in the meantime that you mentioned 10.5 and Intel in the system requirements. But who reads that after having used FF faithfully for years and the first FF 4 betas still supporting PPC?

It's really a strange way of dumping PPC and 10.4 users!

MacLake மூலமாக திருத்தப்பட்டது

No!! It does not work on OS X 10.5.8 either. Plus it renders the previously installed version of Firefox (3.6.10 in my case) unusable, just by trying to copy the new firefox.app to the Apps folder (an action which is says it cannot complete).

I guess I'll have to use Time Machine to restore my working Firefox 3.6.10 (I've already tried restarting my computer, doesn't help).

Mozilla obviously did a poor job of this! I downloaded the new version assuming it's OK to use and now I can't find a place to get the old 10.4.11 version back. All of my saved sites have probably been lost. Where can I find 10.4.11 that I had????

TenFourFox sounds great. And by the way, why doesn't Mozilla have a link to their system requirements next to the Download link (or at least on the same page)?

I just downloaded an older version for a 10.4.11 Mac. Try this website: http://www.mozilla.com/en-US/firefox/all-older.html

Look for Firefox 3.6.16 I know this version works on 10.4 machines.


fixed link.

James மூலமாக திருத்தப்பட்டது

To reinstall the older version of Firefox go to: Main download site http://www.mozilla.com/en-US/firefox/new/ click on All Systems & Languages (under Firefox 4 download bar), right side of page you find Other Firefox Downloads, under that you find Firefox 3.6.16 click on that and follow instructions.

firefox 4 does not work on my os x 10.5.8! it replaced my old version of firefox. i had to use the safari and reinstall the 3.6 version. firefox needs to make it clear on what systems it will work on, and hopefully fix this so that it will work on the 10.5.8. i cannot upgrade my system any farther and i getting tired of seeint the warning about "my version being old and not having the same saftey, and that i should download 4.0."

This worked for me and miraculously all of my bookmarks were there! It still sucks that Mozilla isn't supporting version 4 with the older system software. My 10.4.11 still works fine on my MacBookPro - I really don't want to have to upgrade until I replace this machine in a year or so!

to reinstall the older version of Firefox go to: Main download site http://www.mozilla.com/en-US/firefox/new/ click on All Systems & Languages (under Firefox 4 download bar), right side of page you find Other Firefox Downloads, under that you find Firefox 3.6.16 click on that and follow instructions.

I did this and clicked on "New Languages still in beta" on the right side and downloaded the English version of 3.6.12 and all is well. Favs and links are still all good. Thank you, hope all gets better soon.

  1. 1
  2. 2