Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Command-click does not open links on

  • 19 பதிலளிப்புகள்
  • 8 இந்த பிரச்னைகள் உள்ளது
  • Last reply by Morbus

Title of my post says it all really: On a Mac, when command-clicking an auction link in a page of search results, the auction should open in a new tab. Instead, nothing happens. If I control-click to bring up the contextual menu I can open in a new tab OK.

This started happening a few weeks ago - maybe after a Firefox or Java update?

This does not happen on, by the way, just the US site.

URL of affected sites

All Replies (19)

Hello Iain.

I'll tell you something that should be common knowledge but it isn't, and once you know it, it will change your life forever!

If you middle-click a link (pressing the scroll wheel on your mouse) it will open in a new tab!

Go try it :)

But if that doesn't work, you may be having a problem with some extension or plugin that is hindering your Firefox's normal behavior. Have you tried disabling all add-ons (just to check), to see if Firefox goes back to normal?

Thanks for the scrollwheel tip Morbus, but unfortunately I'm using an Apple MacBook with a trackpad! Yes, I've tried disabling add-ons.

Yeah, every website in the world works fine except eBay. I use a laptop too, like most of the modern computer-using world, and don't have a middle mouse button. I just want to be able to command-click like I have for years without difficulty.

I use a PC. This started to happen to me yesterday as well It's really frustrating. Does anyone have any other suggestions?

I'm the original poster.

I created a brand new Firefox profile with no add-ons. Problem still happens.

More weird behaviour: if I'm on an auction page and click on a "See seller's other items" link, I can Command-click to open a new tab fine from the resulting list.

firefox is crashing  whenever i make a bid on ebay

IainNZ, the same thing is happening to me, on a MacBook. If I control-click or right-click on a listing, i can select "Open in New Tab," which works as it should. But the problem seems limited to a page of auction listings.. command-clicking works perfectly on an item's page.

Yup, me too. sometimes, on a Firefox restart it will work for a while. Command-clicking to open in a new tab works fine on Safari.

Windows 7 x64

Happens to me too but only in the last few days, perhaps ebay has changed their code?

"Clear the Cache": Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now" "Remove the Cookies" from sites that cause problems: Tools > Options > Privacy > Cookies: "Show Cookies"

Menu differences: Windows: Tools > Options - Mac: Firefox > Preferences - Linux: Edit > Preferences --- Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes). See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

I posted this elsewhere thought you may benefit too on this thread. I had similar issue then realized I recently did an update to Windows XP. Maybe not the best solution but set my system back to a restore point I knew was prior to that update. In my case that was from 5/9 although that is probably well back of where needed. Anyway, setting back to that restore point prior to that update, ebay appears to be working fine. Will do the Windows updates but will be more careful when selecting and will make sure to create a new restore point prior to updating. Hope this helps. FF fan.

I'm on a Mac, but thanks for contributing. As it happens, today seems to be working correctly again - cross fingers and touch wood. The eBay page might look a little different too perhaps, so maybe eBay have rewritten it.

Working for me too on Windows 7 x64 at

Must have been a bug in their scripting as it wasn't working yesterday..

Ebay probably did change something. Mine started to function again a few days ago. Thanks for everyone's contribution and help.

So, who's at fault: eBay or Firefox? Or is it a pass the buck type of problem?

So, who's at fault: eBay or Firefox? Or is it a pass the buck type of problem?

Must have been some weird Java or somesuch incompatibility in the eBay code.

I just installed Ubuntu 10.04 with Firefox 3.6.8 and also getting an error on eBay when clicking on item I already bid on with a Windows PC. It states "Your browser doesn't follow HTML standards and made an invalid request. If you feel you have reached this page in error, please try again, maybe with a different browser.." I seem to have some Linux curse. As soon as I think things are working well, something like this pops up.

Any solutions?

Open PREFERENCES click on PRIVACY then select SHOW COOKIES then look for ebay's cookies an delete them............ PROBLEM SOLVED