Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Ridgid site not working

  • 2 பதிலளிப்புகள்
  • 0 இந்த பிரச்னைகள் உள்ளது
  • 6 views
  • Last reply by R B (The Fixer The Builder)

https://register.ridgidpower.com/# is not working. Specifically the Sign-In link. It works just fine with MS Edge. I had all extensions off, anti-virus off and I also cleared the cache twice, and also followed the Help/Troubleshoot Mode to no avail. I'm using V125.0.1 64bit

https://register.ridgidpower.com/# is not working. Specifically the Sign-In link. It works just fine with MS Edge. I had all extensions off, anti-virus off and I also cleared the cache twice, and also followed the Help/Troubleshoot Mode to no avail. I'm using V125.0.1 64bit

All Replies (2)

Try clearing site cookies and disabling Tracking Protection for the site.

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile. Make sure you stay signed out of your sync account when testing.

Helpful?

Without doing anything different, it works today. I even left the webpage site up and only did another refresh page, but I also emailed Ridgid about this matter the same time as Mozilla. I wonder if Ridgid fixed something on their end. Thanks for your input.

R B (The Fixer The Builder) மூலமாக திருத்தப்பட்டது

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.