Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't login to my GM account using Firefox

  • 7 பதிலளிப்புகள்
  • 0 இந்த பிரச்னைகள் உள்ளது
  • 42 views
  • Last reply by 53gmcgarry

I have a General Motors account that I can't login to. https://www.gmccanada.ca/en/ownercenter/service They recently changed to multi authentication using Microsoft. I can login to the first step but after I enter the sent password in the second step nothing happens. I have tried basic some trouble shooting like Firefox trouble mode, clearing cache and adding web site to exceptions in settings. GM Help Line told me to use a different browser!!!

I have a General Motors account that I can't login to. https://www.gmccanada.ca/en/ownercenter/service They recently changed to multi authentication using Microsoft. I can login to the first step but after I enter the sent password in the second step nothing happens. I have tried basic some trouble shooting like Firefox trouble mode, clearing cache and adding web site to exceptions in settings. GM Help Line told me to use a different browser!!!

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Retested the problem today and it now works okay. I assume that GM must have changed something on their website to fix the problem because I am still running the same version of Firefox!!

Read this answer in context 👍 0

All Replies (7)

Can you update to the current Firefox 117.0 release to see if this still happens ?


You can check for issues with Total Cookie Protection.

You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or if userChrome.css/userContent.css is causing the problem.

  • switch to the Default System theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

The above information did not fix the problem. As I mentioned it happens on multiple machines including an android app so the chances of all devices having the same problem and any of the solutions above fixing it is quite slim but I did do all the suggestions on one of my computers but it did not help.

I can sign in to GMC with MFA using email or authenticator app (latter requires two attempts) with Firefox versions 115 ESR and 117. The app security codes won't work if the clock time is incorrect.

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.

Thank you for your quick reply. I have just loaded version 118 of Firefox on my 4th device (2 Desktops, Laptop, android app) and it doesn't work there either. This should be a nice clean install?? I assume that should rule out a profile, add-on, extension problem etc. Just to clarify that the problem I am having is trying to login to my GM account in Canada. https://www.gmccanada.ca/en/owners. It am guessing that you are logging into a US account not Canada??

I tested on GMC Canada.

A new installation will not be clean if there is an old Firefox profile on the system.

Things that could interfere include third-party anti-virus, security software, VPN, DNS, firewall, proxy and network filters.

Again Thank you for all your help. I tried to refresh my Profile and that did not work. I downloaded Firefox Developer Edition and it WORKS fine?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Retested the problem today and it now works okay. I assume that GM must have changed something on their website to fix the problem because I am still running the same version of Firefox!!