Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Extension Management

  • 3 பதிலளிப்புகள்
  • 0 இந்த பிரச்னைகள் உள்ளது
  • 60 views
  • Last reply by andrew219

Hi All,

I have recently been enhaciing our security posture and have started sorting out our browser extensions, however I seem to be having errors allowing 2 extensions

  • 1Password; and
  • Firefox Multi Containers.

This is my json:

{ "*": { "blocked_install_message": "version 0.4 - Addon or Extension is not approved. Please submit a ticket to Help Desk if you need access to this extension.", "install_sources": ["https://addons.mozilla.org/"], "installation_mode": "blocked" }, "{bc8367b6-d946-484e-8da6-37691f23ee64}": { "installation_mode": "allowed", "install_url": "https://addons.mozilla.org/firefox/downloads/latest/1password-x-password-manager/latest.xpi" }, "{2a28e7e4-64c9-4e7f-81fb-0475af840c0f}": { "installation_mode": "allowed", "install_url": "https://addons.mozilla.org/firefox/downloads/latest/multi-account-containers/latest.xpi" } }

I have tried the obvious and removed the {} from both extensions, however still having troubles.

Is someone able to point me in the right direction?

Hi All, I have recently been enhaciing our security posture and have started sorting out our browser extensions, however I seem to be having errors allowing 2 extensions * 1Password; and * Firefox Multi Containers. This is my json: { "*": { "blocked_install_message": "version 0.4 - Addon or Extension is not approved. Please submit a ticket to Help Desk if you need access to this extension.", "install_sources": ["https://addons.mozilla.org/"], "installation_mode": "blocked" }, "{bc8367b6-d946-484e-8da6-37691f23ee64}": { "installation_mode": "allowed", "install_url": "https://addons.mozilla.org/firefox/downloads/latest/1password-x-password-manager/latest.xpi" }, "{2a28e7e4-64c9-4e7f-81fb-0475af840c0f}": { "installation_mode": "allowed", "install_url": "https://addons.mozilla.org/firefox/downloads/latest/multi-account-containers/latest.xpi" } } I have tried the obvious and removed the '''{}''' from both extensions, however still having troubles. Is someone able to point me in the right direction?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Resolved :)

{ "*": { "blocked_install_message": "Please contact the system administrator to request an addon or extension", "install_sources": ["https://addons.mozilla.org/*"], "installation_mode": "blocked" }, "{d634138d-c276-4fc8-924b-40a0ea21d284}": { "installation_mode": "allowed", "install_url": "https://addons.mozilla.org/firefox/downloads/latest/1password-x-password-manager/latest.xpi" }, "@testpilot-containers": { "installation_mode": "allowed", "install_url": "https://addons.mozilla.org/firefox/downloads/latest/multi-account-containers/latest.xpi" } }

I had the incorrect IDs

Read this answer in context 👍 0

All Replies (3)

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Resolved :)

{ "*": { "blocked_install_message": "Please contact the system administrator to request an addon or extension", "install_sources": ["https://addons.mozilla.org/*"], "installation_mode": "blocked" }, "{d634138d-c276-4fc8-924b-40a0ea21d284}": { "installation_mode": "allowed", "install_url": "https://addons.mozilla.org/firefox/downloads/latest/1password-x-password-manager/latest.xpi" }, "@testpilot-containers": { "installation_mode": "allowed", "install_url": "https://addons.mozilla.org/firefox/downloads/latest/multi-account-containers/latest.xpi" } }

I had the incorrect IDs

Awesome!

Also, fyi, you can remove install_sources and both of those install_urls.

install_sources is only needed to add sources and install_url are only needed if you force things.

By enabling those IDs, they can be installed from anywhere.