Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

High memory and cpu usage for just opening the browser

  • 5 பதிலளிப்புகள்
  • 0 இந்த பிரச்னைகள் உள்ளது
  • 92 views
  • Last reply by cor-el

I been having problems with firefox using up most of my cpu while browsing some websites and it doesn't even load as fast as before. This has been happening for a few days now. Prior to this, firefox was fine and loading pretty quick, but these last few days have been painful.

Thinking that was a small bug, i restarted my computer. Before opening the firefox again, I opened up task manager to check how much resources will the browser be using. Before that usage would be normal and not even close to high, but opening firefox and waiting a few seconds to let the home window appear, the task manager showed that it was using all of it still.

I browsed some other help questions on this website and disabled "Use recommended performance settings", because that was one of the solutions on one of the relevant questions. But even that didn't do reduce resource usage either. Is there any way to fix this or will I have to suck it up and suffer with slow loading?

I been having problems with firefox using up most of my cpu while browsing some websites and it doesn't even load as fast as before. This has been happening for a few days now. Prior to this, firefox was fine and loading pretty quick, but these last few days have been painful. Thinking that was a small bug, i restarted my computer. Before opening the firefox again, I opened up task manager to check how much resources will the browser be using. Before that usage would be normal and not even close to high, but opening firefox and waiting a few seconds to let the home window appear, the task manager showed that it was using all of it still. I browsed some other help questions on this website and disabled "Use recommended performance settings", because that was one of the solutions on one of the relevant questions. But even that didn't do reduce resource usage either. Is there any way to fix this or will I have to suck it up and suffer with slow loading?
Attached screenshots

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Your System Details show that you have the Malwarebytes Browser Guard extension. We have seen reports from Firefox 113 users that Malwarebytes Browser Guard is causing slowness issues, so if you use this extension and it is causing issues then best is to contact Malwarebytes for support.

Read this answer in context 👍 1

All Replies (5)

Clear cache and history plus if you have a lot of tabs open it will cause this problem

AzZA said

Clear cache and history plus if you have a lot of tabs open it will cause this problem

I did that already, it still doesnt change the usage. At most, i can only do one tab at a time which take around 10-20 seconds on average to load.

Erm, Small update. I restarted my pc after AzZa commented their solution and it's mostly fixed. There is still some slight loading delays, but I think it's because my pc is just warming up before going fast.

Thank you AzZa, for telling me to clear my cache and stuff. >~>

Another update. The issue appeared again, but after trying the the troubleshooting mode for a little, the problem was one of the extensions. An adblocker to be precise. No idea what kind of command was running on repeat to cause such lag.

Though, this doesn't mean that it was the final solution, as mentioned previously, AzZa's solution for clearing the cache, cookies and history did contribute to a decrease on my computer's load.

Rude Red மூலமாக திருத்தப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Your System Details show that you have the Malwarebytes Browser Guard extension. We have seen reports from Firefox 113 users that Malwarebytes Browser Guard is causing slowness issues, so if you use this extension and it is causing issues then best is to contact Malwarebytes for support.