Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox doesn't load specific webpage

  • 8 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 12 views
  • Last reply by jonzn4SUSE

Dear sir/madam,

I have an issue with a specific webpage which doesn't load and since it's the second time it is happening I decided to ask for your help. More specific, since today I can't open this webpage: www.offradio.gr. As I said it's the second time dealing with this issue. The webpage seems to work fine, because I already tried with another browser and load fine but not with Firefox. Thanks in advance.

Regards,

George Falias

Dear sir/madam, I have an issue with a specific webpage which doesn't load and since it's the second time it is happening I decided to ask for your help. More specific, since today I can't open this webpage: www.offradio.gr. As I said it's the second time dealing with this issue. The webpage seems to work fine, because I already tried with another browser and load fine but not with Firefox. Thanks in advance. Regards, George Falias

All Replies (8)

The site works for me. see screenshot Did you try with Firefox in Safe Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode

You can also try the option to Forget About This Site, but make sure you know the login if used. https://support.mozilla.org/en-US/kb/remove-websites-address-bar-suggestions

Another option is to refresh Firefox. Read the warning. https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

jonzn4SUSE மூலமாக திருத்தப்பட்டது

Can post a screenshot of what your seeing? What security software are you running?

jonzn4SUSE said

The site works for me. see screenshot Did you try with Firefox in Safe Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode You can also try the option to Forget About This Site, but make sure you know the login if used. https://support.mozilla.org/en-US/kb/remove-websites-address-bar-suggestions Another option is to refresh Firefox. Read the warning. https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

Tried all of these before posting but nothing solved it. Even deleted cookies, but still nothing, It just tries to load it with no success

jonzn4SUSE said

Can post a screenshot of what your seeing? What security software are you running?
Using Bitdefender, but never had any problems. It's the only website that refuses to load...

Tried to connect using VPN and worked...Don't know what to say...

Glad to see that you've shown it's not a browser issue. Can you disable Bitdefender, reboot, and try again without VPN.

jonzn4SUSE said

Glad to see that you've shown it's not a browser issue. Can you disable Bitdefender, reboot, and try again without VPN.

Nope, still the same situation. I don't know if I unistall/re-install Firefox will solve it, but what is frustrating is that happening only on this specific webpage.

Are you running Win10 Pro? If so, try running windows sandbox. If you have no issue in sandbox then this confirms that BD is your issue.

https://www.howtogeek.com/399290/how-to-use-windows-10s-new-sandbox-to-safely-test-apps/