Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox View Not Enabled By Default On Update to 106 on Arch Linux

  • 14 பதிலளிப்புகள்
  • 0 இந்த பிரச்னைகள் உள்ளது
  • 61 views
  • Last reply by Harley The Foxy

I have recently updated to Firefox 106 on two Arch Linux systems. One of them has Firefox View enabled and working by default, another does not. I looked around and tried some options in about:config to enable it, however it did not work and I reverted the changes. I would like to enable Firefox View on this browser as well, and I would like to know how to enable it.

I have recently updated to Firefox 106 on two Arch Linux systems. One of them has Firefox View enabled and working by default, another does not. I looked around and tried some options in about:config to enable it, however it did not work and I reverted the changes. I would like to enable Firefox View on this browser as well, and I would like to know how to enable it.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

"TabsToolbar":["firefox-view-button"] would indicate that the Firefox View button should be positioned on the Tab bar.

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Read this answer in context 👍 1

All Replies (14)

Hi Harley, Firefox View works like a toolbar button, so it could be mixed in with the other available buttons on the Customize screen. This article will get you in there -- can you find it and drag it where you want it?

Customize Firefox controls, buttons and toolbars

Hi

Are you using the version in the Arch repo, or are you using the tarball, snap or flatpak versions that are provided by Mozilla?

I am using the version in the Arch repo. I have it installed the same way on another PC, and Firefox View works correctly on that PC, however not on this one.

Can you try one of the Mozilla builds? It may be the case that the maintainer of the Arch build has not included the new feature in their package.

Well as I said the feature is enabled just fine on another Arch PC using the same package. But I can try one of mozilla's builds to see if anything changes, anyway!

The flatpak version also does not have Firefox View for me.

Do you have firefox-view pref on the about:config page?

  • browser.tabs.firefox-view

You can also check the browser.uiCustomization.state pref to see whether that has the firefox-view-button under the "TabsToolbar" key.

cor-el said

Do you have firefox-view pref on the about:config page?
  • browser.tabs.firefox-view

Yes, it is there and set to true.

cor-el said

You can also check the browser.uiCustomization.state pref to see whether that has the firefox-view-button under the "TabsToolbar" key.

firefox-view-button is within that key as well.

The JSON is hard to read, but if you work your ways backwards from "firefox-view-button" to the previous left bracket ([), which toolbar is listed to the left of it? For example:

  • "toolbar-menubar" (optional menu bar)
  • "TabsToolbar" (tabs bar)
  • "nav-bar" (main toolbar)
  • "PersonalToolbar" (Bookmarks Toolbar)
  • "widget-overflow-fixed-list" (pinned to overflow)
  • something else?

You can try "Clear the startup cache..." via the "Help -> More Troubleshooting Information" (about:support) page.

jscher2000 - Support Volunteer said

The JSON is hard to read, but if you work your ways backwards from "firefox-view-button" to the previous left bracket ([), which toolbar is listed to the left of it? For example:
  • "toolbar-menubar" (optional menu bar)
  • "TabsToolbar" (tabs bar)
  • "nav-bar" (main toolbar)
  • "PersonalToolbar" (Bookmarks Toolbar)
  • "widget-overflow-fixed-list" (pinned to overflow)
  • something else?

"toolbar-menubar":["menubar-items"],"TabsToolbar":["firefox-view-button","tabbrowser-tabs","new-tab-button","alltabs-button"]

cor-el said

You can try "Clear the startup cache..." via the "Help -> More Troubleshooting Information" (about:support) page.

Unfortunately, this did not work.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

"TabsToolbar":["firefox-view-button"] would indicate that the Firefox View button should be positioned on the Tab bar.

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

cor-el said

"TabsToolbar":["firefox-view-button"] would indicate that the Firefox View button should be positioned on the Tab bar. You can create a new profile as a quick test to see if your current profile is causing the problem. See "Creating a profile": If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Creating a new profile did work. I should be able to copy the data over, so I'm going to attempt that now.