Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

lastest versions have screwed up my computer. HELP!

  • 7 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 16 views
  • Last reply by emberg418

Good morning, There are multiple questions. 1. Now everytime I click on a link in an article it opens a completely different page of firefox instead of just making a tab on the line with all the other tabs. It also loads that new page half way off the screen on the right hand side and I have to drag it over, open it full sized and then screw around with cutting and pasting the url into a new tab on the old firefox page. How do I stop it from doing this? It's realllllly annoying.

2. It is screwing up some of my graphics by putting horizontal lines into the picutres to where you can't view it. Specifically on jigsaws from jigsawplanet.com. I work on a gaming site and this really impacts my ability to do my job (or have fun).

3. One one particular site HEXrpg.com, I set my view at 120% and every page I go it it reverts it back to 100%. This did NOT used to happen and it only seems to be happening on that particular site..... However, it could be on other sites as I've had to set my entire computer to 120% now so I can read the posts on that one site and now everything is too big for my screens in the other sites.

I don't know what you guys were trying to do, but whatever it was, can you please put it back to the way it was before this last (possibly last 2) updates. If not I'm going to have to switch to Edge or Chrome and I really don't want to have to do this because I've been with Firefox forever. HELP!?! Deborah DeVane

Good morning, There are multiple questions. 1. Now everytime I click on a link in an article it opens a completely different page of firefox instead of just making a tab on the line with all the other tabs. It also loads that new page half way off the screen on the right hand side and I have to drag it over, open it full sized and then screw around with cutting and pasting the url into a new tab on the old firefox page. How do I stop it from doing this? It's realllllly annoying. 2. It is screwing up some of my graphics by putting horizontal lines into the picutres to where you can't view it. Specifically on jigsaws from jigsawplanet.com. I work on a gaming site and this really impacts my ability to do my job (or have fun). 3. One one particular site HEXrpg.com, I set my view at 120% and every page I go it it reverts it back to 100%. This did NOT used to happen and it only seems to be happening on that particular site..... However, it could be on other sites as I've had to set my entire computer to 120% now so I can read the posts on that one site and now everything is too big for my screens in the other sites. I don't know what you guys were trying to do, but whatever it was, can you please put it back to the way it was before this last (possibly last 2) updates. If not I'm going to have to switch to Edge or Chrome and I really don't want to have to do this because I've been with Firefox forever. HELP!?! Deborah DeVane
Attached screenshots

All Replies (7)

Hi Deborah, do you recall any major changes before these new issues appeared, such as either a Firefox update, a Windows update, a browser crash, a system crash, etc.?

1. Now everytime I click on a link in an article it opens a completely different page of firefox instead of just making a tab on the line with all the other tabs. It also loads that new page half way off the screen on the right hand side and I have to drag it over, open it full sized and then screw around with cutting and pasting the url into a new tab on the old firefox page. How do I stop it from doing this? It's realllllly annoying.

Dropa gave you a link to the article Tab preferences and settings. Make sure the checkbox in that first screenshot is checked:

For future reference, you also can click and drag the tab in the new window to the tab bar of the existing window. a Special blue bar with a little circle at the bottom will appear to show where it will be added to the bar (for example, next to the last tab, between two tabs, etc.).

2. It is screwing up some of my graphics by putting horizontal lines into the picutres to where you can't view it. Specifically on jigsaws from jigsawplanet.com. I work on a gaming site and this really impacts my ability to do my job (or have fun).

This is caused by the hidden "resist Fingerprinting" feature -- it restricts how sites can extract images from a page and by default it causes them to look randomly stripey. When you notice this issue, Firefox also should display an extra icon next to the lock in the address bar -- it looks a bit like a picture. Use that icon to give the site permission to extract images from an HTML canvas.

Or if you didn't mean to turn on privacy.resistFingerprinting (maybe you share your Firefox with someone else), you can turn that off. I'll give the steps below the line.

3. One one particular site HEXrpg.com, I set my view at 120% and every page I go it it reverts it back to 100%. This did NOT used to happen and it only seems to be happening on that particular site..... However, it could be on other sites as I've had to set my entire computer to 120% now so I can read the posts on that one site and now everything is too big for my screens in the other sites.

This might also be a side effect of privacy.resistFingerprinting but I think you would need to turn the feature off to test that possibility.


(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we are restoring the default, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste privacy.resistFingerprinting and pause while the list is filtered

(3) Double-click the privacy.resistFingerprinting preference to switch the value from true to false

jscher2000 - Support Volunteer மூலமாக திருத்தப்பட்டது

I have the same problem with links opening new half size windows despite the fact that I have "Open links in tabs instead of new windows" checked in my settings. This issue began several months ago on my old mac mini running El Capitan. I assumed it had to do with the fact that I had long since lost the option to update my Firefox version. I just got a new mac mini and the same thing is still happening. I'm using Firefox 110.0 but I did use Migration Assistant to set up the new computer. I must have migrated the problem as well. Are there certain files I should trash to get a fresh start or is there a clean uninstall for Firefox?

emberg418 said

I have the same problem with links opening new half size windows despite the fact that I have "Open links in tabs instead of new windows" checked in my settings. This issue began several months ago on my old mac mini running El Capitan. I assumed it had to do with the fact that I had long since lost the option to update my Firefox version. I just got a new mac mini and the same thing is still happening. I'm using Firefox 110.0 but I did use Migration Assistant to set up the new computer. I must have migrated the problem as well. Are there certain files I should trash to get a fresh start or is there a clean uninstall for Firefox?

Hi, are you referring to links in web pages you are viewing in Firefox, or external links you are opening from outside of Firefox?

For internal links, is the problem for specific sites or does it affect all links on all sites?

Are the unwanted new windows "popup-style" windows with most of the toolbars missing?

Regarding window sizes, there are some settings files you could clear, but those are not related to whether links open in a new window.

The links are in pages I am viewing in Firefox. The problem affects links from all sights. The new windows are not popup-style, They have all the toolbars.

Thank you for your rapid response. Any thoughts?

emberg418 said

The links are in pages I am viewing in Firefox. The problem affects links from all sights. The new windows are not popup-style, They have all the toolbars.

Normally, Firefox will open most links in the same tab. Firefox will open all links in new windows if it thinks you are holding down the Shift key when clicking. Just in case Firefox is confused about what is going on with your keyboard, try jabbing that key rapidly several times to see whether that makes any difference.

Try to rename/remove xulstore.json in the Firefox profile folder with Firefox closed.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).


You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works, you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

I have solved the problem! I did a complete uninstall of Firefox including the Firefox folder in Application Support. Before I uninstalled I saved my bookmarks as a .json archive. When imported from this archive file everything came back just like it was before. I only had to do a little toolbar customizing. Many thanks to all who have generously offered their assistance.