Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Connection not secure message

  • 15 பதிலளிப்புகள்
  • 0 இந்த பிரச்னைகள் உள்ளது
  • 22 views
  • Last reply by bowtieperformance

I have this problem. It just showed up after installing a brand new ARRIS modem exactly like the one I had. "Your connection is not secure" error when trying to log in to my modem's login page at the local address. There are several fixes that I saw, none seem to help. Tried the SSL refresh and it screwed up the browser. Now I get to figure out how I had it set up before the "refresh". Like I said this just started in Firefox and it prevents me from accessing the modem console period. If I use Edge it does not block me. (yuk) It does show a "Not Secure" message in the address bar but it will allow me to access my Modem. Why cant we get a fix for this. Its a local web address not on the internet. Should be a way to add to a allow local address list and ignore certificates or whatever else is causing it to block access.....

Email me when someone answers the thread seems to be broken on this page. I would like a email please so I can find a response.

[email removed from public]

Thanks! Roger

I have this problem. It just showed up after installing a brand new ARRIS modem exactly like the one I had. "Your connection is not secure" error when trying to log in to my modem's login page at the local address. There are several fixes that I saw, none seem to help. Tried the SSL refresh and it screwed up the browser. Now I get to figure out how I had it set up before the "refresh". Like I said this just started in Firefox and it prevents me from accessing the modem console period. If I use Edge it does not block me. (yuk) It does show a "Not Secure" message in the address bar but it will allow me to access my Modem. Why cant we get a fix for this. Its a local web address not on the internet. Should be a way to add to a allow local address list and ignore certificates or whatever else is causing it to block access..... Email me when someone answers the thread seems to be broken on this page. I would like a email please so I can find a response. [email removed from public] Thanks! Roger

James மூலமாக திருத்தப்பட்டது

All Replies (15)

What instructions did you get for setup of the modem? Did you also look at the site for setup or login issues?

Helpful?

Which modem do you have? https://www.surfboard.com/products/cable-modems/ Can you post a screenshot of the page? I can test my SB8200 when I get home.

Helpful?

bowtieperformance said

It just showed up after installing a brand new ARRIS modem exactly like the one I had. "Your connection is not secure" error when trying to log in to my modem's login page at the local address. There are several fixes that I saw, none seem to help.

Hi Roger, can you copy/paste the fuller explanation of the problem from the error page into your next reply.

Sometimes you can see an ERROR_CODE immediately, while other times, you need to click the Advanced button first. As the first step, we'll check the code against this support article: How to troubleshoot security error codes on secure websites.

Tried the SSL refresh and it screwed up the browser. Now I get to figure out how I had it set up before the "refresh".

What kind of Refresh? Was it the Refresh that moves your Firefox profile folder to an Old Firefox Data folder on your Windows desktop? If so, hang onto that folder and we can provide tips on using some of the files in there.

Why cant we get a fix for this. Its a local web address not on the internet. Should be a way to add to a allow local address list and ignore certificates or whatever else is causing it to block access.....

The best fix depends on the specific situation, so the info requested earlier would be really helpful. But the reason it works like the web is that your router's interface runs on an embedded web server. If your router did not use a web server, you wouldn't be accessing its interface with an http or https address.

Helpful?

1. No, the ISP does any setup not the end user. 2. jonzn4SUSE it is a SB8200. You may find yours does the same thing now.

3. Here's the error off the page: Secure Connection Failed An error occurred during a connection to 192.168.100.1. PR_END_OF_FILE_ERROR The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem.

I googled this message and got a couple fixes like this: https://www.hostinger.com/tutorials/pr_end_of_file_error

The first fix is this: Since PR_END_OF_FILE_ERROR is a Firefox-specific issue, we’ll start by reviewing the browser settings. Reset Firefox SSL Settings

Then it goes on to show you how to do the refresh.

Yes, I completely understand your explanation of the embedded web server. I cant understand what is the root cause of this to suddenly stop working. I was wondering about a settings page to exclude internal web page from this certificate security issue. I believe the browser is looking for a certificate to verify a secure site.

To make matters worse or more strange is this: I pulled a different PC that had been sitting in the corner for 6 months out and connected it to the network. Mostly to remember how had Firefox set up on this PC. Fired it up and launched Firefox. Stopped any updates from installing. Typed in the address for the modem (192.168.100.1) and bingo got right in!!!! So it seems something has happened in the last update to Firefox possibly?

Hope this is all the info you guys asked for, if not let me know I am happy to add anything else you need!!!

Helpful?

Did you try to use the http:// protocol?

Helpful?

cor-el,

Nice try! Yes, I did try that. I have that set now, no difference... It seems to be something deeper than just a setting I can do or undo with a radio button. I tried the Firefox fixes that I saw when the error message comes up it has a link to fixes including this one. Then I tried the fixes on the page that I posted the link.

Thanks!

Helpful?

Did you already set "No proxy" on the Settings page per https://www.hostinger.com/tutorials/wp-content/uploads/sites/2/2021/11/firefox-proxy-settings.webp ?

Do you still have that other computer fired up? You could learn a little more about your connection by calling up Page Info while you're viewing the site (Ctrl+i), switching to the Security tab, and viewing the Technical Details. I don't think there's a way to copy/paste from there, unfortunately.

The link I would pay attention to there is the protocol (the TLS version listed at the end).

Helpful?

Yes, I have it set to no proxy.

I took a picture of the screen with my phone . Cant do a screen shot and cant copy and paste... Does not have any of that in security.

Helpful?

Sorry, but could you look at the Firefox which is able to connect -- your old computer.

Helpful?

What protocol is used on the old computer as the screenshot you provided indicates that you would have to use HTTP and not HTTPS ?

If Firefox insist to upgrade to secure HTTPS then maybe check SiteSecurityServiceState.txt in the Firefox profile folder to see if there is a reference to this local address.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

Helpful?

Is this what you get? see screenshot What is your LAN ip range? I found this... https://superuser.com/questions/834861/unable-to-connect-to-modem-web-interface-through-router I have to plug into my modem to access it because of the ip address.

jonzn4SUSE மூலமாக திருத்தப்பட்டது

Helpful?

Sorry guys. I has out all day just getting back to this...

jscher2000, the security page on the other PC looks just like this one. (screen shot above) There is no different setting in the other PC that I can find. It has all the standard settings not all these that I have changed to try to find the problem. I haven't touched any of those settings! I just prevented a update from getting installed...

Cor-el, I have "don't enable HTTPS- only mode" turned on to see if that made any difference. It did not.

jonzn4SUSE, the modem IP is fixed so IP range would not make any difference. My other PC is on the same network with the same IP range as this one and I can get to the modem with FFox or MS Explorer. I do not get any errors or warning about a security risk. I have seen the security risk warning on this machine but I just clicked "accept the risk" and it logged right in... I never get a log in page like that, I am able to just go right to the console page.

Guys, I am thinking this is not that big of a deal to be having you guys working on this! I don't have to use this very often. I had a router issue the other day and just wanted to check for errors in the log file. I can always use the other browser or PC if needed...

You guys are the best putting in effort to resolve an issue at the drop of a pin!!!

Helpful?

So just for grins I updated the other FFox. It still works!!! It is not in the updated version! It is something related to this PC. Nuts I thought it would break when I updated!!!

You gotta love computers!!!

Helpful?

Once you have used a secure HTTPS connection then Firefox remembers this in SiteSecurityServiceState.txt and will insist in using the https://, so you may not see a difference. Can you confirm what protocol (https:// or http://) is used on the device that works ?


You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

Helpful?

Hey cor-el (and the rest of the guys that worked on this),

You are onto something I think! I had a chance to look at this today and with a fresh perspective I guess. So FF wants to default to https every time I click the saved shortcut now. This causes the error. All I had to do was on the error page delete the "s" and try again and it worked! The address bar then has no http or https just the IP address. Retry and the issue repeats itself. Error page then delete the "s" and it resolves to the IP address.

So whatever, as long as I can get to the console page I really don't care... Its bugs me that the shortcut worked for years, now I have this little issue. No big deal...

Thanks for all the help!

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.