Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I stop Firefox from saving all downloads to my download folder?

  • 9 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 36 views
  • Last reply by AliceWyman

I have used Firefox for years. I am computer literate and do not like the newer approach Firefox has taken to save all downloads to my downloads folder. I have to continually go in and manually delete the files.

For instance, I have a lot of pdf forms that I have to open directly in Acrobat, those files are then duplicated and saved in my downloads. This is causing a mess for me.

This was NOT an improvement in my opinion. Is there a way to stop this???

I have used Firefox for years. I am computer literate and do not like the newer approach Firefox has taken to save all downloads to my downloads folder. I have to continually go in and manually delete the files. For instance, I have a lot of pdf forms that I have to open directly in Acrobat, those files are then duplicated and saved in my downloads. This is causing a mess for me. This was NOT an improvement in my opinion. Is there a way to stop this???

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Firefox version 102 includes a new preference, browser.download.start_downloads_in_tmp_dir that you can toggle to true in the Configuration Editor for Firefox (about:config page). This will save files you open with an application in Firefox in your Windows Temp folder and those files will be deleted after you exit Firefox. This fix was added in Bug 1738574 Want an option to continue to use /tmp and autodelete downloads automatically opened in an application.

See the solution posted here, for details: https://connect.mozilla.org/t5/discussions/firefox-keeps-cluttering-my-download-folder-with-temp-files/td-p/9158

Read this answer in context 👍 2

All Replies (9)

Change the download destination folder Menu -> Settings -> General page -> Files and Applications Save files to -

Helpful?

This does not stop it from saving in a named folder after I have already saved it as a renamed file I open directly in Acrobat Pro.

This is very frustrating and just causes extra steps for me to get rid of all kinds of extra files I don't want and didn't not want Firefox to automatically save.

Helpful?

EDIT It seems that they have now added a new option, see the next post.

ddb6081, I believe that Firefox has always saved copies of opened files locally, but it used to save them in the system temp folder. Whereas now it saves them in the downloads folder. But, again, they have always been saved somewhere on your system.

Unfortunately I do not personally know if it is possible to revert back to the old behaviour of saving temp files in one location, and actual downloads in another.

TechHorse மூலமாக திருத்தப்பட்டது

Helpful?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Firefox version 102 includes a new preference, browser.download.start_downloads_in_tmp_dir that you can toggle to true in the Configuration Editor for Firefox (about:config page). This will save files you open with an application in Firefox in your Windows Temp folder and those files will be deleted after you exit Firefox. This fix was added in Bug 1738574 Want an option to continue to use /tmp and autodelete downloads automatically opened in an application.

See the solution posted here, for details: https://connect.mozilla.org/t5/discussions/firefox-keeps-cluttering-my-download-folder-with-temp-files/td-p/9158

Helpful?

I have done this and will report back if it works.

Thank you very much for the link and information!

Helpful?

Moderator note: The original reply is redacted due to potential copyright infringement. The information this user shared originated from the following article: https://www.askvg.com/tip-restore-classic-download-confirmation-prompt-in-mozilla-firefox/

Kiki மூலமாக திருத்தப்பட்டது

Helpful?

DO NOT follow the advice by Dropa to deactivate the ... improvements_to_download_panel preference. It is an old solution that turns off all download panel improvements.

Setting the new browser.download.start_downloads_in_tmp_dir preference to true in about:config is the correct solution for your issue in Firefox 102 and above.

Please be careful with all about:config changes. Please read Firefox advanced customization and configuration options to learn more.

Helpful?

I have followed the directions by AliceWyman/Moderator, and Firefox is now responding and handling downloads exactly as it used to.

Thank you very much Alice for your advise and guidance! Works like a charm!!!

Helpful?

ddb6081 said

I have followed the directions by AliceWyman/Moderator, and Firefox is now responding and handling downloads exactly as it used to. Thank you very much Alice for your advise and guidance! Works like a charm!!!

You are welcome! I marked my directions as the solution.

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.