Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Spacebar not working on random sites

  • 1 பதிலளி
  • 4 இந்த பிரச்னைகள் உள்ளது
  • 400 views
  • Last reply by Gilberto A Rivera

Clicking on the spacebar, does not produce a space between words, when typing text. I'm using a Mac Mini M1, on macOS Monterey (V 12.4), along with a Logitech MX Keys for Mac keyboard.

This happens randomly, for instance, on this very message. I previously posted a question regarding another problem that I came across with the same hardware and Firefox.

I found the solution to that problem by disabling an Extension in Firefox, however, I can't begin to think where to look for what setting, that may be causing my current problem.

Clicking on the spacebar, does not produce a space between words, when typing text. I'm using a Mac Mini M1, on macOS Monterey (V 12.4), along with a Logitech MX Keys for Mac keyboard. This happens randomly, for instance, on this very message. I previously posted a question regarding another problem that I came across with the same hardware and Firefox. I found the solution to that problem by disabling an Extension in Firefox, however, I can't begin to think where to look for what setting, that may be causing my current problem.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Well, it seems I've found the culprit, for now...

I went to macOS settings for the keyboard, not the actual settings for the hardware.

In macOS>Keyboard, select the "Shortcut" tab and scroll down to "Keyboard", select it. On the right, a display of shortcuts is shown.

At the very top, I had "Change the way Tab moves focus" checked. I unchecked it and the problem disappeared.

Crossing my fingers and hoping this is the solution.

Read this answer in context 👍 0

All Replies (1)

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Well, it seems I've found the culprit, for now...

I went to macOS settings for the keyboard, not the actual settings for the hardware.

In macOS>Keyboard, select the "Shortcut" tab and scroll down to "Keyboard", select it. On the right, a display of shortcuts is shown.

At the very top, I had "Change the way Tab moves focus" checked. I unchecked it and the problem disappeared.

Crossing my fingers and hoping this is the solution.