Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox hangs on google search V 100.0

  • 6 பதிலளிப்புகள்
  • 2 இந்த பிரச்னைகள் உள்ளது
  • 391 views
  • Last reply by dan.baldewicz

When using built in search (google default) -- browser stops responding. Shows Firefox new tab background when loading the search. Issue resolves on Firefox close and re-open. Paste and go, creating new tabs also fail with same 'new tab background' displayed. Issue is intermittent but appears often, at least 4-5 times a day.

Tested same sample search with google chrome in same time period, no issue.

Issue appeared around the V99 update. Fix would be greatly appreciated - exiting and re-opening browser, dropping all tabs to reload is a serious usability issue.

When using built in search (google default) -- browser stops responding. Shows Firefox new tab background when loading the search. Issue resolves on Firefox close and re-open. Paste and go, creating new tabs also fail with same 'new tab background' displayed. Issue is intermittent but appears often, at least 4-5 times a day. Tested same sample search with google chrome in same time period, no issue. Issue appeared around the V99 update. Fix would be greatly appreciated - exiting and re-opening browser, dropping all tabs to reload is a serious usability issue.
Attached screenshots

தீர்வு தேர்ந்தெடுக்கப்பட்டது

This could be a problem with the TLS 1.3 Early Data feature also known as Zero Round Trip Time Resumption (0rtt). You can try to set security.tls.enable_0rtt_data = false on the about:config page to disable this feature until this is fixed by Google or Mozilla to see if that helps.

See also:

Read this answer in context 👍 1

All Replies (7)

Did you go to the Actual www.google.com website to do the search first.

Dropa மூலமாக திருத்தப்பட்டது

Helpful?

One should try google website to search first to see if there is a problem.

Helpful?

So this issue --- once the tab is stuck / hanging, a new tab will not navigate to google.com, including typing google.com then enter, or copying that address and trying paste + go.

In the attached image --- the reload circle looks like the tab is loaded - for some reason.

I can run the search in another browser like chrome without issue. Image on chrome search successful.

BTW -- I did not find a ticket for this specific issue so far, in the V90-V100 firefox range.

Helpful?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

This could be a problem with the TLS 1.3 Early Data feature also known as Zero Round Trip Time Resumption (0rtt). You can try to set security.tls.enable_0rtt_data = false on the about:config page to disable this feature until this is fixed by Google or Mozilla to see if that helps.

See also:

Helpful?

Much appreciated folks: cor-el's recommendation:

security.tls.enable_0rtt_data = false on the about:config page.

Appears to have resolved this issue. I also noticed some serious Gmail instability when I was having the search issue freezing, so it does seem like these problems are connected and tied to the tls feature.

I'll keep this ticket open for the next 24 hours and will re-up if the issue re-appears, but I assume this config change fixes this problem.

[Ticket + 12 hours] Issue appears to be resolved -- issue has not reappeared.

dan.baldewicz மூலமாக திருத்தப்பட்டது

Helpful?

So if this is correct TLS behavior and not a bug in the Firefox implementation of TLS (Broken on Google webservices end), there should be a TLS enable / disable option.

About:config is not something I think many users will know to dig into, save a few extreme power users.

Feature Request, add check box under advanced settings which: Toggles: security.tls.enable_0rtt_data T/F Description: "Enable TLS [ X ]" Default -- Checked. Checked: security.tls.enable_0rtt_data == T Mouseover: "TLS is a feature which xxxxx. "

This may also apply to Ticket: https://support.mozilla.org/questions/1376015

Helpful?

dan.baldewicz said

When using built in search (google default) -- browser stops responding. Shows Firefox new tab background when loading the search. Issue resolves on Firefox close and re-open. Paste and go, creating new tabs also fail with same 'new tab background' displayed. Issue is intermittent but appears often, at least 4-5 times a day. Tested same sample search with google chrome in same time period, no issue. Issue appeared around the V99 update. Fix would be greatly appreciated - exiting and re-opening browser, dropping all tabs to reload is a serious usability issue.

Thanks for bringing it to attention, i too had this problem and tried everything. It was supper annoying. In my case it was hanging after typing sth in the search bar, not in built in search, but in a new tab, with www.google.com on it. The cor-el fix solved it. I might add i disabled harddware acceleration which didnt fix this, but the browser works a lot better without it, especially the cpu fan doesnt spin like crazy when browsing now. Really strange.

EDIT: The fix didn't work, now i think it might have to do with the windows on screen keyboard which i frequently use.

damazywlodarczyk மூலமாக திருத்தப்பட்டது

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.