Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Need older Firefox version on older MAC.

  • 6 பதிலளிப்புகள்
  • 3 இந்த பிரச்னைகள் உள்ளது
  • 2334 views
  • Last reply by James

I have a 10.11.6 Mac and wonder if I can reinstall Firefox version 65.

I have a 10.11.6 Mac and wonder if I can reinstall Firefox version 65.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

You can find Firefox 78.15.0 en-US DMG file for Mac OS X 10.11 on the Mozilla CDN server on this page:

See also:

Read this answer in context 👍 0

All Replies (6)

This is a forum and not some form of instant chat or ticket system.

Firefox since Fx 79.0 and later including the current Fx 98 and Fx 91 ESR requires Mac OS X 10.12 (ten.twelve) at minimum.

Besides updating your OS to Mac OS X 10.12 (ten.twelve) or later, the most current Firefox version you can install on mac OS 10.11.6 is Fx 78.15.0 ESR though it is EOL with no more updates.

https://support.mozilla.org/en-US/kb/firefox-mac-osx-users-esr

https://www.mozilla.org/firefox/78.0/system-requirements/ https://www.mozilla.org/firefox/79.0/system-requirements/ https://www.mozilla.org/firefox/98.0/system-requirements/

In case you ever need the Firefox 78.15.0esr file. https://archive.mozilla.org/pub/firefox/releases/78.15.0esr/mac/en-US/ other locales at https://archive.mozilla.org/pub/firefox/releases/78.15.0esr/mac/

I'm a little old lady, so i don't seem to understand what is in the links in your reply, @James. i have a very old computer and 10.11.6 is the "latest" version it can use.

Would you please, and simply, direct me to the version of FF that i can use?

sooo much appreciated!! Gramma Lo

I don't see where to ask for replies to be sent to me!

searchless1 மூலமாக திருத்தப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

You can find Firefox 78.15.0 en-US DMG file for Mac OS X 10.11 on the Mozilla CDN server on this page:

See also:

searchless1 said

I'm a little old lady, so i don't seem to understand what is in the links in your reply, @James. i have a very old computer and 10.11.6 is the "latest" version it can use. Would you please, and simply, direct me to the version of FF that i can use?

I gave you the links in bottom part of my reply

James said

In case you ever need the Firefox 78.15.0esr file. https://archive.mozilla.org/pub/firefox/releases/78.15.0esr/mac/en-US/ other locales at https://archive.mozilla.org/pub/firefox/releases/78.15.0esr/mac/