Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Error in 98.0.1! When I click on web link in email, does not open new tab, but goes to last used tab - wrong!

  • 7 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 74 views
  • Last reply by dianerjones

Fix this bug ASAP - I can't get to any new sites on FF 98.0.1 since it updated yesterday! Need to go to the link I clicked in an email in a new tab. URGENT! On a MacBook Pro. Has worked fine for years, til this update yesterday.

    • Please reply to [email removed from public] The email I had to log in under no longer exists! Help! **


/edit: moved thread from Firefox for iOS (iPhone/iPad) to (desktop) Firefox section as you have macOS.

Fix this bug ASAP - I can't get to any new sites on FF 98.0.1 since it updated yesterday! Need to go to the link I clicked in an email in a new tab. URGENT! On a MacBook Pro. Has worked fine for years, til this update yesterday. **Please reply to [email removed from public] The email I had to log in under no longer exists! Help! ** /edit: moved thread from Firefox for iOS (iPhone/iPad) to (desktop) Firefox section as you have macOS.

James மூலமாக திருத்தப்பட்டது

தீர்வு தேர்ந்தெடுக்கப்பட்டது

  • quit and
Read this answer in context 👍 0

All Replies (7)

Hi, is this email a message you are viewing in a Firefox tab, and Firefox opens a link in the message in the same tab? You can use one of the methods to direct the link to a new tab, such as:

  • right-click (one button: Ctrl+click) the link > Open Link in New Tab
  • Command+click the link
  • "middle-click" the link with the mouse scroll wheel or middle button (if any)

If the email message is in a separate program, make sure external links are not set to open in the last active tab, but instead in a new tab in the last active window. Here's how to check that and the related settings:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we have had this setting for a long time, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste neww and pause while the list is filtered

(3) Review/Edit the preference values as follows (double-click the current value to open an editing field, and then when you're done, press Enter or click the blue checkmark to save the change):

(A) browser.link.open_newwindow - for links in Firefox tabs

This is the one that has a checkbox on the Preferences page and determines whether targeted links are allowed to open in a new window or are diverted to a new tab instead; there's no effect on untargeted links:

  • 3 = divert new window to a new tab (default)
  • 2 = allow link to open a new window
  • 1 = force new window into same tab

(B) browser.link.open_newwindow.override.external - for links in other programs

This preference governs external links that open in Firefox:

  • -1 = apply the setting under (A) to external links (default)
  • 3 = open external links in a new tab in the last active window <== if the default doesn't work, try this one
  • 2 = open external links in a new window
  • 1 = open external links in the last active tab replacing the current page

(C) browser.link.open_newwindow.restriction - for links in Firefox tabs

By default, if a page sets width, height, or toolbars for a popup, Firefox will open it in a "dialog-style" window. To force those into a tab as well, you can change this preference to 0. However, I don't think this affects your question.

  • 0 = apply the setting under (A) to ALL new windows (even script windows with limited features)
  • 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default)
  • 1 = override the setting under (A) and always use new windows

To return to normal if things go haywire, there's an arrow-like reset button at the right end of each of those rows if it has a non-default value.

Thanks. I wasn't sure how to get out at end of your nicely detailed instructions. Do I need to restart Firefox? How? On a MacBook Pro.

It's still going to the last tab I used in the window, but not opening the new link; just still showing what was already at that tab! Do I need to restart FF? How?

Oh, I thought the problem was the page getting replaced. It sounds more like Firefox is getting activated but isn't receiving the link to open.

I confess that being a Windows user, I don't know how Mac "default applications" work -- the method used by the system to pass the link over to the default browser. Hopefully a Mac person will have a suggestion.

Thanks for trying! Just discovered when I click a link in Twitter, same problem. Can't get there! Sure restricts your Twitter use.

Any MacBook Pro users out there? HELP!

Mystery! I quite and re-opened FF last night and it didn't seem to help, but today it's suddenly working! I did make your suggested change yesterday, so,...?? Thanks!

தீர்வு தேர்ந்தெடுக்கப்பட்டது

  • quit and