Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Borders of some controls are white instead of none

  • 8 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 76 views
  • Last reply by Terry

I'm on Linux and I have a custom theme that has no borders for inputs & such (picture 1 is an example), however instead of them not appearing on Firefox, they appear white. I'm not gonna change my whole theme just to be able to have a pretty browser in 2022. How can I change these borders (picture 2) while keeping the GTK theme?

I'm on Linux and I have a custom theme that has no borders for inputs & such (picture 1 is an example), however instead of them not appearing on Firefox, they appear white. I'm not gonna change my whole theme just to be able to have a pretty browser in 2022. How can I change these borders (picture 2) while keeping the GTK theme?
Attached screenshots

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Here's the solution for fellow ricers, you're looking for this line of CSS: frame > border, .frame { border: blablabla; }

That's the line affecting Firefox control borders Make sure you're never the guy who commented 3 times on this post with no solution, nobody likes these

Another solution is to dump this browser, uses way too much resources anyway

Read this answer in context 👍 0

All Replies (8)

.....

jonzn4SUSE மூலமாக திருத்தப்பட்டது

jonzn4SUSE said

What distro? Try downloading another copy of Firefox, run it from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Newest Ubuntu, nope, still the same, I think they just don't have "an option" for no border, so it defaults to white YIKES

.....

jonzn4SUSE மூலமாக திருத்தப்பட்டது

jonzn4SUSE said

So it's not a browser issue. Mark it resolved and enjoy.  ;-)

If it wasn't a browser issue - it'd display all of those controls without a border. Instead - it defaults to full 255 border, I'm not gonna enjoy white in 2022, this isn't resolved

.....

jonzn4SUSE மூலமாக திருத்தப்பட்டது

jonzn4SUSE said

LOL Right, it's not resolved. Is it a browser issue or the OS or Desktop Environment? Spin up a VM or live stick to see if you have the same issue.

I don't see what you can't seem to understand in "I have a custom theme that has no borders for inputs & such" Firefox is using the same GTK/system theme, but instead of displaying them without borders, it makes them the ugly default white ones (probably because it doesn't know how to handle border: none or w.e I put in the CSS there). Please stop spamming on here, you've literally said nothing useful in your posts

Brave handles it well, so how exactly is it not a Firefox issue?

தீர்வு தேர்ந்தெடுக்கப்பட்டது

Here's the solution for fellow ricers, you're looking for this line of CSS: frame > border, .frame { border: blablabla; }

That's the line affecting Firefox control borders Make sure you're never the guy who commented 3 times on this post with no solution, nobody likes these

Another solution is to dump this browser, uses way too much resources anyway

My DE provides a means of selecting "no border", yours probably does also.