Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox blank error window, does not start

  • 5 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 53 views
  • Last reply by FredMcD

Hello,

It is not the first time I got that error. I have no idea why.

When I want to start Firefox, this blank window appears (see image). When I click the button or close the window, nothing happens except the window being closed.

I tried to reinstall Firefox, and the autolaucher after the installation opens a Firefox window but, if I close it, I see the error window again when I try to open the program later.

I tried to reset the taskbar's shortcut with the new-one-time-only-working-window-following-the-reinstallation but this did not work.

Please, check for this error. I can not just wait for the program to be ok to run without any logical reason/explanation.

Hello, It is not the first time I got that error. I have no idea why. When I want to start Firefox, this blank window appears (see image). When I click the button or close the window, nothing happens except the window being closed. I tried to reinstall Firefox, and the autolaucher after the installation opens a Firefox window but, if I close it, I see the error window again when I try to open the program later. I tried to reset the taskbar's shortcut with the new-one-time-only-working-window-following-the-reinstallation but this did not work. Please, check for this error. I can not just wait for the program to be ok to run without any logical reason/explanation.
Attached screenshots

தீர்வு தேர்ந்தெடுக்கப்பட்டது

FredMcD said

Use these links to create a new profile. Use this new profile as is. Is the problem still there? https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles Type about:profiles<enter> in the address box.


--== I found a bad? solution at the end of the message ==--

I write down everything I tried in the case I missed something because nothing seems to work.

The CLI firefox -P displays the same error box as before.

Now, even when installing firefox again or restarting the computer, the application does not work (error box my dear friend).

Thus, I am unable to access the profiles.

Since this morning, even Thunderbird displays empty error boxes. Yes, boxes, between 2 to 4 when launching the app. Oddly, the application starts anyway after displaying the boxes (I do not have to click them for the application to start)

I even tried to use the CLI with thunderbird with thunderbird.exe -p but, again, the error box.

I completely emptied %APPDATA%\Mozilla\Firefox\ without any positive result.

I also scanned for viruses but nothing seems to be found.


--== I found a solution after all ==-- Even if I hate that "kind of solution", I finally uninstalled completely firefox and tried to install it with chocolatey (I had the idea to try a windows' app repo lately) and everything seems to be fine since I am currently using it. Curiously, thunderbird stopped displaying the error box since I did that.

Thank you for your help, FredMcD.

Read this answer in context 👍 0

All Replies (5)

As there is no message in the window . . . This could be caused by the text being the same color as the background.

Does this happen only when starting the browser?


Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

FredMcD said

As there is no message in the window . . . This could be caused by the text being the same color as the background.

Well, I cannot select anything with my mouse, like it is really empty.

FredMcD said

Does this happen only when starting the browser?

Yes. The browser usually start at least one time if I remember correclty.

FredMcD said

Start Firefox using Troubleshoot(Safe) Mode {web link} A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

Since Firefox wont open, I cannot launch the troubleshoot mode with the GUI. Launching the app while holding shift also does not work and displays the same error box. I also gave a try with the CLI with firefox -safe-mode but, again, the same error box.

The only way to be able to use Firefox is to restart the computer. But the problem keeps appearing after that.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

FredMcD said

Use these links to create a new profile. Use this new profile as is. Is the problem still there? https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles Type about:profiles<enter> in the address box.


--== I found a bad? solution at the end of the message ==--

I write down everything I tried in the case I missed something because nothing seems to work.

The CLI firefox -P displays the same error box as before.

Now, even when installing firefox again or restarting the computer, the application does not work (error box my dear friend).

Thus, I am unable to access the profiles.

Since this morning, even Thunderbird displays empty error boxes. Yes, boxes, between 2 to 4 when launching the app. Oddly, the application starts anyway after displaying the boxes (I do not have to click them for the application to start)

I even tried to use the CLI with thunderbird with thunderbird.exe -p but, again, the error box.

I completely emptied %APPDATA%\Mozilla\Firefox\ without any positive result.

I also scanned for viruses but nothing seems to be found.


--== I found a solution after all ==-- Even if I hate that "kind of solution", I finally uninstalled completely firefox and tried to install it with chocolatey (I had the idea to try a windows' app repo lately) and everything seems to be fine since I am currently using it. Curiously, thunderbird stopped displaying the error box since I did that.

Thank you for your help, FredMcD.

That was very good work. Well Done.