Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

New Bookmarks In Firefox Have Folder already Allocated.

  • 27 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by OneTrueFriend

When I go to create a new bookmark in firefox I find that the file name is already allocated, and that file name is appearing on all old bookmarks as well. Instead of saying Other Bookmarks it says Location. This is only happening since I moved to Version 95.0 I have had to stop trying to create new bookmarks, and would appreciate any help I can get.

All Replies (20)

Let's start with; If you have sync, and there is a problem anywhere, Shut Down Sync Immediately On All Devices to prevent the problem from spreading. Type<enter> in the address bar. Once the problem is fixed, perform the same repair on all computers/profiles before using sync again.

[v57+] Places Maintenance is built into Firefox.

Type about:support<enter> in the address bar.

You will find Places Database near the bottom. Press the Verify Integrity button.

If any errors are reported:

The places.sqlite file contains your History and Bookmarks. And it looks like it is corrupted.

Type about:support<enter> in the address bar.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the above file. Then rename or delete it. Restart Firefox. The browser should then create a new place.sqlite and recover your bookmarks from the backup files.

Note: Your history is not backed up and will be lost.


Many thanks. I have to say that with my limited knowledge I find the instructions daunting. It seems to be only this laptop that is affected. In creating a new bookmark location should say Other Bookmarks. Instead it shows the most recently used folder number. As this problem has only happened since switching to version 95.0 I wonder would it be possible to roll back to the previous version which was working perfectly?


Current and recent releases have always remembered the last used folder. You can click the Folder line in the Edit This Bookmark dialog to choose a different folder.

The "Edit This Bookmark" dialog that opens if you click the highlighted star has a checkbox with "Show editor when saving" (shortcut key in the dialog is Alt+S). This item is at the bottom just above "Remove Bookmark" and "Done". You can click the highlighted star a second time to open the "Edit This Bookmark" dialog.

See "How do I change the name or location of a bookmark?"

See also this extension:


Thanks. Have been using Boolmarks for years without a problem. Now, In trying to create a new bookmark it says Bookmark Current Tab When I click on that it turns out that the location field is already filled in, as if it was an existing bookmark. But it is a new bookmark with no location yet added and field should read Other Bookmarks. and I should be able to allocate a folder of my choice, not one already allocated.


I would appreciate if someone could tell me how to go back to the previous version of Firefox as the bookmark problems only started with version 95.0. I can move forward again when the next update is released.


Before you begin, create a copy of your current profile and put it somewhere save.

Back up and restore information in Firefox profiles {web link} I use a Legacy add-on that makes backups of my user profile, Just In Case. Unfortunately, it is not compatible with the current Firefox.

Every now and then, open the profile folder and create a copy of the current profile as is to another location on your hard drive. This way you will have a backup.

If you do this each day, you will not lose much data. This should be done with Firefox Closed.

Note: In case you need to restore from these backups, you may need to overwrite old or corrupted files.


Note: With some versions of Firefox, the data files are not backward compatible. If there is an issue, create a new profile and we can tell you how to recover the data.

Step one: How do you completely turn off update checks in Firefox v64? You can use a policies.json file to disable updates for all users. or

You can use a policies.json file in the distribution folder in the Firefox installation folder instead as also listed in the article, so no need to use GPO keys in the Windows Registry. • ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ You can use the ManualAppUpdateOnly policy in Firefox 87+ to enable only manual updates e.g. via "Help -> About Firefox".

Note that it is important to stay up to date and install the latest security patches.


Step two: Note: With some versions of Firefox, the data files are not backward compatible. If there is an issue, create a new profile and we can tell you how to recover the data.

Install Older Version Of Firefox {web link} Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

Note: If you know what version you want, press <Control> (Mac=<Command>) F to open the search bar. Then enter the version number to see the available files.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements


Just wanted to say thank you for taking so much trouble. I really appreciate it. I will investigate all the options and see which way to go, looking for the easiest way as a novice.


Did not do anything over Christmas holiday in case I could not get help. Have now gone with first option. I have got to Profile Folder and Show Folder. Then Close Firefox. Problem is I don't understand from Locate the above file, on. Which file etc. Thank you.


What instruction are you having problems understanding? Go to that message, right-click the time stamp just above it, select Copy Link Location, then Paste it in the reply box.

Helpful? Firefox.n-US/questions/1360695#answer-1465349 It is the last part of this after Close Firefox

OneTrueFriend மூலமாக திருத்தப்பட்டது


It is from Locate the above File, towards the end, that I am having difficulty.


'Locate the above file.'

This refears to the places.sqlite file.

Removing this file should have the browser restore a backup file.


Problem is still there. I exited Firefox. Closed the file. Opened Firefox again. But problem is still there. New bookmarks still opening with folder already allocated.


OneTrueFriend said

I exited Firefox. Closed the file.

FredMcD said

Removing this file should have the browser restore a backup file.


I clicked on the X in the top right hand corner. Does that remove it?


Right-click on the file and delete/remove it.


Places.squilite file, it appears to be. I am sorry, but I overlooked backing up profile.


  1. 1
  2. 2
கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.