Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox cannot run online games but chrome can run games just fine

  • 2 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • 3 views
  • Last reply by official.skylightgaming

Hello, i've recently made the switch from Chrome to Firefox. However, I am someone who enjoys playing games in their browser. And it occured to me, that firefox seemingly lags and stutters whenever i try to play a game.

The two games i have tested are Zombs Royale and Wormax IO. These are two very minimalistic games with nothing much to them. The slowest computers can handle them...

I have a GTX 1080, with 12 gb of rams. I also tested on my laptop, which has unknown specs, but 4gb of ram.

Both devices performed worse then how they would perform in chromium based browsers. I wish to stick with firefox, as i hear security is a virtue with Mozilla, and Chrome really just wants to steal your data.

I might add, that i did follow a couple steps to make my browser more secure, I didn't disable stuff like webgl, but i disabled a bunch of other settings, here is the video i followed:

https://youtu.be/xxWXLlfqNAo

I did install a few add-ons, such as Privacy Badger, uBlock Origin, HTTPS Everywhere, and nightTab(I had this on chrome, and without it i feel home sick.)

I am unsure why these problems occur, as far as i know, my computer should be able to handle this.

I cannot find any other questions related to this, and it is really odd to me. I should also mention, Firefox is also quite slow anyways, it just feels slower than chrome, so i'm unsure if it's an optimization issue or what, but this occurs on all of my computers.

I hope someone can help me thank you.

தீர்வு தேர்ந்தெடுக்கப்பட்டது

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting to make changes effective.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.


You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Read this answer in context 👍 0

All Replies (2)

தீர்வு தேர்ந்தெடுக்கப்பட்டது

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting to make changes effective.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.


You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Helpful?

Thank you!!! My problem wasn't anything but the settings i made in about:config. What i had done was enabled "Resist fingerprinting" and, that seemingly caused my entire browser to lag. My guess is because that also spoofs WebGL, i didn't realize this would happen, fortunately, i didn't have to wipe my profile. So, thank you very much for your help!

Helpful?

கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.