Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google pages fail to load at random intervals

  • 10 பதிலளிப்புகள்
  • 1 இந்த பிரச்சனை உள்ளது
  • Last reply by Joshua

Firefox will randomly stop resolving google search results. At random times, no search entered at the top url bar will resolve. The browser will just change the text in the bar, and then won't do anything else. If there is a Google page already open, it won't load any links from the results. won't even load. This typically lasts about 2-5 minutes.

I've seen this in both Windows and Linux. Linux Builds I've tested were the Flatpak from flathub, the snap, the Fedora Repo, and the Tarball binary. They all had the same result after a while of using it. This also happens on both my home network as well as my work network.

I have cleared my profile by manually deleting the folder in appdata or in ~/.mozilla, and tested with no extensions and no setting tweaks. The only tweak I made is disabling DNS over HTTPS. If I change the default search engine to DuckDuckGo or something else, It no longer happens. but that's because it's not trying to access a google domain.

I have attached a gif of my issue.

Attached screenshots

All Replies (10)

Try to go to about:config, set "network.http.http3.enabled" = false and restart Firefox.


Thanks for the quick response I just made the change. I'll use it throughout the day and report back.

Thank you


It started doing it again. Are there any logs that I can generate to see what is going on?


You can open Web tools (Ctrl + Shift + I) -> Network. But according to your answer, I don't think it's our bug. Google seems to not like us.


I didn't know about the network monitoring in the dev tools. I'll monitor that. I just think it's odd that I wasn't able to find anything about the issue online. If I'm the only one experiencing it, it has to be some config on my end.

I just remembered there was an issue way back with proxy settings. I just updated that. I'll post an update at the end of the day with either log information from the network section, or with confirmation that it is resolved.



The network proxy settings did not fix it.

I think I figured out what the problem is. Rather the cause of the problem. Not the actual problem itself.

The only common factor that I can think would be my google account. I signed out of my google account, and now everything is working fine, and has been since yesterday..

So it looks like there's something going on with that. I'll do some more digging.

Thank you very much for your help

Edit: It did not fix the issue. I spoke too soon

Joshua மூலமாக திருத்தப்பட்டது


Update Again.

I checked the network tab in the dev-tools and Turns out Ublock origin was blocking the site. which is weird because I definitely saw it happen while I was in safemode, but I guess It was some remnant cache somewhere. Either way I think I'm good :)


Nevermind. I lied. The network tab still shows 0 bytes transferred while this happens. BUT if I double-click the entry, a new Browser tab opens and the page loads...


In the network tab. It says Error 301 Moved Permanently.

This just appeared when I tried to go to ""


It happened again. Below is the contents of the generated HAR file.


கேள்வி எழுப்பு

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.